Jump to content

Radeon trouble


roodboy
 Share

Recommended Posts

The default location and filename on a PC for the CM Prefs file is:

C:\PROGRAM FILES\CMBO\Combat Mission Bynd Ovr Prefs

This file holds, primarily, the resolution that CM runs at (possibly some other details that I'm not familiar with).

What kind of problem are you having with the Radeon ? What OS and driver version are you running ?

Link to comment
Share on other sites

I am using Windows 98 with Ati radeon 64mb sdr card driver file version 4.13.7109. It is supposed to be the latest version. I have also updated to Directx 8. MaddMatt is working with me and I am trying to follow his instructions but I am a technical idiot and can't find the prefs file. I had a search run for it and it looks like it is there but I can't open it to erase it.

I also had to manual install the game because it is looking for a cab.3 file which doesn't exst.

I tried to erase the Temp file but there was nothing there.

Anyway, it looks like the CMBO directory is merely a shortcut to open the program because every time I try to open it, the game wants to run and asks for a resolution of 800x600, which I accept and it locks.

I haven't blasted a tank in a week and am getting itchy.

Link to comment
Share on other sites

Don't bother attempting to open and 'erase' the file. Just highlight the filename and delete it. A new file is generated when CMBO doesn't find a previous copy of the prefs file to read.

The Cab.3 issue is due probably to a previous installation (of another software program) that has left temporary files in your TEMP directory. In the Explorer File Manager go to the C:\WINDOWS\TEMP directory and delete everything in there (even if it is an 'executable file' - if that warning pops up). With these files deleted you should be able to run CMBO's installer without problem.

The latest beta driver for the Radeon is 7153 which you can get here:

Rage 3D (in upper right-hand corner - click on the version number for Win9x 4.13.7153):

http://www.rage3d.com

I don't know (and I doubt) that this newer beta will offer anything different or improved over the current version you're running (at least in the case of CM).

Link to comment
Share on other sites

I am a little nervous regarding the whole betea thing. it seems like I have everything so screwed up I want to limit the possible existing problems. I will talk to ATI tomorrow. In the meantime I still can't locate this mysterious prefs file. The CMBO directory appears to be a shortcut to run the game. How do you find this prefs file?

In the spirit of screwing up I completely deleted the whole temp directory even though it was empty and the regular install won't run and now i can't manual install because it won't read the disk. I am going to try to clean it.

I am losing my mind.

Link to comment
Share on other sites

I can only guess that somehow you were running off of the CDROM (which is very possible, since the files on the CD aren't compressed).

If you delete the temp directory's files you should be able to run the CM Installer (and not recieve the "cab file" error).

The 7109 driver you are using IS a BETA driver itself (the current official release is 7075, with a beta 7115 posted on ATI's site). However I don't think that the driver is the issue, unless you have more details about what your initial problem was.

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by Schrullenhaft:

I can only guess that somehow you were running off of the CDROM (which is very possible, since the files on the CD aren't compressed).

<HR></BLOCKQUOTE>

Funny how many people do this, eh Schrullenhaft?

Hopefully BTS will provide an auto-run Install feature with CMBB.

Link to comment
Share on other sites

I actually got the game to run a QB with a small map and 1000pts of material. Next I got greedy and tried to run with a medium map and 2000 pts in a QB. After selecting units and scanning the map, it locked while on an arrow button.

Like any well trained lab rat, I attempted to try agin and got an interesting message-

Unhandled exception: C0000006

At address:0055fa10. What the *#@! is that all about?

Anyway, I'm not sure if I am running off the cd or hard drive although I am under the impression I have performed a manual install because the game absolutely refuses to install without the cab.3 nonsense.

I should mention that it takes a much longer tome to initilize 3d graphics than with my old ATI 16mb rage pro. During this time the light is on on the cd drive which makes me think it is taking info from there and not the hard drive.

If any of this makes any sense please let me know and I will definitely update you on this so nobody else has to endure this particular form of tortutre.

I intend to have a chat with ATI tomorrow.

Thanks for all your help.

Link to comment
Share on other sites

The error you are getting seems to suggest something may be possibly wrong with your DirectX installation. I'd suggest reinstalling DirectX 8.0a and then reinstalling whatever ATI driver you prefer (that is oriented for DirectX 8).

Microsoft DirectX 8.0a:

http://www.microsoft.com/downloads/release.asp?ReleaseID=27741

You can either utilize the latest beta drivers (which usually don't have too many problems - get from the Rage 3D link above) or use one of the official drivers:

ATI Radeon Win9x drivers:

http://support.ati.com/products/pc/radeon/win98/radeon_win98_drivers.html

It sounds like you are running off of the CDROM; however CM will check for the presense of the CM CD for copy-protection purposes. Sorry to repeat this again, but have you deleted all of the files in the C:\WINDOWS\TEMP directory ? When you launch CM are you still using the same shortcut (which most likely points to the CDROM) ?

A Radeon will work with CMBO (I've tried it under Win98SE). There won't be any fog effects (ATI hasn't supported fog-tables in DirectX since the beginning it seems), but other than that it should work.

[ 09-03-2001: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

I downloaded new direct x 8 again and got new driver from ATI 7115. I loaded game it locked and ATI phone support closed before I could talk with them again.

I still think I am making some dopey mistakes because when I look to delete C:\Windows\temp directory it says I have 479 files. Needless to say I am a little nervous about deleting this mauch info. When I look for C:\program files\CMBO\combat mission bynd Ovr prefs file it says it is located in the shortcut.

I'll admit that what I know about computers can be fit on the head of a pin but at this point I am getting really frustrated. It seems like the game should install itself without all this hassle. It sure was easy before I deleted it.

Is there any light you can shed on finding exactly what it is I'm supoposed to delete?

So far flight sims are running OK like Mig Alley and Microsft combat europe and Pacific. So is talon Soft east and West. Please Help! You can see what I have been reduced to playing.

I plan on trying to get off work early tomorrow to speak with ATI again.

Link to comment
Share on other sites

What prompted you to delete CM in the first place ? Has all of this just been the result of upgrading your video card ? Maybe you should go back to your previous video card. It's possible, depending on your motherboard, that it may not support graphics cards will a lot of VRAM on the AGP bus. They require more electrical current than cards with less VRAM. You need to find out from either the motherboard manufacturer or tell us exactly what you have in your system for us to help you. Maybe just a more powerful power supply may do the trick.

If you're really nervous about deleting temp files you can move them to another directory so that the C:\WINDOWS\TEMP directory is completely empty. However I don't know how much of an issue this is anymore since it is just a matter of using the Installer program on the CM CD - and that just pretty much copies files and creates a shortcut.

Your issue is most likely one between the motherboard, the power supply and your Radeon.If CM is locking up for you in Software mode then that would indicate that the problem may be deeper than a video driver issue. It could still be a software issue, but hardware problems can cause this too.

If you still have your old video card, I'd suggest uninstalling the Radeon drivers; removing the Radeon and reinstalling the old card. Once the drivers for the old card are reinstalled (and no other problems crop up), then try CM and see if it still gives you the same problems.

Other than that you may want to consider a clean install of Windows 98 (wiping out or renaming your current Windows directory), but that is an obviously drastic and time-consuming step to take.

If you're truly unknowledgeable about computers you may want to considering having a computer service center look at your problem. However that can be quite costly since many hourly rates are above US$60, with most jobs being billed for more than a single hour.

[ 09-05-2001: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

I just wanted to let you know how this saga finally ended, I hope.

I spoke with ATI downloaded newest non beta driver and went into safe mode and eliminated monitor, standared video driver and went into regular mode and changed refresh to optimal ... and the game still didn't work. ATI said you should have a patch.

After contemplating what I could destroy, I tried to run install again and the drive couldn't find the install program.

I unleashed a string of profantites and tried to install again and the gd thing installed. No cab.3 BS.

Oh happy day there are burning armored vehicles on my screen again!

I believe that this makes no sense at all but i wanted to let you know. Please eliminate this cab.3 crap on CM2.

Thank you for all your help, I really appreciate it.

Link to comment
Share on other sites

For the record, CM does not really use CAB files, it is the SETUP.exe (which is a seperate program) which does and we can't change that, as I mentioned before that error was because of some other program that used the SETUP install progam left too many remnants of itself in your Temp Folder or registery references. That is why it looks for a non existant data3.cab file, since the older program DID utilize that file.

By the way, I am going to look and see if we can upgrade to a newer version of Setup.exe (assuming one exists) for CMBB which may eliminate this issue.

Madmatt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...