Jump to content

CMAK demanding 800x600 res


Recommended Posts

Well, I updated my Ati 9700 pro drivers to the latest DNA4.4.5.10 drivers. AK now tries to start, says it needs at least 800x600 (desktop res is 1024x764) and quits.

Reinstalled vid drivers-no luck

reinstalled direct x 9c-no luck

cleaned registry of old drivers-no luck

reinstalled CMAK-no luck

restored system save to an earlier point-no luck

Anyone got any luck for me?

Link to comment
Share on other sites

From the Start Menu > Run command > type in dxdiag. This will run the DirectX Diagnostic. Once it has fully loaded (progress bar in lower left corner) go to the Display tab and check your settings under the 'DirectX Features' section. You'll want all of them 'enabled' (a 'disable' button is visible for each one that is enabled). Click on the 'Test Direct3D' button and go through the tests. If any of them fails, there is something wrong with your video driver setup.

One other thing to check is your monitor definition (as seen in the Device Manager). If you can find something that is accurate for your monitor (an INF definition from the manufacturer or a Windows provided one), use that. On occasion the 'Default Monitor' profile seems to be problematic for CM when it comes to selecting resolutions (though most monitors will be detected and defined as 'Plug and Play').

Typically CM will go through the resolution selection process when it detects that the desktop resolution has changed, especially (or possibly 'only') if it is lower than what CM is set to run at. The '800x600 resolution' message indicates that you are either running beneath that resolution (which you aren't) or CM can't detect your 3D videocard or its driver support (specifically its DirectX-3D supported resolutions).

It's strange that the System Restore didn't work. Have you played CMAK in awhile since the last Restore Point ? Is the resolution warning message the first thing that comes up when attempting to run CMAK ? If you still had a Prefs file you could delete that (which forces CM to reselect your resolution), but since you've ('cleanly' ?) reinstalled CMAK it probably isn't there. However it CMAK was seeing your videocard/drivers properly it would have displayed other resolutions that would have been visible at some point.

With this error it generally isn't necessary to reinstall CM (though you could reapply the latest patch, which updates/refreshes the executable).

My suggestion is to repeat most of what you've already done. Uninstall the ATI/DNA drivers and clean out the registry of any settings associated with them. Also uninstall any ATI drivers that are sitting in the system (from the Add/Remove Programs control panel). It will probably take a couple of reboots to do all of this. Also remove any ATI-related 3rd party utilities (Rage3D Tweak, etc.). Don't forget to remove the ATI Control Panel (Catalyst Control Panel - CCC) too.

With that done, let Windows boot and redetect your videocard. It may or may not have some Microsoft-generic drivers for it. If Windows prompts you for a driver, DO NOT install one yet.

Assuming that you have DirectX 9.0c redistributable installer, reinstall DirectX 9.0c and reboot as necessary. Now you need to pick which driver to install. For now I'd suggest going with one of the ATI-standard drivers; whichever one you feel most comfortable with (Catalyst 6.1 being the latest). After the reboots necessary for the driver, check your monitor definition again to make sure it is the most appropriate one for your system. Then try out the DXDIAG test again and make sure that it passes all three DirectX version tests. If it does, then attempt CMAK again and see if it will select a resolution now.

Link to comment
Share on other sites

Thank you for taking the time for such a detailed answer. Apparently the first install of the drivers was corrupted. I deleted and reinstalled the drivers, CMAK and cleaned the registry thoroughly. After installing the game for the 2nd time it works. Thanks again for your effort.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...