Jump to content

A problem I have when hosting TCP/IP games . . .


Recommended Posts

When I host a TCP/IP game I get to the screen where it lists your IP address and says that you are waiting for your opponent to connect. Sometimes its a long wait, so Ill window out of CMBB to do something else.

The game will start and sometimes the entire lower control panel of the game is invisible {where all the info is listed and even the 'go' button is gone}. All the buttons still work but you can not see them. BTW, the same thing happened with CMBO.

Has anyone else experienced this problem?

I have a p4 winXP with DSL connection.

Just curious if I am the only one.

Chad

Link to comment
Share on other sites

I know I said I would not read any more of your posts...but I lied!!!

This condition happens quite often when you close your game window while waiting for a TCP/IP connect, I dont know whether or not it has been discussed before...I'm sure it has, somewhere. The best remedy is not to exit the TCP/IP window until your opponent has fully connected. Go grab a beer, or play with the baby while you're waiting, it really doesnt take that long.

[ May 23, 2003, 07:45 AM: Message edited by: Nidan1 ]

Link to comment
Share on other sites

I already posted this to the tech support forum, but hey, maybe this will get more attention here.

---

I went through the old threads concerning TCP/IP -play, but found nothing that was similar to this problem.

Background:

- I have played several TCP/IP battles against this opponent before, experiencing no problems.

- Both have 1.02 CDV version

- I have 512kbps ADSL, opponent has 525kbps cable modem

- My machine was acting as server

- Scenario we played was Pershotraveneve Ridge

Problem:

Everything was going smoothly, until we both hit 'go' after turn 13. After that I saw normal video playback but my opponent froze in the 'completing upload' screen for a while and then received 'connection lost' message. We tried again from the autosave, same problem. So we decided to back up a couple of turns, starting again at turn 11. Strangely when we hit turn 14 -> connection lost.

Has somebody experienced this same problem? Could the scenario be "broken", causing the crash? Amount of data being transferred can't be the problem, since this is a small scenario, we have fought larger ones before.

I have save games of both the original attempt and the re-run on my hard drive. I'm willing to mail them if someone would like to give it a try.

Link to comment
Share on other sites

Yes a simple solution would be to just wait at that screen for the game to start. Why does it never work that way for me? The most common example for me is I get an email while waiting in that screen and . . . is it from that person? Is it that turn I have been waiting for in my PBEM game? I . . . must . . . look! Crash! No dashboard for you today.

I just wanted to see if it only happens on my computer, or if others are having similar problems. Since I am atleast not the only person, have BFC come out with an official say on it? Obviously I can live with it {its not that big of a deal really}, I just wanted to know if BFC was aware of it.

Chad

Link to comment
Share on other sites

Had the same problem with all Nvidia drivers Ive used since I got CMBO. Am pretty much used to it now.

If I do get caught while alt tabbed out I can usually manage set up and a go at turn 1 to make sure it saves opp. units. Then I ask opponent to disconnect and rejoin to remedy it.

Link to comment
Share on other sites

Originally posted by rune:

Again, it is a bug in Microsoft's Directplay, which BFC uses for gameplay. BFC cannot fix MS products. I had talked with Charles directly on this while we were still in Alpha stage.

Rune

Sorry Rune I had missed your original post.

So BFC is aware of it? If there is nothing they can do about it, is there a simple solution on our end of things that you know of?

Thanks

Chad

Link to comment
Share on other sites

Originally posted by 86smopuim:

I have the same problem. Sam e for CMBO.

geforece 2 mmx video.

I only have this problem when CMBB/BO is NOT the focus window at the time that my opponeent connects.

so be sure u are ready when u give your IP to your opponent.

Do switch out to check chat, email, etc.

Be sure your screen saver is set to a long delay.

Problem solved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...