Jump to content

CMMOS Doesn't want to install.


Recommended Posts

Hey gang, I hope there's a Windoze guru amongst you.

I recently purchased a brand spakin' new HP zd7280us laptop, equipped with Windows XP Media Centre Edition, which recently updated itself to SP2.

I also just purchased CMBB "special edition" yesterday.

The game works fine, but CMMOS refuses to install. Clicking on the icon gets me a little "Unpacking" window which unpacks a bunch of stuff, and then vanishes, never to return.

The download of CMMOS V4.03 did the exact same thing.

Trying it on my work computer (also XP, but a slightly older version) worked just fine. I've zipped up the folder it built, and hopefully that'll work.

Anybody know why the installer might be failing?

DG

Link to post
Share on other sites

Not knowing anything about your system, the most common cause of CMMOS failure comes from having CMMOS and Combat Mission installed in the wrong places.

CMMOS expects the target game to be somewhere normal like C:\Program Files\CMBO [change game name as appropriate]. A lot of people try installing it to My Games or some such place, which may not interfere with the running of CM but knocks the wind out of CMMOS.

In a similar way CMMOS itself needs to be somewhere bog-normal, like C:\Program Files\GEM Productions.

Anywhere else will get it confused, knot knowing where it is or where to look for what it is looking for. Has philosophical implications, really....

As for how the program works with newer technology, only Gordon Molek knows for sure.

Your laptop may be confusing the installer. I think Keith Carter (aka Sitzkrieg in this Forum) was the person that Gordon consulted on the installer at one point (then again, I'm probably suffering from delusions and a faulty memory -- it's been a while).

There's also a faint possibility that CMMOS actually installed, you just aren't looking in the right place. Even after the program installs, you have to load it up with rulesets.

Unfortunately I was not involved in the CMBB side of CMMOS so I can't be more specific than that (and as you have probably figured out by now, wasn't involved on the techie side of anything). The mods themselves work a little differently than with CMBO CMMOS. And I suspect its fair to say that, being several years old, CMMOS for CMBB was probably not designed with your system in mind.

Link to post
Share on other sites

I can pretty much guarentee that the installer itself is not functioning correctly on my system. On a correctly-functioning system, the installer "takes over the screen" for a little bit, and on my system, that never happens.

Most install programs unpack the archive into a temp space, then copy the unpacked data from the temp to the final destination. On my system, the first step seems to be happening, but the second never executes, and I can't find the temp space to see if I can trigger it manually.

Bottom line is that the actual CMMOS executable isn't being installed to the point where I'd have the opportunity to piss it off by having it and CMBB in the wrong spots. smile.gif

DG

Link to post
Share on other sites

I wonder what would happen if you ran your laptop in one of the older computer modes (assuming that is an option) and then tried to install. Windows XP wasn't around when CMMOS was designed. Maybe you could fool it into thinking you're installing on a Windows 98 or something.

I'd suggest a cry for help in the Tech Forum. Schrully makes wonderful suggestions, but the person whose input you really need is Gordon Molek (rarely around anymore, sadly) or Keith Carter. Maybe if you mention Sitzkrieg in the title of your thread it will get his attention, but don't tell him I suggested doing that...

Link to post
Share on other sites

Found the problem.

A background program called KBD.EXE was somehow interacting with the installer (and doing much else bad besides) Disabling it allowed the installer to run (and did much else good besides)

So this appears to be a "my system" problem, and not something inherent to the CMBB Special Edition or CMMOS

Incidently, I used a utility called "The Ultimate Troubleshooter" from http://www.answersthatwork.com to diagnose this.

DG

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...