Jump to content

OT- Need desperate help with PG2

Recommended Posts

Yeah yeah I know "Hi Mom" and all that jazz but I have a life and death problem and I assume that many of you have moved on to CM from Panzer General.

This is my problem-I recently won a copy of PG2 from a website contest-but when I try to play it I have a very "laggy mouse-pointer"

It doesnt respond untill almost 1/2 a second after i move the mouse and it makes it very difficult to play the game. Has anyone ever had this problem before? I also notice that some of the explosions cause my comp to bog down-this is a little disconcerting since I have a Pentium 700 with 128mb ram and a 4 year old game shouldnt be able to do that to my computer!

I've tried both patches and cant find a PG forum since Clubssi shut down

Anyone have any ideas?

Link to comment
Share on other sites


I have PG2 and hve the SAME exact problem!

Be fore it was fine on my P3 800 256mb pc133 ram and a GeForce 256.

Anyway, it worked fine UNTIL, I downlaoded NEW drivers from Nvidias site. After I downloaded the new drivers the game started to lag just like you describe.

Mosue responds slowly and the explosions take for EVER.

To me it seems like the new drivers. Not sure what it is within the Video card drivers that is causing this. I messed with the setting continualsy and still nothing. I haven't tried any other drivers, and probably won't until new ones come out. But it is a pain in the ASS!

Link to comment
Share on other sites

HEre is a site that has the latest update (v1.02):


And here is a site that has a buttload og PG2 stuff:


I haven't played it in a couple of years, but it was the best wargame of all time for a solid year after I got it. I still love the graphics and simple, elegant interface.

As for your problem,. on my 233 I never experienced any difficulties at all. It was quick and fine. Hope the update helps. Maybe try re-installing and disabling any 3d pointers or other mouse stuff you have.

Good luck!

Link to comment
Share on other sites

Rommel I think you are right-I think it is probably the new videocards. I dont know where I could find an older computer and I'm sure as hell not going to dink around with my video drivers

I guess we're screwed :(


Willing to trade Pentium III 700Mhz 128Mb RAM 32MB videocard


Pentium 100 32Mb RAM 16Mb video card

Link to comment
Share on other sites

Make sure you have "Wait for vsync" enabled in your video card tweaker utility or in your display properties. The location of the setting varies for each video card, so you'll have to look it up in your documentation.

Link to comment
Share on other sites

Just a quick update for u guys..

I've managed to solve the problem for myself after perusing that link of Rommels.

Here's what I did

First right-click on your desktop and got to Properties->Settings->Advanced->


Under performance there is a bar for the amount of acceleration-it will probably be at full. What I did was reset this to the first notch after none (not none) and now the game works fine! I'm so happy! :D

Thanks for the help guys and hopefully this helps others out.

Ps. You'll have to change it back to full acceleration whenever you want to play games like CM, etc. Yes I know it's a pain but I suppose it's a small price.

Link to comment
Share on other sites

  • Create New...