Jump to content

Issues with graphics


Recommended Posts

I have bought this game on steam. Recently I have changed my graphic card to RTX 3060ti, after I launched the game, the fonts are really ugly and in game icons of troops in pixels too. No improvement in FPS at all, before I was using RX 570. I tried to search for solution in steam forum. Found advice to force windows to use my graphic card instead of integrated. Applied changes in windows, but for me no effect at all. Still seeing those ugly fonts and icons. Also when I use tab+shift to enter steam menu while in game, graphics is ugly there too. No such issues in any other game. Maybe somebody can help with this. Asked this question on steam forum no answer for 3 days.

Link to comment
Share on other sites

Posted (edited)

If you have an Nvidia card you may have FXAA on by default. This anti-aliasing method doesn't work with the game and you get distorted text. Just change the settings for the game/application inside the Nvidia control panel and restart the game.

Fingers crossed that's it.

Edited by Ithikial_AU
Link to comment
Share on other sites

Posted (edited)

You do, it's built into your motherboard, it's probably disabled in your BIOS.

I actually have the 3060ti as well (It was insanely cheap when I got it).

Everything works good for me, so you will get your problem resolved eventually. This issue comes up all the time on the forums. I've never had the issue so I don't know how to fix it.

Good luck

 

 

Edited by Artkin
Link to comment
Share on other sites

On 5/11/2022 at 5:06 PM, Revan said:

I have bought this game on steam. Recently I have changed my graphic card to RTX 3060ti, after I launched the game, the fonts are really ugly and in game icons of troops in pixels too. No improvement in FPS at all, before I was using RX 570. I tried to search for solution in steam forum. Found advice to force windows to use my graphic card instead of integrated. Applied changes in windows, but for me no effect at all. Still seeing those ugly fonts and icons. Also when I use tab+shift to enter steam menu while in game, graphics is ugly there too. No such issues in any other game. Maybe somebody can help with this. Asked this question on steam forum no answer for 3 days.

Other option - download the Geforce/NVIDIA experience and control panel. Update your driver and check your GPU settings using the Geforce control panel.

https://www.nvidia.com/Download/index.aspx?lang=en-us

Link to comment
Share on other sites

Here screenshot of my graphic settings.image.png.d3f7fe3077b6fea137494c403d7ba64e.png

Before posting about the issues, already downloaded latest drivers from NVIDIA website.

Also tried to launch game on two different windows. First time I ran it on my old SSD, now I have new one with new windows the issues is the same.

This issue appeared after I have changed my graphic card.

Link to comment
Share on other sites

3 hours ago, Revan said:

Here screenshot of my graphic settings.image.png.d3f7fe3077b6fea137494c403d7ba64e.png

Before posting about the issues, already downloaded latest drivers from NVIDIA website.

Also tried to launch game on two different windows. First time I ran it on my old SSD, now I have new one with new windows the issues is the same.

This issue appeared after I have changed my graphic card.

Ah cool - latest drivers, grand. Given what you say re running the game does sound like issue is to do with your graphics settings.

So could you confimr:

Are you using the NVidia Control Panel to tweak the settings?

Are you assigning a profile to your CM exe within the NVidia Control Panel to ensure you override any other settings?

If not have you tried doing this?

Cheery!

Link to comment
Share on other sites

@George MC Confirm all of above.

Here is screenshot.  On the top where "Select a program to customize:" I have chosen path to CMSF2. The only changes that I have made so far changed Vertical sync to Adaptive.

 image.thumb.png.d8b146a49088c267898a520491776a98.png

Link to comment
Share on other sites

Grand, couple of other suggestions...

CM uses OpenGL - does changing 'OpenGL rendering GPU' to ensure uses your GPU (RTX3060) make any difference?

Could you confirm you've defo got 'Anti-aliasing FXAA' turned off? 

Link to comment
Share on other sites

Try turning off antialiasing and Vsync in the game options, and then in Nvidia control panel change power management to maximum power, Vsync to not-adaptive, texture filtering negative LOD bias to allow instead of clamp.

Link to comment
Share on other sites

Posted (edited)

Also, since you mentioned recently upgrading GPU, how thorough were you with deleting the old drivers? Since this is going from Radeon to GeForce, there is a higher chance of driver chaos.

One thing to try is make sure all old drivers are removed by running Display Driver Uninstaller and then re-installing the latest Nvidia GeForce drivers.

https://www.wagnardsoft.com/forums/viewtopic.php?t=3992

Edited by ZPB II
Link to comment
Share on other sites

@George MC No worries mate thanks for trying to help.

@ZPB II Regarding drivers I am sure there are no issues since I have install recently new clean windows. I had same issues on old windows also. Also tried your suggestions regarding graphic settings didn't work for me. 

@Ithikial_AU The funniest part about screenshot is that when I make those, all of them looks perfect, but in game something is wrong. I can't understand what the hell is this :)  Also 3d models in games looks good, the only issues are fonts, and troop icons.

Just an example when I try to use steam menu in game shift+tab and try to go back while in graphics settings this is what happens, but graphics look good on screenshot.

Iimage.thumb.jpeg.0fbefc627d831332a268bfe53e1d98b5.jpeg

I have some feeling that this is issues with resolution somehow.

Link to comment
Share on other sites

Posted (edited)

Yeah resolved the issue, it was caused by Scale and Layout option in windows by the default it is set to 125% as recommended. Set it to 100%. And everything looks perfect now.

Just want to thank everybody for your help, If I would be near you, would definitely by everyone a beer.

Cheers everybody.

Edited by Revan
Link to comment
Share on other sites

3 minutes ago, Revan said:

Yeah resolved the issue, it was caused by Scale and Layout option in windows by the default it is set to 125% as recommended. Set it to 100%. And everything looks perfect now.

Just want to thank everybody for you help, If I would be near you would definitely by everyone a beer.

Cheers everybody.

Brilliant - great result :)

Link to comment
Share on other sites

Also wanted to post this piece of advice from steam forum, maybe it will help also somebody in future.

 

"If your Windows scaling is not 100% you can also suffer some blurriness. You can keep your Windows setting at 125% (I do on my 2K monitor) and then tweak the comparability settings for the CM .exe files.

Right click on each .exe and select Properties, go to the Compatibility tab, click on Change DPI Settings and then check "Override high DPI Scaling Behaviour" and set the choice in the combo box to Application.

That will allow the game to run at 100% scaling and the rest of windows to run at whatever you prefer."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...