Jump to content

Recommended Posts

5 minutes ago, Warts 'n' all said:

To be honest, I didn't know that the Bridge Bug had ever gone away. I just thought that it was more prevalent on certain types than others. Or on their alignment on the map.

Maybe you are right. I've just not seen any for a long time, and then suddenly I have trouble with them in two different scenarios in two different games.

One is the first mission in the (old) CMBN campaign "A Bloody Ride".

Another is in a completely new scenario in CMFB: "Mission to Maas".

Link to post
Share on other sites

Now that is very interesting. I got through "A Bloody Ride" without encountering the bridge bug. Whereas, with "Mission to Maas" my first tank met the first bridge, turned sharp right and ended up stuck in the mud. After that I made sure that I saved the game before sending any vehicles across a bridge. I've read lots of stuff on the forum over the years. I don't think anyone has come up with an explanation as to why it happens, and why it has never been fixed. Very frustrating.

Link to post
Share on other sites

I didn't suffer the bridge bug in testing Mission to Maas, but that was well before latest patch.

But I've hit the issue once whilst testing a new CMFB scenario at Trois Ponts with the new patch.

A panther was tele ported on to the top of a railway bridge. Eventually managed to reverse off.

Anecdotes aren't data, but it may be back

Link to post
Share on other sites

yes , it still exist. but its sure is weird as to when it happens.

I have tried to recreate it when it  has occurred and ran the units over the same bridge a ton of times just fine.

Or just went back to a saved point in the battle it has happened in and run right over the bridge with no issues.

 

Where as, back when it was a real common issue. It was pretty consistent  at screwing up when there was a bad bridge.

 

but yes, getting examples and reporting never hurts.

 

Link to post
Share on other sites

My pet theory of why this happens is about waypoints, speed and facing. It is worth noting that it never happens with infantry which is has fixed waypoints on action spots. A bridge is basically a second playing field on top of another. So when the tank tries to move underneath it "slippes through the cracks" and teleport to the bridge or moves across the bridge and starts to "rubber band" or fall through it. This might be caused if waypoints are plotted a certain way, if the tank just marginally changes its facing when moving ahead and the speed migh excacerbate this behaviour. My impression is that it happens more often (and the times I have had it) when the passage is narrow or if there are obstacles on the bridge. Just my two cents.

Edited by rocketman
Link to post
Share on other sites
4 hours ago, Bulletpoint said:

Another is in a completely new scenario in CMFB: "Mission to Maas".

Assuming we're all talking about the same bridge, I had the same problem, but assumed that the bridge was not supposed to take heavy tanks like Tiger 2's.  One can cross the river in certain parts of that river, altho' again I mentioned to the designer that he should make it impossible to do either.  This is an otherwise outstanding scenario.

Link to post
Share on other sites
29 minutes ago, Erwin said:

Assuming we're all talking about the same bridge, I had the same problem, but assumed that the bridge was not supposed to take heavy tanks like Tiger 2's

You're being too charitable, I think. It's a bug.

And it's the bridge on the left side of the map that goes across a railroad. There's another bridge farther on that goes back across the tracks - that one had the same problem, but with halftracks this time.

Link to post
Share on other sites
4 hours ago, Bulletpoint said:

You're being too charitable, I think. It's a bug.

And it's the bridge on the left side of the map that goes across a railroad. There's another bridge farther on that goes back across the tracks - that one had the same problem, but with halftracks this time.

I loaded the scenario up to check.  I have to say that with proper waypoint discipline my German units including KT's had no problems crossing that first bridge over the tracks.  However, the 2nd bridge one encounters after La Gleize station was a big problem.  Not sure if I got any KT's across via the bridge, but I did see vehicles ignore the bridge and try and cross the tracks elsewhere.  Then a couple KT's did get stuck on the bridge and could not be reversed out.  That's why I thought that the bridge may be too light for KT's.  All other vehicles seemed to cross that bridge ok (until the KT's blocked it).  After that they all found a way to cross the tracks nearby.  But, two KT's were stuck there permanently.

I commented to the designer that if the intent was to force the player to use the other roads to the west of La Gleize, it was a good idea to not allow KT's to travel by that route to attack Cheneux and then Stoumont.  However, the KT's can cross the tracks away from the bridges.  I recommended that he make the southern road route more impassable and difficult to "encourage" players to attack west from La Gleize.  The southern route currently seems too easy and fast imo. 

The scenario version I have is v2 dated 2/7/20.  Is there a newer version?

Link to post
Share on other sites

My pet theory based on limited testing is that every patch nerfs a proportion of bridges on any given map.  While I am using Beta stuff at present, I have a scenario that had working bridges, loaded the latest beta build and some of them stopped working.  Once the old ones were deleted and replaced in the new build, they worked fine again.  There is probably more to it than that as this is one of those bugs that seems to completely elude all solutions as has been proven over the years.  Just a theory obviously but based on what has happened over the years and as pointed out by the OP and recalling my recent experience, I think there is possibly a correlation here.

Link to post
Share on other sites
59 minutes ago, Combatintman said:

My pet theory based on limited testing is that every patch nerfs a proportion of bridges on any given map.  While I am using Beta stuff at present, I have a scenario that had working bridges, loaded the latest beta build and some of them stopped working.  Once the old ones were deleted and replaced in the new build, they worked fine again.  There is probably more to it than that as this is one of those bugs that seems to completely elude all solutions as has been proven over the years.  Just a theory obviously but based on what has happened over the years and as pointed out by the OP and recalling my recent experience, I think there is possibly a correlation here.

That is a interesting observation - so if someone would take the scenario in question and replace the bridge, then try it. it would be interesting to see if there is a noticeable change. 

Link to post
Share on other sites

Total guess on my part about what's causing that bug, we know there are restrictions to tanks on bridges do to types of bridges, maybe the engine gets confused about what kind of bridge it is and makes a decision saying "nope can't move, I'm not the right type of bridge".

Link to post
Share on other sites

Another guess - what if the bug has something to do with the engine rendering the tank moving on/under the bridge and gets "confused" about where it is supposed to go. So my question is - has anyone had the bug happen when not having the camera on the bridge?

I might set up an extensive test in the editor. I have a scenario project on hold because of this bug and really want to see it squashed once and for all.

Link to post
Share on other sites
3 hours ago, Bulletpoint said:

I always have good waypoint discipline with bridges by the way. One waypoint immediately before, one immediately after.

My experience is that one has to line up the vehicle so it is oriented directly and perfectly towards the bridge.  Try using 2 or 3 very short waypoints before the bridge to ensure the vehicle is facing exactly he right direction, then a waypoint in the center of the bridge.  Have very rarely encountered any bridge problems in any scenario.  

Link to post
Share on other sites
32 minutes ago, Erwin said:

My experience is that one has to line up the vehicle so it is oriented directly and perfectly towards the bridge.  Try using 2 or 3 very short waypoints before the bridge to ensure the vehicle is facing exactly he right direction, then a waypoint in the center of the bridge.  Have very rarely encountered any bridge problems in any scenario.  

But you're having bridge problems in this scenario even with this method? In "A Bloody Ride", I backed the tank off the bridge and tried again and again, with various combinations of waypoints and speed settings. Could not make it cross.

Link to post
Share on other sites

As I mentioned in my previous e-mail I had NO problems with the first bridge that is being discussed here.  However, I always use multiple very short waypoints when crossing any bridge. 

The 2nd bridge (beyond La Gleize station) was a problem for the KT's.  But, I figured that the 2nd bridge may have been too light for heavy tanks.

Link to post
Share on other sites
  • 3 weeks later...

I have started to make an extensive test in the editor that I will post more on in the coming week or so. My intention is to get a group of volunteers to try my test and document weird bridge interaction and bugs. Then we might get to the bottom of this problem once and for all. The test is made in FB and will have one version for US vehicles and one for German.

Link to post
Share on other sites

Why would I?

 

"Leave the bug tracking to BFC.  Perhaps if you get invited to the Beta team some day then you can participate in all the bug tracking and reporting that you would ever want, but for now just go and play the game and enjoy yourself.  "

https://community.battlefront.com/topic/137625-battlefront-should-implement-a-publically-viewable-bug-tracking-site/?tab=comments#comment-1833962

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...