Jump to content

GETTING CM TO RUN IN WIN 10 (UPDATED)


Erwin
 Share

Recommended Posts

Thought it might be helpful to list all suggestions here so there is a checklist anyone can go through when they encounter problems trying to get CM2 to run on Win 10 machines.  It's probably something helpful that Tech Support should have ready to give out to all.  Or, have it as a sticky.

1)  Try to "Run as Administrator".

2)  Check what graphics card is being used:

"Open up nVidia control panel.  You will have to go to the 3D settings and you can set default GPU from the drop down.  If you only have the nVidia GPU, you won't see any other option.  That means you can eliminate this as an issue.  When I get a new laptop, its the process I have to go through every time.  It has nothing to do with Win10.  If you feel brave, can create a custom profile for each application or game and choose the GPU for each.  For some reason, the CM games always default to the Intel GPU that is part of the Intel chipset.  

If you have a laptop,  you most likely have both GPUs.  If its a desktop, its depends on how the system was built.  You can also google how to set your default chipset."

3)  The problem may be Windows Defender.  Try disabling it.  You can temporarily disable it with these instructions.  

Choose Option One: To Turn Off Windows Defender Real-time Protection in Windows Security

  • Option Two: To Turn On Windows Defender Real-time Protection in Windows Security
  • Option Three: To Turn On or Off Windows Defender Real-time Protection in PowerShell
  • Option Four: To Turn On or Off Windows Defender Real-time Protection in Command Prompt
  • Option Five: To Enable or Disable Windows Defender Real-time Protection in Group Policy
  • Option Six: To Enable or Disable Windows Defender Real-time Protection using a REG file

4)  If that doesn't work, try loading a 3rd party security like AVG or AVAST (they are now made by the same company).  This will automatically disable Win Defender.

5)  Check Task manager to see what if anything is running.

6)  Try Microsoft's Process Explorer which can give you a few more details than Task Manager can about what is running on your system. When you extract this program (it doesn't do an 'install') run the 'procexp64.exe' and that will bring up the Process Explorer. With this you can launch it (instead of Task Manager) and then before launching CMFB, go to File > Save as and type a new name for the text file that will be saved. This will default to Process Explorer's directory and you can copy and paste that text up here and we can examine it for what may be running.

6)  Check the "Controlled folder access".  To navigate to it, type Defender into the search bar, click windows security, scroll down to ransomware protection, click manage ransomware protection, then disable controlled folder access. 

Link to comment
Share on other sites

I also found that if I turn on "Controlled folder Access" under Ransomware protection in Windows Defender to on, you get this warning when trying to run CM:

image.png.1252f391577211daa494551580f5f465.png

By default that protection should be off in Windows Defender.  But some high security and/or privacy settings turn it on.  When turn the protection off, the issue goes away.

Link to comment
Share on other sites

I installed AVG and put CMFB on its excluded list so the game should run, but, nothing improved.  The game seems to start for a fraction of a second and then disappears.  

Where do you find this page (seen above) for turning off Ransomware Protection?

Using instructions:  https://kb.acronis.com/content/62142    I don't see any "Ransomware Protection" option.  I disabled AVG temporarily in the hope that brings back Defender and I would see the same screen as is shown in the link.  But, I do not see the same screen when I click on "Virus and threat protection".

 

Edited by Erwin
Link to comment
Share on other sites

Erwin:

I just installed CMFI on a Windows 10 v1909 machine new in March.

The two slight glitches I experienced were

Defender Smartscreen. It blocked the app from installing until I found the Run Anyway button. After that it installed everything just fine. And activation went flawlessly.

When I tried to launch the game it seemed to start but then went to desktop.

DPI settings. I had to override High DPI  scaling settings and let the application do it. Right click the start icon and then hit properties, click compatibility, and then Change high DPI settings. Then check the box next to Override high DPI setting and set the  box below that to application.  OK and then Apply.

It worked for me. Hope this might help with your machine.

 

Link to comment
Share on other sites

Doubt this is the problem as I was told that my CM2 activations worked fine.  Have assumed that meant that the installs were good.  However, where is the Defender "Run Anyway" button?

Thanks for the DPI idea.  However...  On the Win 10 machine one right clicks on START icon at the bottom left?  When I do that I do not see "Properties".  But then again have been using a Win 7 shell on the Win 10 machine since am more familiar with Win 7.  Am wondering if that affects things altho' am told it should not.  Is there another way to get to "Properties"?

This is not an nVidia control item, right?

Link to comment
Share on other sites

37 minutes ago, Erwin said:

  However, where is the Defender "Run Anyway" button?

 

depending on your settings, you will see a blue box with a big "Don't Run" on it appear when you try to instal.  There should also be a smaller clickable text with "more info", clicking on that will make the "Run Anyway" button appear.

you also need to check the setting in "Windows Defender" for "App and browser control". Make sure that the setting for installing unrecognized apps (i.e. "check apps and files") is set to "off" or "warn". If set to "block", Win 10 will not give you the option to run it anyway.

Edited by Sgt Joch
Link to comment
Share on other sites

26 minutes ago, Sgt Joch said:

depending on your settings, you will see a blue box with a big "Don't Run" on it appear when you try to instal.  There should also be a smaller clickable text with "more info", clicking on that will make the "Run Anyway" button appear.

ok.  I never saw that warning.  So installs should be ok.

27 minutes ago, Sgt Joch said:

check the setting in "Windows Defender" for "App and browser control".

This what I cannot locate - possibly cos I have a Win 7 shell(?)  How to locate?  

Thanks...

Link to comment
Share on other sites

Lots of things can prevent CM from running correctly,  I think you've focused too much on security features. If SmartScreen was preventing the game from running it would prompt you about it with a large popup.

 

A couple years ago I discovered that the Asus Realtek control software prevented CM from running unless CM was launched through a 3rd party shell like Steam, which is weird as ****, but whatever. Try disabling every application in your system tray that isn't critical for your system's operation and launching CM. If it works, then use the process of elimination to track down what it could be. 

 

Also, AVG sucks. I highly recommend going back to Windows Defender. It does all you need without the extra bull**** that will cause more problems.

Link to comment
Share on other sites

Yes, have uninstalled AVG.  Was testing the suggestion that AVG would disable Defender, but it didn't help. 

The other question is whether one needs to re-install a CM2 game after every change one makes.  Right now, am making the suggested changes and then seeing if the existing install works.

I use nVidia and Intel btw.

Link to comment
Share on other sites

You shouldn't need to reinstall CM2 after making changes unless they are large scale hardware changes. Also, if you game needs to be activated, I believe it will tell you.

Again, you should try to shutdown all non-essential software running on your PC to try and launch CM. Your Windows 7 shell could be the trouble, or any other combination of software. 

Link to comment
Share on other sites

You need to go to the task manager,  then "details" Tab, find CMBB there, right click for the context menu and then go to the 5th item ("Zugehörigkeit" in German, just below "Priority". Probably "Affinity" on an English Win 10 version?).

There you can find the option "all processors", "CPU 0", "CPU1", ... (pic below, but in German)

You need to run CMBB on only one CPU. Typically CPU 0 und CPU 1 worked for me.

grafik.png.bc1136a32da12a6a591cdb3dce7ea758.png

The map editor takes ages to open, as does shifting the map or switiching to "sezup zones". But it worked.

 

I bough a cheap version on GOG.com, they are specialists in getting to run "old" games - that saves me that hassle now.  But the map editor is still so slow.Currently EUR 5.49 (that's 6$) . Sometimes with a rebate....

kind regards

Joachim

 

 

Link to comment
Share on other sites

3 hours ago, SgtHatred said:

Joachim's solution is only for Combat Mission : Barbarossa to Berlin.

Ok.  So far I only installed CMBS and CMFB as they had the fewest if any modules - so easier to uninstall and reinstall if needed.  if those will run, so should the other titles.  

 

On 7/22/2020 at 2:04 PM, SgtHatred said:

you should try to shutdown all non-essential software running on your PC to try and launch CM. 

Makes sense.  But, not entirely sure what is "non-essential". 

What is disturbing (and depressing) is that my IT guy (who was not doing me a favor but who I employed for a couple hundred $), also couldn't figure it out, and blames the old CM engine.  When a pro can't get CM2 running one really wonders how amateur gamers have any chance.

Link to comment
Share on other sites

1 minute ago, Erwin said:

 

Makes sense.  But, not entirely sure what is "non-essential". 

 

Almost everything is non-essential. Open your system tray at the bottom right of Windows and right click all the icons you see and select Close or Exit for all of them. Some you won't be able to close and that's OK. If anything suddenly goes awry a reboot will fix any problems. Especially try closing anything relating to sound or RealTek in the name, as that has had trouble with CM2 titles in the past. 

You won't harm anything by shutting down running software on your system, worst case scenario is that you need to reboot because you disabled something important.

 

6 minutes ago, Erwin said:

What is disturbing (and depressing) is that my IT guy (who was not doing me a favor but who I employed for a couple hundred $), also couldn't figure it out, and blames the old CM engine.  When a pro can't get CM2 running one really wonders how amateur gamers have any chance.

Your IT guy isn't necessarily wrong, CM has a lot of jank to it that comes from being custom built by a small team who only sorta knew what they were doing when they started. Hardly unique in games though, and there are professionally built games by big developers who have worse issues on modern hardware.

 

But I wouldn't put a whole lot of stock into what this "IT guy" says. My experience with desktop support "professionals" is that their skills usually lean more towards conman than technical. 

 

Seriously though, click the ^ symbol on the bottom right of your Windows task bar, look at all the application icons in the box that appears, right click and close as many of them as you can and see if CM runs then. If anything wonky happens just restart the PC.

Link to comment
Share on other sites

I have a virgin system with only Skype and a CM2 game installed...  so (unless am misunderstanding and looking in the wrong place) I see virtually nothing, not even a ^ symbol .  All I see are icons for nVidia settings, Skype, Windows Security and my Network access.

Link to comment
Share on other sites

Could be that your Windows 7 shell is obscuring it. Could also be the source of the problem. You really should consider eliminating the shell, Windows 10 isn't very different.

 

For what it is worth, when I had this problem it was software from the motherboard manufacturer, so it would be expected even on a "virgin" system.

 

You could go into Task Manager > Start up and disable anything extra, reboot and try again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...