Jump to content

Half Quick Battle Enemy Units Won't Move


Recommended Posts

Playing CMFB 4.0. A little background first.  Like to make my own tiny and small maps from large and huge maps so I have more map options in QBs. I do this by putting the map file in another folder I call Working Maps.  I then remove all terrain/unit objectives, parameters, setup zones, units selected (if any). For the AI, of the 5 plans I will make 2-5 Not Used and plan-1 Used Frequently. Within plan-1 I will go through groups 1-16 and remove all orders and setup from map then remove all supporting fires. I then save the map with "*-Clean" so I know I've cleaned it up. This basically gives me a clean map that I can modify.

When I mod a map I will cut it down to a portion of the battle field I want to use. Since I like to keep it simple I will then assign 1-2 allied/axis terrain objectives, setup zone for each side, select which direction is friendly for allied/axis.  For the AI, I don't bother with the allied since I almost always play allied but for axis I will use only plan-1 and only group-1 and set an intermediate point for them to move to using order1 and the final objective oriented movement using order2. I'll then run a quick battle using the scenario author test skill level so I can see what's happening.

This works fine most times but occasionally I will have 1/3 to 1/2 of the axis forces just sit there in the setup zone for the whole battle. I only use Plan1 with the other plans set to Not Used and it is my understanding that unless you indicate otherwise, quick battle will put all your AI forces into group1. There has been a time or two when some forces didn't move because AI set vehicles up in a wooded area that they could not move out of but I usually try and config my setups so that this won't happen.

Any ideas what I may be overlooking here? When this has happened I have gone back to scenario editor and looked for any legacy, not-deleted setups, terrain objs, parameters, groups with movement orders not-deleted but I usually can't find anything that explains this strange behavior.

Link to comment
Share on other sites

Oh yeah - the yellow setup area is usually same size as the setup zone I make in the Map menu. But now it occurs to me that you are asking about the size of the areas associated with Order 2, Order 3, etc., (i.e. not where I first set the units up but where they are moving to).  Is that correct?

Edited by glilley
Link to comment
Share on other sites

AI plan 1 is not a plan for AI Group 1 alone, it would typically contain orders for several AI Groups.

Did you cut the map down before removing the AI Plans/Orders? 

Is it possible that the units are attempting to reach painted zones that were present on the full map but which have been trimmed out of your reduced version? 

In my experience the game seems to 'remember' all the various zones of the full map, so I always remove all the AI & Objective related stuff before cutting the map down.

FWIW

Edited by Sgt.Squarehead
Link to comment
Share on other sites

If you want to post the file to DB or similar I'd be happy to take a look.

Probably a silly question, but you have left in the AI scripts for the correct side?  You have no idea how many times I've stared in dismay at non-moving AI units, only to realize I'd been writing the Red AI in Blue's slots (or vice-versa)!  ;)

Edited by Sgt.Squarehead
Link to comment
Share on other sites

SOLVED!!

Alas (sigh), Sgt. Squarehead when I went back and looked at my Huge supposedly clean map that I cut down I found group15 still had movement orders still painted. Weird thing is that group 13, 14 and 16 had no orders, so when I got to 13 & 14 when I was cleaning up first time, I quit looking.  Probably have this same issue with the few other maps that have this problem, so it means I'll have to click through all 16 groups just in case!

Deleted my small map and made a new one from my "now" clean huge map and after doing the required work (setup zones, objectives, plan/orders) ALL the Axis folks move off smartly like they are supposed to do.  Sorry for false alarm!

Link to comment
Share on other sites

An easy way to delete movement orders from everything is to select a blank AI orders plan from the list and 'control-C' copy. Then you select the AI orders plan you want to get rid of and  'control-V' paste. It will overwrite the order plan with the blank set you had copied. Much less work than going in and deleting all the group movement orders.

Link to comment
Share on other sites

18 hours ago, MikeyD said:

An easy way to delete movement orders from everything is to select a blank AI orders plan from the list and 'control-C' copy. Then you select the AI orders plan you want to get rid of and  'control-V' paste. It will overwrite the order plan with the blank set you had copied. Much less work than going in and deleting all the group movement orders.

+1  NOW you tell us............ :D 

Link to comment
Share on other sites

20 hours ago, MikeyD said:

An easy way to delete movement orders from everything is to select a blank AI orders plan from the list and 'control-C' copy. Then you select the AI orders plan you want to get rid of and  'control-V' paste. It will overwrite the order plan with the blank set you had copied. Much less work than going in and deleting all the group movement orders.

Quote

"I think MikeyD has a Point"

D'oh!  :wacko:

Why didn't I think of that?  :rolleyes:

Edited by Sgt.Squarehead
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...