Jump to content

New issue in 4.02? Troops reluctant to fire on spotted enemies


Recommended Posts

Since 4.02, I'm seeing several cases of my troops deciding to not open fire on enemy troops, even though they are actively spotted and within range.

In the beginning, I thought it might be a case of the targets being out of range, but while designing a new scenario, I'm definitely seeing several cases of infantry not shooting at enemies in forests at 80m range, and armoured cars not firing on infantry at the range of some hundred metres.

The funny thing is that I can manually order them to fire, and then they start shooting. So they definitely have LOS and LOF. They just decide not to use it.

Has the TacAI targeting logic been tweaked recently?

Anyone else seeing the same thing?

If there's interest, I can of course provide save games, but I wanted to hear if it's something other people have noticed.

I'm posting this in the general forum, because I think it might be a fundamental thing with 4.02, but I'm seeing the behaviour in CMFB.

Link to post
Share on other sites
17 minutes ago, Frenchy56 said:

Were they being shot at? I'm trying to tell if the AI actually imitates human behavior or if it's just stupid.

Nope, not being shot at at all. Just sitting there, looking at the enemy.

With infantry, I think it might happen especially if you have a squad that's not split, and then one team spots an enemy, but the other team doesn't. I still think it makes more sense for the team to start shooting, even if not everybody can join in.

But it also happens with vehicles.

Link to post
Share on other sites
3 minutes ago, RockinHarry said:

what´s the other variables btw? Soft factors, incl. leader ability and ammo at hand?

I thought it might be a soft factor thing, but I've seen it happen both with "good" and "bad" quality troops, negative and postive leadership/motivation, etc. But haven't done any proper testing - I simply don't have time for that. So to begin with, I just wanted to hear if other people have noticed the same.

Edited by Bulletpoint
Link to post
Share on other sites
2 minutes ago, Bulletpoint said:

I thought it might be a soft factor thing, but I've seen it happen both with "good" and "bad" quality troops, negative and postive leadership/motivation, etc. But haven't done any proper testing - I simply don't have time for that. So to begin with, I just wanted to hear if other people have noticed the same.

okay thanks. I´ll do a check next time I launch up a game. Thus far haven´t experienced anything like this that can´t be possibly explained by any the variables involved. Also worth to consider is FOW and game difficulty setting maybe. 

Link to post
Share on other sites
15 minutes ago, RockinHarry said:

I´ll do a check next time I launch up a game. Thus far haven´t experienced anything like this that can´t be possibly explained by any the variables involved. Also worth to consider is FOW and game difficulty setting maybe. 

Yes there are many different factors that could be affecting this. I just started to notice something seems different from what it used to be, and I've been playing for years. Thanks for letting me know if you find something similar.

Link to post
Share on other sites

I've done some tests on this and I have savegames if anyone's interested.

Armoured cars often won't shoot even when having a good LOS/LOF to a good target (enemy infantry). I don't know why they don't. Interestingly, it seems it also works in reverse - the enemy teams in the forest won't shoot at the unbuttoned AC commander.

 

Infantry often won't shoot in dense terrain. I have an idea why this happens:

The infantry squad is not split. It consists of two teams. The squad has a solid spot and a grey target line to an enemy team 80m away.

 

Here's the interesting bit: The infantry squad will not open fire on its own. BUT if I select "combine squad", the LMG gunner immediately opens fire.

So there is some kind of issue or bug at work here. A "hand brake" that keeps squads from reacting to contacts if they are not split and if only part of the squad spots the enemy.

Edited by Bulletpoint
Link to post
Share on other sites
16 hours ago, lsailer said:

I'm just a noob here.  But my take is, in life, other people often don't do what you think they should.  So it is in CM.

Welcome, and thanks for replying to my thread.

It's definitely one of the good parts of the game that there is some uncertainty about how troops will react in different situations. I think we all agree on that.

However, when troops consistently refuse to shoot in certain situations, but immediately start shooting once I push a button to split or combine the squad, I think it's probably not a simulation of human behaviour, but an issue with the game code.

I've been doing some more testing, and it mostly seems to affect squads with two teams and a small headcount - German recon units in this case.

Is this important enough to look into? I don't know. I just bring it here in order to help improve the game.

Link to post
Share on other sites
  • 3 weeks later...

I have seen something which may or may not be related. Sometimes I get a spotted marker on an enemy unit. Then, during the command phase I click on it to see who among my own units is spotting the enemy. If I go to my own unit to give it a fire command, I get the message that there is no LOS. It's not a case of a grey line, it's no LOS/LOF whatsoever. I don't know what to make of this to me very puzzling situation. As I say, I don't know if it has any connection to what Bulletpoint is reporting or not. Furthermore, I can't say if it is a bug or simply something that turns up now and then that the designers decided to leave in. It doesn't strike me as something that real life soldiers would never do, which is why I never brought it up before.

Michael

Link to post
Share on other sites
1 hour ago, Ales Dvorak said:
On 9/3/2019 at 10:11 AM, Bulletpoint said:

I'm definitely seeing several cases of infantry not shooting at enemies in forests at 80m range, and armoured cars not firing on infantry at the range of some hundred metres.

I'm not an expert, but would you open fire at 80 or 100m in dense forest?

No, I would just drink tea with the Germans until they got tired of their picnic and went home. But then again I am a quite peaceful guy in real life.

Link to post
Share on other sites
1 hour ago, Michael Emrys said:

I have seen something which may or may not be related. Sometimes I get a spotted marker on an enemy unit. Then, during the command phase I click on it to see who among my own units is spotting the enemy. If I go to my own unit to give it a fire command, I get the message that there is no LOS. It's not a case of a grey line, it's no LOS/LOF whatsoever. I don't know what to make of this to me very puzzling situation. As I say, I don't know if it has any connection to what Bulletpoint is reporting or not. Furthermore, I can't say if it is a bug or simply something that turns up now and then that the designers decided to leave in. It doesn't strike me as something that real life soldiers would never do, which is why I never brought it up before.

 

My situation is different - when I check, there is a blue target line, and I can manually order my unit to fire. But they don't shoot on their own. I'm thinking this behaviour is something new - I don't recall ever seeing it in version 3.12.

Link to post
Share on other sites

As I recall, there have been posts about this over the years. Units do not automatically start firing when they spot an enemy, it depends on range, LOS, type of unit, how much ammo they have, etc. Don't forget that when a unit starts firing, it becomes a lot easier to spot by the enemy. I have been playing a lot of CMBN and CMSF2 lately and have not noticed anything wrong, just isolated instances of reluctance to fire.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...