Jump to content

Recommended Posts

  • Replies 401
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

The Quick Battle Maps are very well along.  No QB Map shipped in CMSF2 is an untouched hold over from CMSF1.  And there are a LOT OF THEM

Update greatly appreciated. I'm firmly in the "I have so much CM to keep me busy, release dates don't matter" but I will gladly hoover up all the new stuff as you finish it. 😉

CMSF 2 Upgrade "Big Bundle" ... Purchased, Download, Installed, Follow instructions to Activate and Get Some 😀!  Seamless....👍 another Happy Holidays from Battlefront.  Thank you Battl

Posted Images

56 minutes ago, zuf said:

How much time should it take to get the confirmation e-mail? I've just bought the big bundle upgrade around 20 mins ago and no confirmation e-mail arrived...

Confirmation emails are sent right away.  The most common problem is people making a typo in their account information or their account is linked to an old email address.  I advise going into your store account and verifying where the email was sent to.

4 minutes ago, Rigg said:

Yeah, I thought so too, but then game show me this 

 

Odd.  We're taking a look into that because I can't think of any reason you'd be seeing Semper Fi grayed out like that.

Steve

Link to post
Share on other sites
Just now, waffelmann said:

What issue do you have?

 

In my case I could not solve the issue myself. The official support has to intervene. But they made it quick and simple!

The same as you, or so I understood; my game refuses to launch after activating my products. The Marines Module is supposed to include the base game.

sf2.PNG?width=643&height=496

Link to post
Share on other sites
2 hours ago, Battlefront.com said:

Try launching the game again with Activate New Products and put in your CMSF1 Bundle license key.

Steve

I've downloaded and installed the PC version of the Big Bundle about four times now into both the C:drive, and my SSD (not at the same time). When I double-click the shortcuts for the application and the additional licenses, and the actual App, nothing happens. I don't even get the licensing screen. Nothing; Nada. I uninstalled each time and tried downloading again. Fortunately, it works fine on my Mac. Should I be submitting a ticket?

Link to post
Share on other sites
Just now, se_poika said:

I bought the SF + Marines bundle and all I had was one key.

Same. You didn't need any other key before other than the CMSF1 Big Bundle Key. The old procedure was install Paradox CD, add Paradox version patches, install Big Bundle with all modules, patch to latest version then activate single Big Bundle key and it all worked. I've never had a CMSF 1.21 key and never needed one.

Link to post
Share on other sites
1 hour ago, altersack said:

Same Problem here, support works on the Problem in my case...

When you get the licensing screen, cut and paste the license Number from your e-mail (just do a copy in your e-mail and click on paste in the licensing screen) then double-click on your "Activate New Product" shortcut, go to your account orders, copy the license number for "Marines" module, and past it into your Activation window. you don't need a "Base CMSF" number if you have Marines.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...