Jump to content

Problem reinstalling CMSF in Win8.1

Recommended Posts

I tried this out (installing CMSF and modules under Windows 8.1) and this is what I did:

1. Followed the Knowledgebase article on I need to reinstall CMSF and one (or more) modules. How do I do that ?

2. I disabled my anti-virus (Avast) and then ran the base CMSF installer (v. 1.11). The anti-virus remains disabled throughout the entire install and licensing process.

3. I installed the Marines module (v. 1.11).

4. Ran CMSF, but it would NOT run until I right-clicked on it and selected "Run as administrator" from the popup menu.

5. This brought up the licensing dialog box for the Marines module. The activation was successful (both the base game and the Marines module are now activated).

6. I ran CMSF (did not necessarily need to use 'Run as administrator', but probably did). The game ran and the Marines module showed up. The game was at version 1.11.

7. Installed the British Forces module.

8. Ran CMSF (again with a 'Run as administrator' option) and licensed the British Forces module.

9. Ran CMSF and both Marines and British Forces module appeared (game at version 1.20 now).

10. Installed the 1.21a patch. The default selection was for the base game and both modules (top one).

11. Ran CMSF and it was now at version 1.21 and both modules were present.

12. Installed NATO module.

13. Ran CMSF (again, with 'Run as administrator') and all three modules appeared and the game was now at version 1.30.

I didn't get to finish, but the 1.31 and 1.32 patches would need to be installed to get CMSF fully up-to-date. You need to make the correct selections with each patch to make sure that all of the modules are getting patched. If you make an incorrect selection, then you either get prompted for a license key for a module that you don't have or one or more modules disappear. If this happens, then just re-run the patch and make sure to make the correct selection.

CMSF uses eLicense as its copy-protection system. During the license activation process a few files are downloaded and installed to run the license service. Prominently this is the 'Runservice.exe' file that gets copied to the 'C:\Windows' directory and gets installed as a service. It is possible that if security software is running during the initial license activation process that this installation might get interfered with, preventing CMSF from running. The Knowledgebase article Missing or not working Runservice.exe file mentions that the Helpdesk can send you the files if they are not present. However there are registry settings that may not be in place to allow it to function properly (if licensing got interfered with by security software).

In the past DEP (Data Execution Prevention) needed to be set for the game executables and the Runservice.exe eLicense service file. I did NOT need to do that with my installation, but it is possible that some installations may need to do this. The Knowledgebase article When I launch the game nothing at all happens ! (or I get a 0xc0000005 error) deals with making the DEP settings that might be necessary for some users.

Another Knowledgebase article that MIGHT be applicable mentions 'BEX' Problem Event: BEX. This involves permissions on the 'elicen40.dll', which MIGHT be the issue behind the error you reported of 0x0000142

Doing a google search on your original error of 0x0000142 I come across a number of mentions of performing some registry editing of an entry for 'AppInit DLLs'. I suspect that this MIGHT be related to the 'elicen40.dll' file or possibly the launching of the Battlefront logo video file as mentioned in the Knowlegebase article CMSF won't launch (you would need to rename the file to something other than 'intro.wmv'). I suggest renaming the intro logo video file and performing the permissions settings mentioned in the 'Problem Event: BEX' article BEFORE attempting the editing of the registry for the AppInit DLL setting (which might be reset back to the value before editing once some programs are run !).

Link to comment
Share on other sites

Just out of interest what AV software are you using and have you tried temporarily disabling it when you run the game as a test?

Webroot has caused me some major hassles in the past and it still likes to delete a file called battlefront.exe whenever it gets the chance.  :rolleyes:

Edited by Sgt.Squarehead
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...