Jump to content

Recommended Posts

Well....for closure's sake, being I started this thread.  I got a notice from NVidia that there was a new driver update available for my graphics card. Did the download and install then thought to myself...why not give Red Thunder another try.  Low and behold....the game runs perfectly well now.  No more black screen issues. This is one of my favorite games so I am very pleased and may well look into Final Blitzkrieg when it's available.

Link to post
Share on other sites
  • 9 months later...

I have just bought a new machine with Win10 and I am having the exact same problem as Rayfer

" Can't play CM:RT at all since the Windows 10 upgrade.  Opens to a black screen, no error message of any sort arises. Can only close using cntrl-alt-delete". Task Manager show it is running.  I also have the NVidia GeForce GTX745, 8GB's RAM and 64 bit system.

I have updated the driver but still get the black screen.

Driver Info:

Driver Date 9/16/2016

Driver Version:


Edited by Ted
Link to post
Share on other sites

Ted - so you upgraded a computer that previously had Windows 7 or 8 on it to Windows 10 and CMRT was instaled BEFORE the Windows 10 upgrade, is that correct ? Since this upgrade to Windows 10 CMRT has not run at all (no error messages, etc.).

What anti-virus/security software are you using ? Have you added an exception for the CMRT game executable and/or its directories within your security software ? There is a mild chance that your security software is interfering with CMRT's operation (though you usually get a warning of some sort when this happens, from the security software).

There is also the possibility that the activation was rendered invalid with the upgrade to Windows 10. If this is the case you usually get some sort of error message from the game on launch saying that the activation is not valid. You may want to contact the Helpdesk (click blue '+new ticket' button in upper right) and request the gsClean utility for CMRT. This would wipe out your current activation and allow you to reactivate the game. However you may also want to check with them to make sure that they don't have any further info on Windows 10 Upgrades and your issue. (in case the gsClean utility is unnecessary).

There are slightly newer drivers than what you have, but I wouldn't think that would be the issue here. If you do decide to upgrade (downloading a newer driver such as 376.33), you will want to pick the 'custom' option for installation and then checkmark the 'clean install' box. This will most likely require a reboot, but it will remove any old driver files in case they are causing some sort of problem.

Link to post
Share on other sites

This is a new Dell computer I just purchased.

I did a fresh install of all the games (You just helped me fix an issue with CMBN V1.0) downloading each of the games using the activation codes I was sent when purchased.I loaded CMRT, entered the activation code, it said it was good to go and did I want to launch the game. I clicked "Launch" and nothing but a black screen.

CMBN, CMFI and CMFB are all up and running.

I have Kaspersky Security software. No I didn't do an exception for CMRT. I will look in to that.

I see no error messages or popups when I launch the game. It seems to run but is just a black screen, Task manager shows it is running,

I will contact the helpdesk and describe my problem and see what they have to say.

And I will upgrade the driver to 376.33 with a clean install.

Also, thanks for your prompt help with these issues. It can get very frustrating sitting idle.  

Link to post
Share on other sites

Install the 1.03 patch for CMRT too. This should require reactivating (though it doesn't eat up an activation). Though it may not make a difference for this particular problem it may be worth doing. Also definitely ad the exception within Kaspersky for CMRT. Occasionally the games are seen differently by the security programs and one may run into an issue while others don't.


Link to post
Share on other sites

 Schrullenhaft, just an update.

I created the exception for CMRT in Kaspersky. Didn’t work.

Before doing a clean install and loading the drivers I contacted at the helpdesk.

John said that since the other games are all working he doubts that it is the drivers.

At this point all John wanted to know if it was a PC or laptop.

I tried the V1.03 patch also but since the screen is black there was never anywhere from the beginning to add an activation code.


I will keep this forum updated.

Link to post
Share on other sites

With help from John over at the Helpdesk we have found the reason for the black screen.

There was an issue with running the Setup where the Data folder ended up being filled with a long list of file folders (something like 80) and did not have the .brz folders. All the extra folders were empty. All that should be in the data folder are 5.brz and a hotkeys file (maybe a .wmv).

John said it may be an issue with the 4.0 bundling.

A sample of the odd folders found in the Data folder after setup (there are about 60 more):


What I wrote to John explaining how I finaly had the correct files in the data folder:

"Now I know what to look for, a normal Data folder with only hotkeys and brz files, I then tried several attempts of uninstalling and re-installing CMRT.

I tried Setup from the Downloads folder, from the battlefront folder and directly from the WinZip folder and had the same issue with all those exact same odd folders in the Data file.

Instead of "extracting", I dragged and dropped from the WinZip window the Setup and .brz files to the Battlefront folder that was created by previous CMFI, CMFB setups. 

When I ran the setup it took a long time (about 15-20 Minutes) and when the green bar was at the end I noticed it was running files with "CMBN" (?) in the string so I stopped the setup. 

I decided to move the Setup and brz files out of the Battlefront folder and created a "Temp" folder in My Documents. 

I moved the CMRT Setup folder and the associated .brz files from the CMRT download to the new Temp folder and out of the Battlefront folder. 

When I ran setup from there it took about a minute or two and was done. The Data folder only had the hotkeys and the 5 brz files it and when I ran the game it was fine."


Edited by Ted
Link to post
Share on other sites

Sigh, yes the way the installer works can have unintended side effects. As near as I can tell it processes or installs all files it finds in the directory it runs in. Which means that if you unpack the .zip files in a place where there are other files, directories or worse game files you will get a very strange looking install.

When you are about to install an update you must unpack the .zip file to a new, clean, empty folder so that the installer will only find the files that are part of the install. Then run the install program. If you unpack the .zip file to your desktop, temp folder or any other place where there are already files then badness will ensue.

I had not heard of that causing a black screen on startup before though - usually you end up with some strange looking text and graphics in the game.

Link to post
Share on other sites
  • Create New...