Jump to content

SF and its modules will not run


Recommended Posts

Having great fun with CM:Normandy but wanted to load up SF and all its modules on my Windows 7 computer for a bit of modern action.

Installed the programs, patched and re-registered with no problems and when I try to run them they will not run - I just get nothing happening.

I tried messing with the firewall settings. I messed with the administrator settings. I still can't get the software to run - I never had any problems on my older system and CM:N and its modules work with no problems.

I notice this seems to be a recurring problem with many posts in this forum, I've tried a few solutions mentioned but with no success. Is there a complete guide to fixing this problem step by step?

Thanks in advance - I dearly love SF and all its modules and am gagging to get stuck into them again.

Link to comment
Share on other sites

CMSF on the PC uses a different copy protection system than CMBN. eLicense can run into issues with DEP (Data Execution Prevention) and security software.

You may want to read through our Knowledgebase article on DEP.

Your security software can also interfere with eLicense. You may want to set exceptions/exclusions/ignores within your security software (sometimes in multiple locations) to prevent it from interfering with the game and the eLicense service ('Runservice.exe'). Some security features also can interfere to such an extent that they may need to be disabled (a 'feature' within the security software) in order for the game to run.

Link to comment
Share on other sites

Reinstalled and patched the base game and all its modules and turned on DEP for essential Windows programs and services only. I also had to allow exemptions for the base game and all the modules exe files in AVG as it seemed to think they were a threat.

Game and all modules working fine now. I'm glad the new series of CM WW2 games no longer has this type of copy protection. Thanks for the help!

Link to comment
Share on other sites

AHHHHH!

I played the first mission in 'Rolling Thunder' and half the second mission. Turned the computer off for the night and now the game has stopped working again.

Getting this message:

'The application was unable to start correctly (0xc0000005). Click ok to close the application.'

Anyone any ideas to solve this one?

Link to comment
Share on other sites

Your DEP settings are still in effect, is that correct ? Have you set an 'exception' within AVG for the 'Runservice.exe' file in the '\Windows' directory ?

You may also want to go to your Control Panel > Administrative Tools > Services and look for 'LicCtrlService' and make sure that the 'Status' says 'Started'.

You may also want to launch the game by right-clicking and selecting "Run as administrator" from the popup menu.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...