Jump to content

CMMOS troubles

Recommended Posts

Hoping someone can maybee nudge me in the right direction here.

Trying to get CMBO set up with CMMOS. Downloaded the base files (4.03 IIRC), the rulesets, and mods. I go to launch the CMMOS core, it shows the files expanding to the temp directory, then, nothing. Same happens with the rule sets. (I know the core must be installed first, just tested to see if it was a problem with the installer itself)

I notice in the task manager after launch, it still showed the CMMOS 4.03.exe, and also NTVDM.exe had appeared since the attempted launch. Tried multiple times, same result. Tried unpacking the file with winrar, and launching the setup.exe manually, but got the same result. I have since downloaded and reinstalled installshield in the hopes that would fix things, but no go.

Any help, suggestions, etc will be much appreciated. Guess worst case I can unpack the zips but renaming all those files will be quite a chore. Needless to say, hoping to avoid "Plan B" smile.gif

Link to comment
Share on other sites

yes try 4.05 - well organized

Are you trying to install CMMOS on a drive other than C:\ ? For some reason (i found)it does not setup correctly if you install to a D:\ or E:\ drive, but reinstalling it back on C:\ made problem go away

[ May 11, 2004, 06:30 PM: Message edited by: worfare ]

Link to comment
Share on other sites

Was at CMMods last night but didn't see where to get the CMMOS file, only the mods themselves. (Was nearly asleep when doing it, so probably just missed it.)

Will try that, but got it working nevertheless, using less, conventional methods. I installed it on a relatives comp for his installation (we were planning on playing each other) and simply exported all the releavant registry entries, and copied the actual installation itself onto CD for transfer. Imported the registries and pasted the CMMOS fiels, and it appears to be running now. (haven't actaully tried using it though, but it did load up at least, which is a good sign.)

I assume it is something with my comp, as I burned the mods and CMMOS onto disc for him, and they installed without a hitch on his comp. As to why they did not on mine, I have no clue whatsoever.

Guess it pays to be a part time nerd sometimes. smile.gif

Link to comment
Share on other sites

If you are using CMMOS 4.03 (from the CMHQ site) as opposed to CMMOS 4.05 (from the Cmmods site) there are a couple of things you should remember.

First, CMBO CMMOS 4.03 doesn't work the same way as CMBB CMMOS. You have to unzip the mods into the CMBO bmp folder for them to work.

So the basic drill is as follows:

1) Make sure you have installed CMBO somewhere normal (i.e. C\Program Files\CMBO and not to another drive or to a folder called games).

2) Make sure that the GEM CMMOS program (that's not quite the right name, I'm doing this from a weakening memory) is installed to its default setting (C\Program Files\GEM whatever)

If 1) and 2) aren't adhered to, CMMOS probably won't be able to find anything to manipulate.

After that, make sure you've downloaded and prperly installed the Rulesets.

First diagnostic trick:

Run the cmmos program to see if the mods are properly installed or not. If they're x'ed out, they aren't installed.

Second diagnostic trick:

If something isn't working, look at the log file in the GEM productions folder. When you fire up the CMMOS program it runs through all the rulesets and rules, and gives a short, cryptic description of what happened. It can be a major clue to the embarassingly common problem of clicking on a mod but forgetting to hit the install button (my personal favorite).

And, sadly, if you are using a Mac, CMMOS won't work for you.

Note that CMMOS 4.05 works differently.

Link to comment
Share on other sites

Thanks for all the advice everyone.

However, for the last bit, think I was misunderstood. The trouble I had was that the installer itself would not run, ie: no install window opened up, no program installed. smile.gif I had to do a surgical method of implanting it myself, but no matter, as it runs now.

Also thanks for the instuctions for CMMods.com, grabbed a few more things from there as well.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...