Jump to content

Please Help.

Recommended Posts

Hi everyone im chris, im new to these forums but i've been playing the Combat Mission series of games for some time now. Anyway, some time ago i bought CMSF off a seller on ebay, installed it fine and everything worked fine..playing the game was fine, graphics, sound effects, all seemed right. Not so long ago i downloaded and installed CM Afghanistan from Battlefront.com and thats been fine too.

However i have just downloaded and installed the add on for CMSF British Forces, went to play it and its just unplayable. First before i installed British Forces a box came up and said its extremely important to have the original CMSF patched to v1.10, which i hadn't done. So i did, once i downloaded it i put the v1.10 patch in the Data folder for CMSF and thought right, thats done.

I then installed British Forces and then went to play it..i loaded a battle called UK British joy, which was to rescue some hostages..im sure those of you who have British Forces will have played that battle.

Anyway once the battlefield with my forces loaded up, most of the battlefield was covered in black, except for the ground just nearby surrounding where my troops are. As i moved round the battlefield that blackness goes to reveal what the ground is supposed to look like (desert) it looks like how in some RTS games you have the fog of war, sure you're all familiar with games that have that concept (example: Command and Conquer). Not only that, but when i ordered my troops to fire their weapons, i couldn't hear any sound effects, except for the occasional few, or the whizzing of bullets. Or for example, i ordered a jackal HMG crew to fire their HMG and GPMG, and couldn't hear hardly anything. I then dismounted a sniper team and ordered them to fire and heard the soldiers' L85A2 rifle firing (which sounded just like the M4's the yanks have in CMSF, bizarrely) but i couldn't hear the snipers' rifle sound effects.

I also tried playing one of the original CMSF battles with the yanks, and they now come up exactly the same as in British Forces, with the battlefield black and lacking sound effects. It just seems ruined..i hope you all can help me here..maybe i need to config the setup because of the latest patches installed with it..including the v1.10 patch i installed? if so could anyone advise me on how i do this? any help would be greatly appreciated and look forward to your responses, thanks a lot.

Link to comment
Share on other sites

Stikkypixie, yes the v1.10 patch i downloaded..i just put in the data folder. I downloaded it and saved it to my desktop, then i copied and pasted it in the CMSF data folder. So how exactly do i execute it? the thing is i did the same when i downloaded the AKD sound module, by copying and pasting it in my CMSF and CM Afghan data folders and it worked...the sound effects in the games had changed, although there were some problems with that...which i rectified by removing everything of that AKD sound module except for "ZBase_AKDSM.brz"...it came with other brz files which i removed because with those, or certain ones, there were sound effects missing, or they sounded distorted.

wombat of war, when i downloaded British Forces, it came with the 1.11 and 1.20 patches..so with the 1.10 patch which i downloaded myself i have them all in order..dont i? but what i think i need to do is open and execute that 1.10 patch which is what stikkypixie is saying, but i don't know how to. I'm not the best with working PC's. Would appreciate anymore help guys, thanks. Oh and merry christmas.

Link to comment
Share on other sites

ah yes you need to double click on the file to execute it not just copy and paste. if its in a .rar or .zip. format you will need winrar or a zip program to unpack them first.


you will need a zip program which is easy to find free on the net to unpack the zip file to get the files you need

official patches you will need


try reinstalling the base game

patch to 1.10 or 1.11

install the british module

skip the 1.20 patch

patch to 1.21

patch to 1.31

patch to 1.32

hope that helps

Link to comment
Share on other sites

Excellent, all sorted now guys, thanks very much for your help. I did what you said wombat of war..just double clicked the patch i downloaded and it opened up with a screen to install it. It included not just patch 1.10 but all of them previous between 1.01 to 1.09 and they automatically went straight into the data folder once installed. Top draw...lets shoot some syrians with our british boys lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...