Jump to content
Sign in to follow this  
CPT Cater

Avast wont let me download my files?

Recommended Posts

I had purchased WAW and Global Conflict a while back, and I tried downloading it on a different computer and it wont let me. It keeps saying that Avast is detecting a virus, then I tell it to ignore that and it still wont let me download the files of either game. Whats the problem?

Share this post


Link to post
Share on other sites

This is a so-called "false positive". It often happens when you allow your anti-virus program to "guess" (the professional term is "heuristic" scanning). In other words, there is no virus, but some code in the executable may be vaguely similar to one, and if your AV is set to act on suspicion, then it will block.

You should change your AV settings to not act, but instead only prompt you for confirmation of what to do. Or you can set an exception to leave the file (which is known to not have any viruses) alone entirely. Or you can shut off "heuristic" scanning (it's useful sometimes, but VERY prone to false positives like that with ANY type of encrypted - aka protected - file).

Martin

Share this post


Link to post
Share on other sites

OK, the turning off the Avast trick worked, thanks! But now I still have the same problem I had that caused me to want to reinstall my game. Whenever I complete my turn on a game it locks up and says something like "Failed (store) Permission Denied" and I have to go to processes on my computer and close it out because it wont let me just click OK. It locks the whole thing up. Any ideas? I have uninstalled and reinstalled twice.

Share this post


Link to post
Share on other sites

If you're running Windows Vista or Windows 7, then you may want to launch the game by right-clicking and selecting "Run as administrator" from the popup menu. Assuming that the error is actually based on one of write permissions, then this should give the game the necessary permissions to write in its protected folder (often the '\Program Files' or '\Program Files (x86)' directory).

Share this post


Link to post
Share on other sites

You may want to do it all of the time. You can modify the shortcut to do this for you (though it will come up with a 'confirmation' dialog box each time you launch). Right-click on the launching shortcut and select "Properties" from the popup menu. In here go to the 'Compatibility' tab and near the bottom of this tab will be a section labeled 'Privilege Level'. Check mark the box next to the text that says "Run this program as an administrator". Click 'Apply' and then 'OK'. You shouldn't need to right-click to launch the game now and still have administrative rights within the '\Program Files' directory.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...