Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Mord

How To Install Mods

Recommended Posts

Yes, except there may be some problems with some older pre-2.0 uniform/face mods that haven't been updated and a handful of sound mods that may not work correctly with Macs because of the bitrate.

 

 

Mord.

Share this post


Link to post
Share on other sites

Hi guys ive downloaded the Saving pvt Ryan campaign and the 2nd rangers mod, i created a folder named z in the data folder and i sent the brz file there but for some reason the rangser skin isnt showing, what am i doing wrong?

Share this post


Link to post
Share on other sites
On 5/27/2017 at 1:11 PM, Kumando said:

Hi guys ive downloaded the Saving pvt Ryan campaign and the 2nd rangers mod, i created a folder named z in the data folder and i sent the brz file there but for some reason the rangser skin isnt showing, what am i doing wrong?

I'm having similar problems with the various British 53rd Division uniforms. I put the subfolders for the various Brigades into my z folder but all my quick battles still have troops bearing the 49th West Riding arm patch. I can't even seem to figure out where or if there is a place to select which unit uniform I want to play the quick battle with when setting up. What am I missing here? I read this thread and a few modding guides and can't seem to figure it out.

Edited by historysteve

Share this post


Link to post
Share on other sites

The mods folder doesn't like folder-in-folders.

You could simply throw your mods folders into 'Data' and avoid the Z folder' entirely

Z folder works simply because 'Z' will fall at the end of any alphabetical listing. The contents of the last folder in 'Data' will overwrite the previous. For CMBN any folder starting with a name after 'N' (for 'Normandy) will work as well.

So if you have several folders of different mods you can name the folders 
'O German uniforms',
'P American uniforms',
'Q British vehicles' 
or whatever you like. Just drop them into 'DATA'. As long as its not folder-in-folder all the mods should appear.

Share this post


Link to post
Share on other sites

I tried that with a few different uniform mods but am still just getting the same ol' white bear patch on all my soldiers. No idea why - maybe because I'm still on 3.0 engine? Or that all the uniform mods I have are from 2012?

Share this post


Link to post
Share on other sites

"The mods folder doesn't like folder-in-folders."

Good to know.  Unfortunately, mod sluts like me have hundreds, perhaps thousands of mods for a particular game and it's impossible to keep track without folder and subfolders.  Eg I have many sub Z folders called TERRAIN; SFX; SOUNDS; UI; UNIFORMS; MOD SETS etc.   

Most of the time the desired mods show up if you put enough ZZZ's at the start of the desired mod folder name.   (Sometimes there are unpleasant effects like a mod not showing up ie: "blacked-out".)

Share this post


Link to post
Share on other sites

RE: Folders in folders. I am not sure what @MikeyD is getting at. I have folders inside folders all over the place and my mods work. For example in my z folder I have a v folder which contains a folder for each vehicle. Works like a charm.

RE: uniform issues. One of the upgrades (I forget which) changed the way uniform mods were numbered. This means that older uniform mods will not work without some file renaming. This was discussed some where on the forum but I am not sure where. Not sure if that is at play here though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×