Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Yskonyn

Some performance and quality tips for NVIDIA users

Recommended Posts

1 hour ago, MOS:96B2P said:

Those settings worked out well so far.  We have the same graphics card GTX970.  If you don't mind me asking, what settings do you use in the options menu? Vertical Synch., Antialias, Advance shaders etc. Also do you use the same Nvidia settings for CMSF?  Thanks.  

Options in CM? They're all turned on/max. As for CMSF, I've got stacks of disks (including spares for a buddy who, alas, was not interested), but since I've rebuilt my system several years ago, shamefully, I have not reloaded them. I seem to remember being in the midst of the German campaign...

Here's what I have for my AMD card. (I'm sure there are those who are better qualified than I am to discuss the pros and cons of my selections. I do have a freesync monitor hooked up to that one (R9 390). The GTX970 is NOT hooked up to a gsync monitor.)

AMD v16.7.1 CMBN.JPG

Share this post


Link to post
Share on other sites
44 minutes ago, c3k said:

Options in CM? They're all turned on/max.  <Snip> 

Thanks Ken.  In the Combat Missions game's options menu how do you have your Vertical Synchronization, Antialias/multisample (not even sure what that means) High Priority Process and Shaders set?  Thanks for taking the time to indulge all my questions.   

Share this post


Link to post
Share on other sites

My settings are:

V Sync: Off

Antialias/Multisample: On

High Priority: On

Shaders: On

What really helped with my GTX 970 was turning on Adaptive V-Sync and setting the V-Sync refresh rate to 1/2 in nVidia Inspector for all of the CMx2 games. I get 30 fps pretty consistently using Improved Model Quality and even Better and Excellent.

The Texture Quality is always set to Best.

 

Edited by WallysWorld

Share this post


Link to post
Share on other sites
2 hours ago, Vanir Ausf B said:

My settings are identical to Ken's except for the adaptive V-Sync. I have a much lower end system but still get decent performance.

Thanks Vanir.  If two old timers have the identical settings this is probably the way to go.

Share this post


Link to post
Share on other sites
14 minutes ago, c3k said:

V Sync: On

Antialias/Multisample: On

High Priority: Off

Shaders: On

Thank you again!

5 minutes ago, WallysWorld said:

My settings are:

V Sync: Off

Antialias/Multisample: On

High Priority: On

Shaders: On

What really helped with my GTX 970 was turning on Adaptive V-Sync and setting the V-Sync refresh rate to 1/2 in nVidia Inspector for all of the CMx2 games. I get 30 fps pretty consistently using Improved Model Quality and even Better and Excellent.

The Texture Quality is always set to Best.

 

The one difference I had with both of you was the Antialias/Multisample.  Mine was off.  Now it is on :).  Thanks.  My high priority was also on.  It sounds like a good thing so I left it on ...... but then again I don't really understand all this stuff so.................

Share this post


Link to post
Share on other sites
9 hours ago, WallysWorld said:

My settings are:

V Sync: Off

Antialias/Multisample: On

High Priority: On

Shaders: On

What really helped with my GTX 970 was turning on Adaptive V-Sync and setting the V-Sync refresh rate to 1/2 in nVidia Inspector <Snip> 

Just making sure I understand.  In the CM options menu you have V Sync off but in the Nvidia settings you have adaptive V-Sync on?  (I'm not even sure if those are the same thing)  I'm trying to learn some of this stuff while people who also have an Nvidia GTX 970 are talking about it.  Thanks.   

Share this post


Link to post
Share on other sites
48 minutes ago, MOS:96B2P said:

Just making sure I understand.  In the CM options menu you have V Sync off but in the Nvidia settings you have adaptive V-Sync on?  (I'm not even sure if those are the same thing)  I'm trying to learn some of this stuff while people who also have an Nvidia GTX 970 are talking about it.  Thanks.   

V-Sync is  set to Off in the game.

In nVidia Inspector, V-Sync is set to 1/2 Refresh Rate and Vertical Sync Tear Control set to Adaptive. That should give you 30 fps pretty consistently.

Edited by WallysWorld

Share this post


Link to post
Share on other sites
1 minute ago, WallysWorld said:

V-Sync is  set to Off in the game.

In nVidia Inspector, V-Sync is set to 1/2 Refresh Rate in nVidia Inspector and also Vertical Sync Tear Control set to Adaptive. That should give you 30 fps pretty consistently.

Okay.  Thanks. 

Share this post


Link to post
Share on other sites
On 7/18/2016 at 10:48 AM, c3k said:

Here are screenies of my NVidia control panel settings which I use for all my CM games on my GTX970 running a 1920x1200 panel.

I also use hi-res mods for terrain, buildings, and vehicles. (Thanks to Aris, Vein, Marco Bergman, Juju, Kieme, Umlaut, Tanks a Lot, and...gah... I've forgotten some. Grrr.)

NCP CM 01.PNG

NCP CM 02.PNG

NCP CM 03.PNG

These settings are excellent,  I had most of them set but a few I changed based on yours (high quality texture filtering and 4X supersample) and it made a noticeable difference in-game.  I can't detect a jaggie or issue with shadows now and the game actually runs even smoother.  My specs:  Win 7, ASRock DG4, G3258, 3GB ASUS GTX 1060, 8GB Ram.

Share this post


Link to post
Share on other sites
1 hour ago, AstroCat said:

Now when I turn on any supersampling I get this issue on lots of textures...

http://s1351.photobucket.com/user/astrocat2/media/Game screenshots/20161230095025_1_zpsbnsxertv.jpg.html

Yep, that has been a problem with nVidia drivers since november IIRC if you have antialiasing on in-game and in the control panel. I've seen it across several games so it is not only CMBN :( 

Share this post


Link to post
Share on other sites

I haven't played in a while, last time I did I didn't have this issue. Some driver change must have introduced it. Does AA work if off in-game, used to not?

Share this post


Link to post
Share on other sites

Ah, I know I am missing something - hence why I am asking.

What is the issue in the picture? Could be that I am on my phone I suppose. Can you guide me to what I should be looking at? Please

Share this post


Link to post
Share on other sites
1 hour ago, IanL said:

Ah, I know I am missing something - hence why I am asking.

What is the issue in the picture? Could be that I am on my phone I suppose. Can you guide me to what I should be looking at? Please

Look at the road, it looks like the texture is stretched or doubled which gives it a fuzzy look.

Share this post


Link to post
Share on other sites

Wow... so now Supersampling is ALSO broke in the CMx2 engine?!?! This is a joke! You can't even get rid of the crazy shimmering now without breaking a ton of the textures. I assume there will never be any fix from the devs? Grrr! I just unwisely bought the 4.0 upgrade and battle pack... what was I thinking!?!? :(

Share this post


Link to post
Share on other sites

Ok, now that the frustration is over I'm doing some homework. Ok, you are gonna need the latest version of nvidiaProfileInspector and you can get it here:

https://ci.appveyor.com/project/Orbmu2k/nvidiaprofileinspector/build/artifacts

So far, and I'm still testing: Antialiasing: 8xSQ [Combined: 2x2 SS + 2x MS] works but it makes the UI a little blurry. It's gonna take some work but I'll see if I can find a combo setting that works the best.

 

Edited by AstroCat

Share this post


Link to post
Share on other sites

Supersampling is a routine performed by the video drivers. CM isn't programming those routines, Nvidia is in this case. As others have pointed out the anti-aliasing routines in recent releases of the Nvidia drivers are problematic for CM and OpenGL currently.

Edited by Schrullenhaft

Share this post


Link to post
Share on other sites

Yeah, well that might be but CM always seems to have opengl issues... etc... anyway after some more messing around I think Antialiasing: 8xSQ [Combined: 2x2 SS + 2x MS] is the only way to get it to work. The UI is a bit blurry but the game space is not. It's not nearly as good as normal 4xAA 4xSS but it'll have to do. It's better than the super shimmering you get otherwise. I'm not counting on any kind of fix ever. 

Although considering Nvidia is what most people have you'd think it would be in BF best interest to be compatible... but I guess not worth the effort.

Also 32xS [Combined: 2x2 SS + 8x MS] and 16xS [Combined: 2x2 SS + 4x MS] work "ok" as well.

Also turning on the fps limiter to like 30 or 40 helps with the big fps jumps.

Edited by AstroCat

Share this post


Link to post
Share on other sites

Why do you assume this is BFC's fault? My (limited) understanding is that the OpenGL spec is pretty clear, but that both Nvidia and AMD have been somewhat loose in their implementation of that standard. (See Steve's explanation of how AMD did not correctly map 3D coordinates in OpenGL for a few years, for just one example.)

I'll have to check and see if my Nvidia settings have changed. (I posted my profile upstream...but that was awhile ago.) I'll see what supersampling looks like on my rig. I have not, as yet, seen any corruption like what you have posted. Driver versions: I usually update, but recently held off due to the stink about the Nvidia drivers/Geforce sending information back...until I understood the issue. (It seems to be very harmless and only to tweak settings/optimize software.) I think I have the latest version now.

 

Share this post


Link to post
Share on other sites

I understand how drivers and the graphic card manufactures can be at fault. But what I see "most" other companies do is either contact the driver developer and work it out or make changes in their game to adapt to the new drivers. What I don't see happening is companies saying, ah too bad customer, deal with it. 

Enabling any kind of independent Supersampling will cause many textures, especially busier ones like gravel roads to become distorted.

 

Share this post


Link to post
Share on other sites

×