Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Yskonyn

Some performance and quality tips for NVIDIA users

Recommended Posts

I agree that CMBS feels like it is running more smoothly than the other games, and I have them on the same settings. Both nVidia and in game. CMFI runs the worst I think.

Share this post


Link to post
Share on other sites

I'm curious though to what extend the different CM games perform.

Black Sea vs FI vs BN vs ?

 

Well the newest release has the newest code and therefore it gets any performance improvements first but one of the great things about this game is that even CMBN that has been out for a while now is using the latest major version of the engine.  Once the current games get their next patches there is an excellent chance they will get the benefits of any engine optimization that has been fixed along the way as well.

Share this post


Link to post
Share on other sites

Once the current games get their next patches there is an excellent chance they will get the benefits of any engine optimization that has been fixed along the way as well.

Hope so, up to now I am not impressed with 3.0's general performance.

Perhaps it is time for the devs to think about optimization, not only adding more campaigns and highly detailed but unoptimized 3d models. Rivet counting is nice, but not at the expense of general playabity.

Share this post


Link to post
Share on other sites

i use a gtx 750 and get incredible playback performance with back settings turned way up..its a different story when you overburden the game while plotting moves..antistropic filtering is the main cause of flickers the use of wich is fine as long as you use a type the game recognizes. ie adaptive will flicker all over the place and fancy versions of antialiasing will screw up your fonts. if the game runs fine in playback but everything wiggle and waggle your antialising is not clamped down and should be turned off i think if your card does not support clamping.

Share this post


Link to post
Share on other sites

hi everybody!

my problem is that I get always the error "could not initialize graphics display: REQUIRED 1024x768, 32-bit color" and black sea is not running.

when i lower the graphic stats to 1024x768 the game runs, but just on two thirds of the display - on the right and the left of the dsplay are broad black parts. very anoying.

i also tried lot of the nvidia stats showed in this thread, but it doesn't work.

 

my system:

core i7

nvidia geforce 940m

8gb ram

display 1920x1080

and, well, i'm a real noob in system problems. with my last computer the game went without problems but only on poor settings.

maybe anyone has a solution?

thank you!

yours,

blitzkriegmyass

Share this post


Link to post
Share on other sites

I see and m at the end of your graphics card.  Is this a notebook by chance?  If so it could be as simple as there are two graphics cards - one integrated into the motherboard and the Nvidian one.  My work notebook is like that.  I have to tell it to use the Nvida card for the games. Use the Nvida control panel to add an entry for the game so it uses the Nvida card.  Assuming that is the problem.

Share this post


Link to post
Share on other sites

I see and m at the end of your graphics card.  Is this a notebook by chance?  If so it could be as simple as there are two graphics cards - one integrated into the motherboard and the Nvidian one.  My work notebook is like that.  I have to tell it to use the Nvida card for the games. Use the Nvida control panel to add an entry for the game so it uses the Nvida card.  Assuming that is the problem.

Hello IanL,

thanks for your answer. But I already added the game to the control panel for the graphics card. the black bars (like a 4:3 screen) stay. on my old notebook i could use the full screen...

but thanks a lot

Share this post


Link to post
Share on other sites

A belated response...

blitzkriegmyass - You may want to look at this Knowledgebase article about your "could not initialize graphics display.." error.

The 1024 x 768 resolution is a 4:3 aspect ratio. The black bars on the side of the display are normal IF that is how your video chip/card and display handle non-widescreen resolutions. Some will 'stretch' the image to cover the entire screen (resulting in stretched, out-of-aspect-ratio images) or will map the resolution directly to the pixels on the screen (what you are seeing); giving you a sharper display, but shrinking it to the exact space it would take up on your 1920 x 1080 widescreen display. I'm not sure if this option exists in your Nvidia Control Panel, but you may want to experiment (if it is there) and see if this gives you what you want:

Nvidia Control Panel > Display section (left-hand menu) > Adjust desktop size and position > under '2. Apply the following settings' > Scaling tab > 'Select a scaling mode'.

In here the default will probably be 'Aspect ratio'. You can change it to 'Full Screen' and see if it makes a difference. I don't know if it will for full screen games like CM or not. There is another option of a check box for 'Override the scaling mode set by games and programs'. I don't think CM does anything like this, but you could check it to see if it helps or not. You can also experiment with the 'Perform scaling on:' option. The default will usually be 'Display'. You can change it to 'GPU' and see if that makes a difference (it may slow down some screen drawing).

Edited by Schrullenhaft

Share this post


Link to post
Share on other sites

A belated response...

blitzkriegmyass - You may want to look at this Knowledgebase article about your "could not initialize graphics display.." error.

The 1024 x 768 resolution is a 4:3 aspect ratio. The black bars on the side of the display are normal IF that is how your video chip/card and display handle non-widescreen resolutions. Some will 'stretch' the image to cover the entire screen (resulting in stretched, out-of-aspect-ratio images) or will map the resolution directly to the pixels on the screen (what you are seeing); giving you a sharper display, but shrinking it to the exact space it would take up on your 1920 x 1080 widescreen display. I'm not sure if this option exists in your Nvidia Control Panel, but you may want to experiment (if it is there) and see if this gives you what you want:

Nvidia Control Panel > Display section (left-hand menu) > Adjust desktop size and position > under '2. Apply the following settings' > Scaling tab > 'Select a scaling mode'.

In here the default will probably be 'Aspect ratio'. You can change it to 'Full Screen' and see if it makes a difference. I don't know if it will for full screen games like CM or not. There is another option of a check box for 'Override the scaling mode set by games and programs'. I don't think CM does anything like this, but you could check it to see if it helps or not. You can also experiment with the 'Perform scaling on:' option. The default will usually be 'Display'. You can change it to 'GPU' and see if that makes a difference (it may slow down some screen drawing).

belated as well, schrullenhaft!

it worked, cm is full screen now.

Thanks a lot!

Rock on !

blitz...

Share this post


Link to post
Share on other sites

Nvidia 750ti sc - card totally off windows updates and on vendor only updates

no AA crap, turned all off

All settings turned off except anisotropic set to 16

texture filtering set to high quality

 

runs smooth

Edited by user1000

Share this post


Link to post
Share on other sites

After downloading the Black Sea and Normandy demos, I have been struggling all afternoon to get acceptably smooth performance on a high end custom built PC.

I have a gsync monitor, which has no effect on vsync in Combat Mission in my tests, but the monitor can go up to 144mhz refresh rate (equivalent to 144 frames per second)

This allows me to set a refresh rate of 120 in the display size.txt file which gives me 60fps in-game, using vsync adaptive and 1/2 refresh rate.

The difference is very noticeable between 30 and 60pfs when scrolling around. It's still not butter smooth but it's acceptable for me.

I have tried every trick I know and this is the only one that actually smoothed things out, ymmv.

 

In-game settings:

Display Size (set externally to 1920 1080 120 in display size.txt)

Vertical Synchronization - Off

3d Model Quality - Improved

3D Texture Quality - Best

Antialias/Multisample - On (Nothing I change in Nvidia Profile Inspector has any effect) and 4x multisample is fine

High Priority - On

Edited by dark helix

Share this post


Link to post
Share on other sites

Hey dark helix - welcome to the boards. Well, to be honest "butter smooth" isn't something a lot of users experience, especially on large Normandy maps with lots of bocage and woods. The range 25-30 FPS is about what to expect, as a high end PC doesn't improve as much as some anticipate.

However, I'm curious as I myself just bought a new MSI laptop with a 970M nVidia card and it seems like I don't have the "adaptive vsync 1/2 refresh rate" that worked wonders on my old PC. I have been told it is because gsync is instead of it. But from your post it seems like you have both. Are there any other settings apart from the control panel to access it?

Share this post


Link to post
Share on other sites

Hey rocketman.. thanks.
I would call it peanut butter smooth now.. at least it's playable. I still can't decide between Normandy or Black Sea.. I love both.

If you use the built in Nvidia control panel (right click on desktop to access it from contextual menu), under Vertical Sync, there should be an option for Adaptive (half refresh rate). To disable gsync, you will need to select Monitor Technology - Fixed refresh.. at least that's what I do.

I hope this helps.

 

Edited by dark helix

Share this post


Link to post
Share on other sites

For vsync I only have On/Off. Where do you find "Monitor Technology"? In the control panel?

Also worth mentioning is that the demos probably arn't as good as the full games when it comes to performance. I think that is especially true for BN, but I can be mistaken. Get both :) and then the rest of the series. If you love the demos at this stage, well, you have a lot of enjoyable gaming ahead of you.

Share this post


Link to post
Share on other sites

You might have some kind of custom control panel on your laptop, I don't know.

If you have the regular Nvidia Driver installed, you can right click on the desktop in a free space and select NVIDIA control panel.

Capture.PNG

Share this post


Link to post
Share on other sites

That is what I usually do and I get what you show, but less options and none of the "Display" / "Video" options on the left (which I also had on my previous PC). "Monitor Tech" is not an option in the 3D-manage settings. I will probably post something on Nvidia's forum about this.

Share this post


Link to post
Share on other sites

Turns out my graphics card (GTX 907M) for some strange reason does not support adaptive sync (:angry:) and for gsync to work I need a new monitor as the laptop screen doesn't support it (:angry: again).

Share this post


Link to post
Share on other sites
On May 17, 2015 at 6:42 PM, Simulacra53 said:

Luckily I was able to find a setting that seems to be ok.

 

Although the frame rate of this engine is abysmal compared to something like Graviteam Tactics, with its big maps and similar detailed models.

 

The visuals are still fine and the frame rate is now "ok" min. 25fps while playing relatively smoothly so I can enjoy a huge battle without dropping into the higher teens.

 

Looks like I should have done my research on both counts.

 

780gtx oc model, 4790k w. 16gb mild oc running win7 64bit

What settings are you using that work "OK" for you?  My game is running slow as snot too.  I have two Nvidia 970's in SLI.  Does this game use SLI?

Share this post


Link to post
Share on other sites

Here are screenies of my NVidia control panel settings which I use for all my CM games on my GTX970 running a 1920x1200 panel.

I also use hi-res mods for terrain, buildings, and vehicles. (Thanks to Aris, Vein, Marco Bergman, Juju, Kieme, Umlaut, Tanks a Lot, and...gah... I've forgotten some. Grrr.)

NCP CM 01.PNG

NCP CM 02.PNG

NCP CM 03.PNG

Share this post


Link to post
Share on other sites
3 hours ago, c3k said:

Here are screenies of my NVidia control panel settings which I use for all my CM games on my GTX970 running a 1920x1200 panel.  <Snip> 

Thank you.  I will give these a try in my CMBN game.  CMBN IMO has not looked as good as the other titles.  

Share this post


Link to post
Share on other sites
19 hours ago, c3k said:

Here are screenies of my NVidia control panel settings which I use for all my CM games on my GTX970 running a 1920x1200 panel. 

Those settings worked out well so far.  We have the same graphics card GTX970.  If you don't mind me asking, what settings do you use in the options menu? Vertical Synch., Antialias, Advance shaders etc. Also do you use the same Nvidia settings for CMSF?  Thanks.  

Share this post


Link to post
Share on other sites

×