Jump to content
Sign in to follow this  
CML

Mac mouse cursor problem

Recommended Posts

Greetings,

First of all, I´m very happy too se a return to the Mac! I´m running an iMac 2010, OSX 10.6.7, 3,06 GHz, 4 GB ram, ATI 4670. Simple Logitech USB mouse. CMSF and CMBN demo runs great in Windows XP (using Bootcamp) 1920x1080 with everything set to better/best.

However, when I´m playing the CMBN demo in OSX there is a severe lag with the mouse/cursor and the icons hoovering the units are really crude. Everything else is fine, but this is really ruining the experience and makes it next to unplayable. The problem occurs every time regardless of setting.

Is this a known bug? Anybody else thats experiencing the same problem? Any workarounds? Any help would be much appreciated. CMBN seems to be great and I was really hoping to buy the Mac version.

Regards,

Share this post


Link to post
Share on other sites
Guest

CML - do you have Vsync and High Priority Process both turned on?

As for the icons - that might be a video card thing. I'll look into it.

Share this post


Link to post
Share on other sites

Actually, now that CML mentions it, the original round unit decals above the units on my 2560x1440 i3 iMac with the 512 card are a bit jagged. I'm using DeutschRitter's Contact Icon Mod now, but turned that off to check as the OP triggered a memory for me and sure enough, they are jagged.

Share this post


Link to post
Share on other sites
Guest

Thanks for the reports guys. I think I know what the problem is. This should get fixed in the first patch.

Share this post


Link to post
Share on other sites

Phil, Thanks for the reply! Just for the record, yes I have had both Vsync and High Priority Process on, but it´s marginally better at best. I´ll guess I have to stay updated on these issues.

Best regards,

Share this post


Link to post
Share on other sites
Guest
Phil, Thanks for the reply! Just for the record, yes I have had both Vsync and High Priority Process on, but it´s marginally better at best. I´ll guess I have to stay updated on these issues.

Best regards,

Thanks CML. We'll see if there's anything we can do about the mouse lag.

Share this post


Link to post
Share on other sites

I have also encountered the same mouse lag as the OP. I have an Imac late 2009 4GB ram 2.66 I5 core and ATI 4850 graphics card. OSX 10.6.7 all sw updates applied.

Tried the suggested options on and off and in different constellations but to no real avail unfortunately. Any suggestions are most welcome :D

Share this post


Link to post
Share on other sites

Did som additional testing that might be useful..As the OP I used an generic non apple usb mouse. I hooked in one old Apple mighty mouse usb to test and it was an an clear improvement however a slight lag remained. Tried after that the new Apple magic mouse w bluethooth and the lag was gone. So my amateur guess is that there is an issue with usb connections somehow.. Well hope it helps, I will run the magic mouse but i hope this can be sorted out as i personally think the magic mouse is *awful* for gaming.:P:p

Share this post


Link to post
Share on other sites

Thanks for the tip, Field! Thought crossed my mind earlier but I didn´t try it out until today. Used my Magic Mouse w/ bluetooth. It was somewhat of an improvement, but the lag still remains.

BTW Field, are you playing the demo or the full version?

Regards,

Share this post


Link to post
Share on other sites

@ CML

I'm using the full version. Never tried the demo on mac so I can not say if this problem was around in the demo as well. Sorry to hear that you still have a problem though. As a reference I'm currently using these settings in game:

Vertical sync -on

3D model quality - Best

3D texture quality - Best

Antialiasing -off

High priority process - on

ati left klick -on

Shadows in game -off.

Share this post


Link to post
Share on other sites
Guest

Hey guys - I'm working on this. As you can probably tell this isn't something to do with Combat Mission's speed, and something more to do with how your mouse talks to the game and operating system (as indicated, in part, by the fact that different mice behave differently). In fact *faster* machines seem to have the most trouble with the lag.

Field - just out of curiosity, have you tried turning the ATI left click off? It shouldn't make a difference, but I'd like to hear how it goes. Also, try turning Vsync off separately if you could.

Share this post


Link to post
Share on other sites

@ Phil,

Here is my conclusion so far using a generic usb mouse and various settings. Hope it helps! :-)

ati left click off- does reduce the lag but the pointer started to act up after a while so i turned it back to on.

v-sync off- no difference same lag.

high prio process off - seemed to reduce the lag as well a little but not to a usable degree.

Have not touched the 3D model settings yet but i suspect they should not impact the mouse behavior like this. I might be wrong though.

Share this post


Link to post
Share on other sites

Greetings,

Shameless bump on my part. What is the latest regarding the mouse "lag"? I´ve tried the 1.10 demo for Mac and although it is a bit better than before, the problem remains. I´m running the same machine as before with Snow Leopard and I´ve tried different settings and USB mouses. I´ve not bought the full version yet as I really wanted the OSX-version instead of starting up Boot Camp every time I want to play ;-)

Any help from staff och members is greatly appreciated!

Regards,

Share this post


Link to post
Share on other sites
Guest

Hmm. I made some specific changes to the mouse handling in 1.01 (back in July / August) that should have cleared problems like this up. I'm playing with a Logitech USB mouse as well and haven't seen any trouble.

You're having problems playing scenarios? I'm inclined to think this might be a video driver problem. Have you updated to 10.6.8?

Share this post


Link to post
Share on other sites

I just noticed this thread and I'd like to add another variable, if I may! :D

Maybe has nothing to do with this problem, but eventually may be related somehow.

I'm playing with full graphic options and VSync enabled and generally I don't notice any lag in the 3D view, but in the Editor I'm presently working on a large map (1120*1600) and if I select the first (from the left) three zoom modes, indeed the pointer has an heavy lag; only if I chose to zoom in with the last two buttons, there's no lag at all...

The above happens both on a laptop and a tabletop, with wireless or USB mouses or using the touchpad.

Share this post


Link to post
Share on other sites
Hmm. I made some specific changes to the mouse handling in 1.01 (back in July / August) that should have cleared problems like this up. I'm playing with a Logitech USB mouse as well and haven't seen any trouble.

You're having problems playing scenarios? I'm inclined to think this might be a video driver problem. Have you updated to 10.6.8?

Well, I was actually running 10.6.7...I updated to 10.6.8 yesterday and noticed a huge improvement. I´ve played around with the demo I´m no longer noticing any mouse lag! If one wants to be picky the "feel" or smoothness of the mouse isn´t the same as in the windows demo, but maybe it´s has more to do with the fact that windows and OSX handles mouse input a bit different?

Anyway, the demo scenarios are playable now! Going to order the full version at last. Thanks for all your help!

Share this post


Link to post
Share on other sites
Guest
Well, I was actually running 10.6.7...I updated to 10.6.8 yesterday and noticed a huge improvement. I´ve played around with the demo I´m no longer noticing any mouse lag! If one wants to be picky the "feel" or smoothness of the mouse isn´t the same as in the windows demo, but maybe it´s has more to do with the fact that windows and OSX handles mouse input a bit different?

Yep! OSX and Windows handle mouse input very differently. It's definitely a different feel. The smoothness is something we'll keep working on.

Anyway, the demo scenarios are playable now! Going to order the full version at last. Thanks for all your help!

Very cool - glad to hear it. Let me know if you need further help!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...