Jump to content
Sign in to follow this  
Dave Mackey

Can Move, Not Attack Following Minimizing.

Recommended Posts

So, I got the Weapons and Warfare expansion in large part b/c it allows me to play the game in a windowed mode so I can swap back and forth between working on things and taking a mind break. I booted up the 1939 Fall Weiss campaign and played my turn, ended it, and switched to my browser. A minute later I switch back and prepare to fight my next turn. I click on one of my units - I can move the unit but I am unable to attack enemy units. I think I discovered a bug. :)

I'm running Windows Vista on a Dell Inspiron 1720 with an Intel Centrino processor and 4 GB of RAM.

Share this post


Link to post
Share on other sites

P.S. I do have video acceleration enabled b/c otherwise it lags so badly my mouse can barely move. Also, when I exited the game using the usual power button it took me back to the main menu but didn't refresh the screen properly - instead it kept the old screen and showed only one button. As I moused over other buttons appeared and I was able to exit....

Share this post


Link to post
Share on other sites

I've tried to repeat all of these and I have not been able to do it, I wonder if you try running in Full Screen mode if it works as expected? I realize you prefer Windowed mode but if it works in Full Screen mode the nice thing is that you can still Alt-Tab back and forth, it just takes a little bit longer to refresh the in game graphics as they are entirely reset when running in Full Screen mode.

Share this post


Link to post
Share on other sites

:-? I'll try the full-screen mode at some point. I'm a huge multi-tasker, so playing full screen isn't really a viable option...but I can survive by reading a book while it is running the computer turn...and hopefully a solution will become apparent at some juncture - maybe it is my video card/driver and there will be an update.

Dave

Share this post


Link to post
Share on other sites

Just a quick update, FYI.

1. I found that if I minimize the game and don't return to it until the next turn begins (which I can tell via the little icon in my taskbar flashing green) then usually it works. Not always, but usually.

2. If I save the game, exit to the main menu, and attempt to load the game again I get a dialog box as it attempts to load the saved game stating:

"FAILED(on_menu_command): Segmentation violation"

When I click okay to the error message SC2 closes out automatically.

3. I can then reload SC2 and load the game without any issues.

I know its not a high priority - but just in case any of this explains why this is occurring and provides a potential fix...It'd be great for me. :)

Dave.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...