Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Sign in to follow this  
voncasey

tech question for cmbb

Recommended Posts

hi

i have been playing cmbb through a couple campaigns with no major problems although i still need to alt-tab to minimize the game when text doesn't show up

this seems to be different

i tried to open the game for a campaign in pbem that we are almost done with and the game starts up either with a black screen playing some music or a screen with very large text on the initial start up screen

and it sometimes says the 'game requires at least 800x600'

playing with xp system sp 3, ati radeon x1950 pro video card, intel core2 duo cpu E4600@2.4 GHz

i was thinking of just uninstalling and reinstalling but thought this may lose our pbem game

thanks

Share this post


Link to post
Share on other sites

iirc you can try deleting the prefs file from the cmbb directory to reset the setting of the game resolution.

If you want to keep you PBEM games (or any other scenarios or mods), just look in the folders in the CMBB directory and copy out the files to another location.

Share this post


Link to post
Share on other sites

I would try deleting the 'Prefs' file first ('Combat Mission BB Prefs'). This should force you to reselect the resolution and vertical refresh rate. It will also default some of your settings for games (FOW, etc.).

Have you possibly updated video drivers or something of that nature. It's strange that you would get such behavior all of a sudden.

The PBEM files themselves are probably fine and should be backed up if you decide to reinstall. Depending on which version of the game you have (1.04 or 1.03), it might be quicker to run the 1.03 or 1.04 patch instead of a full reinstall since my guess would be an issue with the executable file rather than a BMP or WAV file (unless you have a lot of mods installed).

Share this post


Link to post
Share on other sites

thx for the input

i bit the bullet and just uninstalled then reinstalled, now it runs fine again, other than having to do the alt-tab when text doesn't show up in boxes

probably had something change the video settings or corrupt the program

as a sidenote it seems like you don't have to 'unlicense' the software if uninstalling and reinstalling on the same computer because i accidentally didn't and it reloaded fine

thanks again

VC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×