Jump to content
Sign in to follow this  
krischej

Demo crashes on launch

Recommended Posts

So disappointing... watched tutorials 1 & 2, downloaded the HUGE demo file and it won't run, that is, the demo itself. The installer ran just fine.

Upon game launch the screen goes black, the video adjusts mode (I can see it flicker), and then crashes with the usual Mac OS crash message.

Machine info and Log file contents:

Mac OS 10.4.10

1.25 GB RAM

1.5 GHz Intel Core Solo

Log File:

MAIN: Parsing command line

MAIN: Version = 0.9.98

MAIN: Creating prefs folder /Users/john/Library/Application\ Support/DropTeam

MAIN: Executing mkdir /Users/john/Library/Application\ Support/DropTeam

MAIN: Executing mv /Users/john/DropTeamSettings.dat /Users/john/Library/Application\ Support/DropTeam/DropTeamSettings.dat

MAIN: Prefs filename = /Users/john/Library/Application Support/DropTeam/DropTeamSettings.dat

LOBBY: Init'ing SDL

VIDEO: Desktop is at 32 bits per pixel

VIDEO: Setting display 800x600x32

MAIN: Screen is 4 bytes per pixel

MAIN: ACCUM RED = 0

MAIN: ACCUM ALPHA = 0

MAIN: GL VENDOR: Intel Inc.

MAIN: GL VERSION: 1.2 APPLE-1.4.56

MAIN: GL EXTENSIONS: GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_vertex_blend GL_ARB_window_pos GL_ARB_shader_objects GL_ARB_vertex_shader GL_EXT_multi_draw_arrays GL_EXT_clip_volume_hint GL_EXT_rescale_normal GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_APPLE_client_storage GL_APPLE_specular_vector GL_APPLE_transform_hint GL_APPLE_packed_pixels GL_APPLE_fence GL_APPLE_vertex_array_object GL_APPLE_vertex_program_evaluators GL_APPLE_element_array GL_APPLE_flush_render GL_NV_texgen_reflection GL_NV_light_max_exponent GL_IBM_rasterpos_clip GL_SGIS_generate_mipmap GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_multitexture GL_ARB_texture_env_add GL_ARB_texture_cube_map GL_ARB_texture_env_dot3 GL_ARB_texture_env_combine GL_ARB_texture_compression GL_ARB_texture_mirrored_repeat GL_ARB_shadow GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_point_sprite GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_EXT_texture_rectangle GL_ARB_texture_rectangle GL_EXT_texture_env_add GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_lod_bias GL_EXT_abgr GL_EXT_bgra GL_EXT_stencil_wrap GL_EXT_texture_filter_anisotropic GL_EXT_separate_specular_color GL_EXT_secondary_color GL_EXT_blend_func_separate GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_texture_compression_s3tc GL_EXT_texture_compression_dxt1 GL_EXT_blend_equation_separate GL_EXT_packed_depth_stencil GL_APPLE_flush_buffer_range GL_APPLE_ycbcr_422 GL_APPLE_texture_range GL_APPLE_pixel_buffer GL_NV_blend_square GL_ATI_texture_env_combine3 GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod

I did notice that the referenced "dropteamsettings.dat" file does NOT exist at the specified folder path... that was the first thing I went looking for.

As for updating OpenGL... how exactly does one do that on a Mac? The graphics card is built-in (non-upgradeable) and Apple's not providing anything more recent than what I've got.

Share this post


Link to post
Share on other sites

I have an older G4 Mac Mini and I think you have one of the newer Intel ones.

The game runs here without problems (although the machine is too slow for real play)

OpenGL is at 1.3 so 1.5 seems not to be absolutly necessary.

Logfile:

MAIN: Parsing command line

MAIN: Version = 1.3.0

MAIN: Creating prefs folder /Users/markus/Library/Application\ Support/DropTeam

MAIN: Executing mkdir /Users/markus/Library/Application\ Support/DropTeam

MAIN: Executing mv /Users/markus/DropTeamSettings.dat /Users/markus/Library/Application\ Support/DropTeam/DropTeamSettings.dat

MAIN: Prefs filename = /Users/markus/Library/Application Support/DropTeam/DropTeamSettings.dat

LOBBY: Init'ing SDL

VIDEO: Desktop is at 32 bits per pixel

VIDEO: Setting display 800x600x0

MAIN: Screen is 4 bytes per pixel

MAIN: ACCUM RED = 0

MAIN: ACCUM ALPHA = 0

MAIN: GL VENDOR: ATI Technologies Inc.

MAIN: GL VERSION: 1.3 ATI-1.4.18

Maybe you have another problem?

Edit: the logfile is from the full game, not the demo

Share this post


Link to post
Share on other sites

I seem to have a similar problem, also trying to run the DropTeam demo on a new Intel Mac Mini. Is it a graphics card issue? Is there no remedy for this (short of buying a fancier machine with a fancier graphics card)?

If so .... Man, that would be/is a bummer! I've been dying since upgrading to OS X killed my ability to play CM1 or its successors, and was hoping DropTeam would fill in some of that hole. :/

Share this post


Link to post
Share on other sites

Argh, that is a bummer then!

One of the beautiful things about original CM was it ran entirely happily on my old G3 Powerbook -- which was not exactly a graphics cranking powerhouse! Why oh why can DropTeam not be just as happy on my shiny new Mac mini? (That's a rhetorical question, I suppose, given the state of things .... :/ )

Is this because DropTeam intends to be real-time, rather than turn-based like original CM, thereby requiring heftier graphics action? (If so, I liked turn-based CM better than any of the real time games I've seen anyway! tongue.gif )

Man, I loved original CM. I hadn't bought a game for years until that one, and bought it on the strength of the demo as soon as it came out. I'm sad to be missing out on Battlefront's games, but I can't justify buying a whole new machine, Mac or PC, just for a game :(

I guess I'll keep living in hope that something more Mac friendly from Battlefront will come along eventually ....

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...