Jump to content
Sign in to follow this  
poesel

bug: microphone not working under linux

Recommended Posts

The microphone works with two other aplications (audacity and skype) but noone hears me in DT.

I'm pressing 'p', the small window comes, I speak loud and clear, but it doesn't work.

Any idea what I can do?

Edit:

Some bits from the log:

[..]

SOUNDMANAGER: Using default capture device

SOUND CONTEXT ERROR: ALC_INVALID_ENUM

[..]

SOUNDMANAGER: Loading ../data/sound/BackLoop.wav

SOUNDMANAGER: Status: No ALUT error found

SOUNDMANAGER: Sound frequency = 44100

SOUNDMANAGER: Sound channels = 1

SOUND MANAGER: Allocated 54 voices

[..]

SOUNDMANAGER: Loading ../data/sound/chink.wav

SOUNDMANAGER: Status: No ALUT error found

SOUNDMANAGER: Sound frequency = 44100

SOUNDMANAGER: Sound channels = 1

[..]

The last part is repeated whenever a sound is played (at least looks like that).

(I had to delete some '<>' because the forum complained)

Edit II:

I tested again with an USB headset. Same result :(

Oh and btw it would be nice if we could change the output level from inside the game. The USB headset is much louder than my regular and has no regulator...

[ April 22, 2006, 02:14 PM: Message edited by: poesel71 ]

Share this post


Link to post
Share on other sites

Ok, has someone got the microphone working under linux? Could you please tell me your setup?

I'd really like to talk to my teammates.

Share this post


Link to post
Share on other sites

I've just checked in some changes that will probably fix your silent microphone on Linux, Poesel. These will be in the next update.

One thing to watch out for, at least if you have a Creative card, is that you *need* to turn on the Mic Boost in your alsa mixer in order for your team mates to hear you. The mic boost is one of the channels that you can "unmute" with any of the alsa mixer front-ends.

This next update also includes doppler sound on Linux, some fixes to 3D sound attenuation, etc.

Share this post


Link to post
Share on other sites

Turned the mic on with alsamix and even the +20db boost but still noone hears me.

Should I hear myself if I speak with 'p' btw?

Share this post


Link to post
Share on other sites

You won't hear yourself except when playing standalone (which you can't do with this public test build).

Everything's probably configured fine on your end and the next update will have you voice chatting just fine. (The issue was that on some Linux distros we have to use a NULL for the default audio capture device, whereas on others we had to actually enumerate the devices and pick the default one. On the next update, DropTeam should do the right thing for your distro.)

Edit: If the next update doesn't fix this issue for you, then I'll eat a bug.

[ April 23, 2006, 08:54 PM: Message edited by: ClaytoniousRex ]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...