Jump to content
Sign in to follow this  
sargemy

does CMBB run slow for anyone here?

Recommended Posts

hi guys,

I can't figure out why, but when i load up an operation of battle of larger than medium size, the game really lags. When i move around in the battlefield, it skips. Does this game have a problem running on newer machines? B/c Theatre of War runs smooth as hell on my computer.

I have an iMac 20" Santa Rosa platform running windows xp (bootcamp) with 2GB ram, 2.4 core 2 duo, 7.10 catalyst drivers running on mobility radeon hd2600xt.

what computers are other ppl running cmbb on? is there any tweaks I can do to make this game run faster? right now any medium sized map game is even unplayable...it skips too much.

it is very odd considering i have the newest platform...

any suggestions/help appreciated.

thanks,

mike

Share this post


Link to post
Share on other sites

Hey mate I'm sorry about your problems. It would appear that CMBB struggles to run properly (or as it should) on any computer with recent hardware. I've got a fairly new pc build here and it doesnt run at all :( Yet I could run it fine using an old graphics card. It looks like we will have to "downgrade" certain aspects of our systems if you want to play CMBB. I don't know how feasible this would be in most cases. It's very sad.

Share this post


Link to post
Share on other sites

well.

i tried to use the affinity setting and turn off one of the cores. doesnt help.

Also i doubt older version of driver works, I have 7.10, but have tried 7.09, etc.

Plus i like 7.10 because of the optimizations in speed it brings to HD2600 series of cards.

So i have a laptop with an ATi Xpress shared graphics card. would that run CMBB better????

that would be hilarious...

other than that, i don't have old computers lying around my dorm for use :(

Share this post


Link to post
Share on other sites

I think it's more than likely the architecture of the graphics card/driver causing the problem. For example, using this current system I have here, (Vista 32/8800 GTS) it doesn't allow me to play any scenario at all well. I get rewarded with all sorts of corruption and 2 FPS.

With my laptop (Vista 32/7950 Go) it ran perfectly! That was a dual core cpu.

Share this post


Link to post
Share on other sites
Originally posted by sargemy:

So i have a laptop with an ATi Xpress shared graphics card. would that run CMBB better????

that would be hilarious...

other than that, i don't have old computers lying around my dorm for use :(

Probably.. As funny as it sounds I can run CMBB perfectly well on a ultra portable laptop with an Intel GMA 950 (I think it is?) It's an integral VGA card basically.

Share this post


Link to post
Share on other sites

My new build: intel E6750, gigabyte P35-DS3R mb, 8800 GT 512 mb, 2 gig DDR2 @800, XP pro, runs CMBB perfectly at 1280x960, 16xAA, 16xQ FSAA.

I understand there were some technical issues with Vista, but no problem under XP.

Keep in mind, however, that a large enough scenario can still bring even a new rig to its knees. CMBB can be very CPU intensive.

Share this post


Link to post
Share on other sites

how do u get a resolution above 1024x768?

by the way, so CMBB runs smooth as hell on my celeron 1.6 laptop with radeon xpress 200M LOL LOL...

but it lags like hell on my mobility HD2600XT with core 2 duo 2.4 LOL

anyways yeah my laptop support 1280x800, is there a way i can get that resolution so things don't look so fat?

thanks

Share this post


Link to post
Share on other sites
Originally posted by sargemy:

how do u get a resolution above 1024x768?

by the way, so CMBB runs smooth as hell on my celeron 1.6 laptop with radeon xpress 200M LOL LOL...

but it lags like hell on my mobility HD2600XT with core 2 duo 2.4 LOL

anyways yeah my laptop support 1280x800, is there a way i can get that resolution so things don't look so fat?

thanks

in your CMBB folder you will find a file called cmbb.prefs or something similar, delete it or if you are unsure rename it cmbb.prefs_old.

when you restart cmbb, you will get a successive choice of resolutions and refresh rate, choose the one you want and a new cmbb.prefs file will be created.

Share this post


Link to post
Share on other sites
Originally posted by Sgt.Joch:

My new build: intel E6750, gigabyte P35-DS3R mb, 8800 GT 512 mb, 2 gig DDR2 @800, XP pro, runs CMBB perfectly at 1280x960, 16xAA, 16xQ FSAA.

I understand there were some technical issues with Vista, but no problem under XP.

Keep in mind, however, that a large enough scenario can still bring even a new rig to its knees. CMBB can be very CPU intensive.

That's very interesting! I was under the impression it was a problem with the 8800 rather than Vista? So you've got one of these new 8800 GT's and you haven't got a problem?

Reason I say this is that I was able to play CMBB with my Vista 32 with a 7950 without problem but I can't play it at all well with my Vista 32 and 8800 GTS.

Share this post


Link to post
Share on other sites

I couldn't resist trying something out - I needed to format my pc, so I decided to reinstall XP Pro SP2 rather than Visa Premium.

CMBB now runs PERFECTLY with my 8800 GTS.

So in my opinion it is a combination of two things at fault - it is primarily the lack of support from Nvidia - the cards WORK, the drivers do not. Secondly blame Microsoft for releasing such a shoddy O/S called Vista. I still can't quite believe just how bad it is. But at least I have my favourite game up and running at long last!

Share this post


Link to post
Share on other sites

Phil, my newfangled 8800 GT runs CMBB, CMAK and CMSF beautifully with no technical issues whatsoever with 32 bit XP pro.

from what I read in this and other boards, a lot of the technical issues with the 8800 series seem to be due to VISTA drivers, especially VISTA 64 bit drivers, part of the reason why I am in no hurry to upgrade (or downgrade ;) ) to VISTA.

Share this post


Link to post
Share on other sites

Hey,

just a question, when i delete the preference file, i do get a black screen asking me to choose a resolution. but the maximum it shows is 1024x768, and not the native my monitor supports, which is 1280x800. I cycled through all of them.

Share this post


Link to post
Share on other sites

@ sargemy

What I find is that if my desktop is set at 1024x768 when I launch CMBB (after deleting preference file) then 1024x768 is the first choice that comes up then the lower resolutions but not higher ones.

If I set desktop to 1600x1200 and then launch (after deleting file again) then it offers me that resolution first and then all lower resolutions.

So try setting desktop to 1280x800 before launching and you should get that choice.

Share this post


Link to post
Share on other sites

It seems to be an issue with the new hardware of today.

- Go to Computer /
- Local disk C: or similar, varies upon computer. This is where your game files are saved. If you have trouble finding this, right click the launcher shortcut you have on your home screen and select 'open file location'. This will take you to the next step.
- Program Files (x86) /
- CMBB (your game files) /
- Right click the launcher called 'Barbarossa to Berlin'  and select properties.

Paraphrasing - Computer / Local disk C: / Program Files (x86) / CMBB - right click CMBB and select properties.

Select compatibility, and tick the box for 'run this program in compatibility mode for:' Select the Windows XP (Service pack 3) option. Additionally tick the box below 'run this program as an administrator'.

Then, launch the game and once in a mission, alt-tab out of the game, and then alt-tab back in (this is minimizing the game, and then reopening it). I know this sounds weird but if you do this every time you enter a mission you wont suffer any issues with extremely low frame rates or similar issues, and it takes a few seconds to do. 

Good luck - xXmush.


Apologies to you people with a bit more knowledge about file directories and such. I made an easy to follow guide that people of all generations and level of PC knowledge can understand :). I would imagine quite a few people of all ages would enjoy the tactical masterpiece and historical recreation that is the Combat Mission games. I have loved them ever since I was a kid, and was really sad at first when these games didn't seem to run on newer operating systems.

Share this post


Link to post
Share on other sites

Hi Guys, I revived this thread since I decided to try the game after a long time.  Wow, very slow, I did run the game as admin, windows xp3 compatible and it seems to run a little better.  Any other suggestions?  I am using a nvidia 1070 card, I just went back into the game, playinga tiny map and wow this game doesn't move that fast as it used to.

 

I just tried the afrika korp game as well.  slow and choppy a little better after doing the alt-tab in the scenario but way different than the old days.  Too bad the game is not running on the new machine like it did back in the day.

Edited by huhr

Share this post


Link to post
Share on other sites

I suggest you get back into an older Computer...

I use a Dell OptiPlex Desktop (2010 time frame) Quad-Core w/ATI 1GB, Win 7. Also I use a Dell Laptop (2007 time frame) Core2 Duo w/Nvidia 140 256MB integrated, Win XP...Desktop works great for both CMx1 & CMx2, but Laptop has slight lagging for bigger size battles (but, still good for smaller battles).

 

Edited by JoMc67

Share this post


Link to post
Share on other sites
On 12/10/2017 at 2:13 PM, TheGreatRadish said:

Just to confirm, with the latest version of DDraw fog is present in CMBB on my new machine running Win 10, i5-8400, GTX 1060.  Excellent :-)

I just tried DDraw on my Windows 7 desktop and now fog shows up for CMBB. Many thanks for that tip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×