Jump to content
Barrold

CMRT Unit Names Remain Stubbornly Hosed!!!

Recommended Posts

After some time away from CM, I am trying to get a good install of all the products on my PC.

I downloaded all the updated files and did appropriate extractions. 

After installing CM:RT I am getting mixed up unit names.

I have gone through and ensured there is not a single trace of the previous time I installed.  I even went through the registry and deleted every single instance of "combat" related to the CM games.

When I do a fresh install...the unit names are still hosed.

Where can that @#$%%* file still be?

Share this post


Link to post
Share on other sites

Make sure that the installation directory where the CMRT installer files are at has ONLY the following files (once they've been extracted from the .zip format that they are downloaded in):

CMRT_v103_Setup.exe

red thunder v100a.brz

red thunder v100b.brz

red thunder v100c.brz

red thunder v100d.brz

red thunder v101.brz

If there are other files present in the installation directory it MIGHT corrupt the installation in the manner that you're seeing.

Share this post


Link to post
Share on other sites
4 hours ago, Schrullenhaft said:

Make sure that the installation directory where the CMRT installer files are at has ONLY the following files (once they've been extracted from the .zip format that they are downloaded in):

CMRT_v103_Setup.exe

red thunder v100a.brz

red thunder v100b.brz

red thunder v100c.brz

red thunder v100d.brz

red thunder v101.brz

If there are other files present in the installation directory it MIGHT corrupt the installation in the manner that you're seeing.

All righty

I am installing version 2.0 and patching to 2.01

I have these files after a fresh extraction of the file I downloaded in May from my Battlefront account
CMRT  v200 installer.exe

CMRT v200 installer-1.bin

RT v100a.brz

RT v100b.brz

RT v100c.brz

RT v100d.brz

RT v101.brz

RT v104.brz

RT v200.brz

Is that .bin the potential problem?

Thanks for the response.

BDH

****UPDATE***  I just did the install without patching to 2.01 and the names are correct!

Previously I did have my other game folders with installation files extracted and I deleted them before doing this install.  When I extract those I am going to make sure I keep them well away from my RT folders as a precaution.

Now to patch to 2.01 and see what happens!

BDH 

 

Edited by Barrold
Update

Share this post


Link to post
Share on other sites

It's the patch! :angry:

When I extracted the files from the RAR the file name for the .brz had "CM Red Thunder Update 202" in front.  So I changed the names to make the brz files uniform and copied them over to the data folder.  When I went back into the game, the unit names are now correct.

That took too much work but I feel I learned something today.

Now let's see how the rest of these go.

BDH

Share this post


Link to post
Share on other sites

?? The patches are are shipped as an install so you should not be renaming anything.

Any package you get from BFC should be unzipped into a clean empty folder. Then run the setup program in that new folder. For a patch make sure it has found your install and let it do the work.

Share this post


Link to post
Share on other sites
12 hours ago, IanL said:

?? The patches are are shipped as an install so you should not be renaming anything.

Any package you get from BFC should be unzipped into a clean empty folder. Then run the setup program in that new folder. For a patch make sure it has found your install and let it do the work.

I hear ya.  I downloaded the RAR files and extracted them into their own folders.  I then put the update itself in another folder.

Those files had the name of the installer file as a pre-fix to the .brz and did not match the various version .brz in the data folder for the games.

Every time I installed the patch before I caught these erroneously named .brz were in copied to the data folder.

What fixed the issue was to edit the file names to match the name in the current game data folder and then install the patch .exe

Each module I followed that process worked just fine.  No more foxholes labeled as Wolverines.

I do have to put in a ticket to help resolve the activation issues I am having for CM:FI and Gustav Line though.

Of course I need more time to play but work is the curse of the gaming class.  

 

Share this post


Link to post
Share on other sites
11 hours ago, Barrold said:

I hear ya.  I downloaded the RAR files and extracted them into their own folders.  I then put the update itself in another folder.

Sounds right.

11 hours ago, Barrold said:

Those files had the name of the installer file as a pre-fix to the .brz and did not match the various version .brz in the data folder for the games.

Every time I installed the patch before I caught these erroneously named .brz were in copied to the data folder.

What fixed the issue was to edit the file names to match the name in the current game data folder and then install the patch .exe

Each module I followed that process worked just fine.  No more foxholes labeled as Wolverines.

That is strange. This files with the different names are used by the installer to extract the needed files for the final install. You shouldn't need to rename them at all it should happen automatically. Very weird.

11 hours ago, Barrold said:

Of course I need more time to play but work is the curse of the gaming class.  

Sigh it sure is.

Share this post


Link to post
Share on other sites

If you have to do this with other modules/games then I'm guessing its a setting in your file manager software. I use 7-zip on Windows 7 with no problems, what are you using? Seems they are being auto-renamed.

Share this post


Link to post
Share on other sites
7 hours ago, MeatEtr said:

If you have to do this with other modules/games then I'm guessing its a setting in your file manager software. I use 7-zip on Windows 7 with no problems, what are you using? Seems they are being auto-renamed.

That could very well be it.  I switched to a different program when I was having problems unpacking an update for a Fields of Glory mod and that resolved the issue as well.

 

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...