Jump to content
BFCElvis

Patches for the 4.0 Upgrades are now available

Recommended Posts

1 hour ago, JSj said:

CMFB base game, then 1.02, then the 2.00 upgrade, and finally the current 2.01. Could I have skipped some of these installs? Could I have gone from the base game directly to 2.00, for instance?

At some time (might even be now - not sure) the all in one installer will be updated to CMFB 2.01 then you can download that installer and install the game fully patched from nothing right away. At the time the patches were announced the all in one installer was still at v2.00 which would have saved you one step.

Share this post


Link to post
Share on other sites
31 minutes ago, BFCElvis said:

Here is a link to an article about Error 501. It should be helpful

https://battlefront.mojohelpdesk.com/help/article/128015

Ack that article says to email sales @ don't do that for goodness sake . com. You might want to change those instructions to something about contacting support via the new ticket button.

Share this post


Link to post
Share on other sites
1 hour ago, IanL said:

At some time (might even be now - not sure) the all in one installer will be updated to CMFB 2.01 then you can download that installer and install the game fully patched from nothing right away. At the time the patches were announced the all in one installer was still at v2.00 which would have saved you one step.

Ok, good to hear. Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, IanL said:

Ack that article says to email sales @ don't do that for goodness sake . com. You might want to change those instructions to something about contacting support via the new ticket button.

YIKES!!! Good catch. Fixed it. 

Share this post


Link to post
Share on other sites
4 hours ago, JSj said:

I did a new install, and it went smoothly. Everything works now. By the way, when doing a new install, do you need to install all patches again, or can you skip some? I installed the CMFB base game, then 1.02, then the 2.00 upgrade, and finally the current 2.01. Could I have skipped some of these installs? Could I have gone from the base game directly to 2.00, for instance?

Also, are there newer, updated install files for the base game available with some patches integrated, or is the base game installer the same as when the game was released? I did this from an old install file for the base game that I had saved on my computer.

Every game using the Game Engine 4 (and 3 for CMBN) have all-in-one full game installers which install everything through the most recent patch. Never drive yourself nuts with the step by step installation again. 

Share this post


Link to post
Share on other sites
2 minutes ago, BFCElvis said:

Every game using the Game Engine 4 (and 3 for CMBN) have all-in-one full game installers which install everything through the most recent patch. Never drive yourself nuts with the step by step installation again. 

Thanks. It was quite smooth though, I just ran the installers one after the other. Where can I find the latest full game installer? When I look under "My Orders" on the site, the base game seem to have a file called "CM Final Blitzkrieg Engine 3 CMFB-BGV3". Then there is the file "CMFB Upgrade 4 CMFB-UPV4" listed under my order for the upgrade to engine 4. But this order has the 10$ price listed, so this seems to just be the upgrade, not a full installer? Both are links to files at battlefront.sharefile.com.

Share this post


Link to post
Share on other sites
2 minutes ago, JSj said:

Thanks. It was quite smooth though, I just ran the installers one after the other. Where can I find the latest full game installer? When I look under "My Orders" on the site, the base game seem to have a file called "CM Final Blitzkrieg Engine 3 CMFB-BGV3". Then there is the file "CMFB Upgrade 4 CMFB-UPV4" listed under my order for the upgrade to engine 4. But this order has the 10$ price listed, so this seems to just be the upgrade, not a full installer? Both are links to files at battlefront.sharefile.com.

In your 4.0 link you will see 4 download options. 2 Mac and 2 Windows. for each platform one is just the 4.0 Upgrade and the other is the full game installer.

Share this post


Link to post
Share on other sites

After uploading the new patch CMFI is not stable or other CM I do not know. When viewing maps in the editor, the crash often follows.

It was never before, CM was super stable.

Share this post


Link to post
Share on other sites
2 minutes ago, BFCElvis said:

In your 4.0 link you will see 4 download options. 2 Mac and 2 Windows. for each platform one is just the 4.0 Upgrade and the other is the full game installer.

Ok, thanks, I see now. I thought the links was just for downloading of a single file.

Share this post


Link to post
Share on other sites
On 5/7/2019 at 8:07 AM, Migo441 said:

Question about patching.  I've applied the CMRT 2 Engine 4 patch to get me from v2.0 to v2.1.  However, I'm now unable to open a saved game from the previous version...  To be clear, a game saved during planning phase and not a PBEM file where a movie is launching.

The behavior is that the load screen progresses to 25% and then the app crashes and I'm back to my desktop.  Initially I not re-activated with my licence but the experience is the same once I did re-activate.

Is this something people have seen before?  What's the recommendation?  Uninstall and reinstall?

Having the exact same issue with my saved games in CMRT, gets to 25% then either crashes or sets there and never progresses.

I always have multiple battles saved so I can switch around and not get to bored by one. Guess I have a lot of replaying to do.

Share this post


Link to post
Share on other sites
11 hours ago, Mudhugger said:

Having the exact same issue with my saved games in CMRT, gets to 25% then either crashes or sets there and never progresses.

I always have multiple battles saved so I can switch around and not get to bored by one. Guess I have a lot of replaying to do.

That appears to be the case with CMRT. The other titles don't appear to have a problem moving saved copies from before the patch to the patched version. But there seems to have been something that changed significantly with CMRT that causes a conflict with previous versions (my guess would be a TO&E change/conflict). I have a PBEM with Peng and we're about a third of the way into a long battle and I'm in the same boat. Our CMFB game advanced just fine.

While it doesn't happen often that patching a game can't advance pre-patched saves it isn't unprecedented. The 2 options are:

1) Install a non-patched version and run with 2 installed versions until you've completed the battle(s)

2) Revert the version to the pre-patch version and then patch up when the battle is finished. To revert your version, simply re-install the 4.0 Upgrade. 

Share this post


Link to post
Share on other sites
5 hours ago, BFCElvis said:

2) Revert the version to the pre-patch version and then patch up when the battle is finished. To revert your version, simply re-install the 4.0 Upgrade. 

In this case I think you'll want to insure the 4.01 brz is deleted as well.

Share this post


Link to post
Share on other sites
5 hours ago, BFCElvis said:

That appears to be the case with CMRT.

OK, understood!  Bummer, but I find that's it's not too onerous to have two installations so as to finish ongoing battles and also be able to start new ones with the latest patch.

Somehow we'll survive.  😛

Share this post


Link to post
Share on other sites
11 minutes ago, sburke said:

In this case I think you'll want to insure the 4.01 brz is deleted as well.

There is no "4.01 brz" for Red Thunder. It is v201.brz. 

Share this post


Link to post
Share on other sites
2 minutes ago, sburke said:

ack I stand corrected

🙂 I wasn't trying to be anal or show off my low grade OCD....I just didn't want someone pulling their hair out searching for a file that doesn't exist.

Share this post


Link to post
Share on other sites
1 minute ago, BFCElvis said:

🙂 I wasn't trying to be anal or show off my low grade OCD....I just didn't want someone pulling their hair out searching for a file that doesn't exist.

:D

 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks, BF, for the 4.0 Patch Fix :-)

Keep in mind, BF Forumites, you will need to take out 'Vin's Animated Text' for all your Titles (and re-do it, or he may come along and re-do it at some point) or you will see wrong names for your Units.

Joe

Edited by JoMc67

Share this post


Link to post
Share on other sites
Posted (edited)

I've only tried so far to patch Fortress Italy, with the Gustav bundle, and it's already a nightmare.  After applying the fortress Italy serial I get 'License Failure Game Engine 4 required' even though I was already running engine 4.  It won't even let me apply the Gustav serial, saying 'Invalid Serial Number'.

So thats 1 out of 6 installs already ruined by these patches, I think I'll take a rain check on the rest for now.  I dread to think what a mess CMBN will end up in. 

I've raised a ticket, but from the customers perspective I don't understand why I have to navigate through a minefield of different version numbers to arrive at the latest version and engine for each game.

Edited by Majick

Share this post


Link to post
Share on other sites

You don't. Every game now has a full installer so no steps. You can download it from your order in the order list. But if you have a working game then applying the patch is just one easy step.

You should never need to activate the license for a patch so I have no idea why that happened but support will get you sorted I am sure.

Share this post


Link to post
Share on other sites

Well if you had a working fortress Italy then just installing the patch should have been painless.

If you are stuck now then starting over with a single installer could be helpful. My main point is if you are doing a fresh install never do the six steps of content installs. Those days are over.

Your licensing issues will not be resolved by this though. For that you need the pros. My recommendation is follow the instructions you get from support.

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks very much to John on support, I'm now able to carry on installing these updates (I was using the wrong activation module...)

However, CMBS requires a 'black sea v103.brz' file.  This does not exist in any of my directories or on any of the updates from Battlefront.  Has anyone else had this issue?

Edited by Majick

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...