Jump to content
Bulletpoint

Vertical sync: Fast (Half refresh rate) no longer works

Recommended Posts

I used to be able to select vertical sync: fast (half refresh rate) to improve performance in CM, but it no longer works. The game runs with variable FPS up to my monitor maxium, and I get plenty of tearing.

Did something change in the latest Nvidia drivers?

Share this post


Link to post
Share on other sites
6 hours ago, Bulletpoint said:

I used to be able to select vertical sync: fast (half refresh rate) to improve performance in CM, but it no longer works. The game runs with variable FPS up to my monitor maxium, and I get plenty of tearing.

Did something change in the latest Nvidia drivers?

Do you use Nvidia Inspector to select those options?  If not, that is how I force the selection (only way I can actually).

Share this post


Link to post
Share on other sites
15 minutes ago, Blazing 88's said:

Do you use Nvidia Inspector to select those options?  If not, that is how I force the selection (only way I can actually).

No, it's in the Nvidia control panel.. under the 3D settings for the specific game

Share this post


Link to post
Share on other sites
7 hours ago, Bulletpoint said:

I used to be able to select vertical sync: fast (half refresh rate) to improve performance in CM, but it no longer works. The game runs with variable FPS up to my monitor maxium, and I get plenty of tearing.

Did something change in the latest Nvidia drivers?

I have a weird issue with half refresh rate. It only works if I restart my laptop from windows using the restart option. If I turn it off and then on it wont work.  So everytime I play a CM title I restart.

Share this post


Link to post
Share on other sites

I had an issue a month or so back where the Nvidia settings would only work for CM after a system reboot & CM was the first program you started.

Whatever it was seems to have gone away.

 

Share this post


Link to post
Share on other sites
4 hours ago, Bulletpoint said:

No, it's in the Nvidia control panel.. under the 3D settings for the specific game

Not everyone has that option, pending the type of Nvidia card (like me for example on my laptop).  My desktop Nvidia card has that option.

That is why I suggested using Nvidia Inspector to select the half refresh option, as it's not an end all if it's not in your Nvidia Control Panel.

Share this post


Link to post
Share on other sites

One other tip, if you happen to have no vsync but still have reshade, you can turn on one or two expensive but not particuarly noticeable effects (say Ambient light) which will decrease your fps below your monitors refresh-rate.

I started turning all vsync off deliberately, as an experiment, only very recently... but my results are pretty positive so far.

Remember, half refresh rate decreases the size of your "high-detailed visual bubble/draw distance"... a considerable drawback of reducing your fps too much.

Share this post


Link to post
Share on other sites
7 hours ago, Blazing 88's said:
12 hours ago, Bulletpoint said:

No, it's in the Nvidia control panel.. under the 3D settings for the specific game

Not everyone has that option, pending the type of Nvidia card (like me for example on my laptop).  My desktop Nvidia card has that option.

That is why I suggested using Nvidia Inspector to select the half refresh option, as it's not an end all if it's not in your Nvidia Control Panel.

That's interesting. I am also playing on a laptop, but I do get the option (which then doesn't work..). Maybe the Nvidia Inspector would allow me to force the driver to do it?

Share this post


Link to post
Share on other sites

It should, does for me.  After setting it in the Nvidia Profile Inspector and applying the changes, it should show up in the Nvidia Control Panel as Vertical sync: Custom (at least for me it does).

Share this post


Link to post
Share on other sites

The latest 418.x driver is faulty. It has messd many peoples comps including mine. If you go over to official Nvidi driver forum you will see people talk all kinds of horror stories about what happened to them after they updated their drivers. My monitor for example does not work right any more - my viewing space on the monitor has shrinked by 1 cm on each side of the monitor.

I rerolled the drivers, DDU-ed them in safe mode and installed some older ones but so far the problem persists.Many users do report their problems got away as soon as they instelled the older driver so try it and se if you get your fast vsync back.   

Share this post


Link to post
Share on other sites

One of the main reasons I update the video cards manually.  Also, I am not one to just update them right away anyways.  If all is working well.....

Share this post


Link to post
Share on other sites
15 minutes ago, Blazing 88's said:

One of the main reasons I update the video cards manually.  Also, I am not one to just update them right away anyways.  If all is working well.....

I never and I man never had such a global driver issue and I have been using a PC since I was 10 years old. That makes for 20 years of no problems in that department where you don't even think not to update as soon as the official driver pops up.(Yea I know, Nvidia's drivers weren't around back then but still...).   

Share this post


Link to post
Share on other sites
3 hours ago, Hister said:

The latest 418.x driver is faulty. It has messd many peoples comps including mine. If you go over to official Nvidi driver forum you will see people talk all kinds of horror stories about what happened to them after they updated their drivers. My monitor for example does not work right any more - my viewing space on the monitor has shrinked by 1 cm on each side of the monitor.

I rerolled the drivers, DDU-ed them in safe mode and installed some older ones but so far the problem persists.Many users do report their problems got away as soon as they instelled the older driver so try it and se if you get your fast vsync back.   

Good thing then that my GEFORCE program, that usually reminds me of drivers, stopped working altogether a week ago, preventing me from updating to this crap driver. I'll stick with what I have from now on.

Share this post


Link to post
Share on other sites
11 hours ago, Hister said:

The latest 418.x driver is faulty. It has messd many peoples comps including mine. If you go over to official Nvidi driver forum you will see people talk all kinds of horror stories about what happened to them after they updated their drivers.

Oh darn. I just installed the latest driver yesterday, thinking it might resolve the problem...

Share this post


Link to post
Share on other sites

Ah so they made a new driver yesterday, I missed it. They might have solved the problems introduced in the previous one with this one. I will try how it goes, wanna get my full monitor surface back.

Share this post


Link to post
Share on other sites
2 hours ago, Hister said:

Ah so they made a new driver yesterday, I missed it

I don't think they released it yesterday; I just had not updated my driver in a long time (if it is not broken, do not try to repair it)

Share this post


Link to post
Share on other sites

I've only installed one new driver since I installed this card in Febuary 2017 and that was to see if I could stop Grim Dawn from crashing after two hours of play. It didn't help but started making CM crash. So,  early last year I rolled back to that December 2017 driver and everything works fine. I haven't had any CM crashes and every game I own plays without a hitch except for Grim Dawn. But for the record I NEVER install new drivers unless I absolutely have to. There's no point if everything is working ok.

 

Mord.

Edited by Mord

Share this post


Link to post
Share on other sites

If you have more then hundred games installed on your PC and among those games many recent that haven't gotten a proper driver support yet, then you need the latest drivers.

 

If you sport only old and older non recent games then sure, you can install an older Nvidia driver and forget all about it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×