Jump to content
Sign in to follow this  
Cambronne

shaders

Recommended Posts

I forgot to say that the same redish vehicles also appear in Red Tunder(and probably would have in CMBN, but I haven't upgraded it so I can't tell). Is there any shaders mod to look for or should I dig deeper into the nvidia settings?

Share this post


Link to post
Share on other sites

You may be better served with calibrating your monitor first on your desktop (using a reference photo) until satisfied with the warmth/coolness of the display. The default color profile is usually designed to grab one's attention in a fluorescent warehouse store. You should be able to switch settings fairly easily  on the front panel of your monitor.

Failing the above, your video driver color space settings can be tweaked.

Share this post


Link to post
Share on other sites

In fact It may be the shadows that are creating the problem, I don't know. Turning the shadows off eliminates the red nuance on the vehicles, regardless if the shaders are on or off. Perhaps it is the simulation of the sun reflection on the vehicle body, but it gives a slightly redish nuance.The issue persists even in overcast weather when there is no shadow. At night, the normal color appears only when the artificially bright night graphics are off. Otherwise the shadows or the shaders have to be turned off  in order to avoid the red brightness. Does anybody else encounter this issue? If yes, it may be from the game engine and I can stop looking for a fix.

Share this post


Link to post
Share on other sites
On 1/8/2019 at 1:55 PM, Cambronne said:

up:shader off, down shaders on

Sorry, forgot about this.

I just checked. Nope, mine stays the same color. I turned on shaders with shadows, shadows without shaders and everything off, no change in the hues. Are you using Reshade? I tested it with Reshade and didn't have any problems either but your settings could be different than mine.

 

Mord.

Share this post


Link to post
Share on other sites

No reshade . Vanilla CMSF2. I have the same problem with the other titles I own, do you think there is something I could do with the Radeon videocard settings? I looked into it but I didn't figure what to change. The monitor seems to be calibrated.

Share this post


Link to post
Share on other sites

The cause is the AMD specific shader code from BFC and not your video driver. As a Radeon user myself; I've found ReShade to be worth the hassle to use as it provides a safe means of overwriting/supplementing the aforementioned shaders.

Unfortunately, the Radeon settings for Color are Display based and will have  wider ramifications outside of CM. Best to avoid as you are happy with your color as it is.

You'll also need to keep Shaders ON. Otherwise, you'll lose the hit decals and see white, or off color, dots/holes in their place.

Share this post


Link to post
Share on other sites

Thank you. I tried to use reshade using Mord's step by step tutorial (thanks Mord for sharing it) but I got stuck when I tried to check Tint [Sepia.fx]. It failed to compile and when I went to statistics to find out what was up I saw the messages from the picture attached.

screenshot.bmp

Share this post


Link to post
Share on other sites

You're welcome. My settings weren't written in stone, just a jumping off point to get people started.  Skip the sepia setting and see what happens.

I used to be a diehard AMD guy, for nearly twenty years. But when I built my rig (my first ever hand built) I went with Intel (the new Ryzen stuff wasn't out yet). I agonized over that choice, waiting or just taking a leap of faith. I am glad I did cause I see a lot of people having problems with AMD stuff when it comes to CM. Though I did have to roll back my Nvidia drivers so the game wouldn't crash after a couple hours.

 

Mord.

Edited by Mord

Share this post


Link to post
Share on other sites
30 minutes ago, Mord said:

You're welcome. My settings weren't written in stone, just a jumping off point to get people started.  Skip the sepia setting and see what happens.

I used to be a diehard AMD guy, for nearly twenty years. But when I built my rig (my first ever hand built) I went with Intel (the new Ryzen stuff wasn't out yet). I agonized over that choice, waiting or just taking a leap of faith. I am glad I did cause I see a lot of people having problems with AMD stuff when it comes to CM. Though I did have to roll back my Nvidia drivers so the game wouldn't crash after a couple hours.

 

Mord.

I did. The same message for all: Failed to compile.

 

26 minutes ago, Howler said:

Download this utility to verify your supported OpenGL version http://realtech-vr.com/admin/glview.

Looks like it may be a version mismatch of some kind.

I did. After running the program I got this:(in attachement)

screenshot.bmp

Share this post


Link to post
Share on other sites

How about the driver on your vid card? Maybe roll it back to an earlier version? That's what I had to do.

 

Mord.

Share this post


Link to post
Share on other sites

Your Radeon drivers need to be updated. ReShade likes to have OpenGL 4.5 for the more exotic shaders.

I'm running version 18.11.22 which is only a couple of incrementals behind the latest.

Share this post


Link to post
Share on other sites

hello ...hehehe... my video driver was from 2015. I just updated it to the latest (2 days old) and everything is working fine right now. The redish brightness is gone and I can fully enjoy the graphics without installing reshade. Thank you for your time Mord and Howler.

Share this post


Link to post
Share on other sites
3 hours ago, Cambronne said:

Thank you for your time Mord and Howler.

AWESOME! Glad we could help you. Updating was gonna be my next suggestion. Howler was smarter and faster!

But man, eventually you should try Reshade. It rules!

Have fun, man!

Mord.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...