Jump to content
tavichh

Horrible frames. Getting frustrated.

Recommended Posts

Back to CMSF2/ReShade 4.1, stationary camera (#2).

Fastest 28 FPS (~ 35ms)

Balanced 28 FPS (~ 35ms)

Improved 25 FPS (~ 40ms)

Best  17 FPS (~ 60ms)

Running again with ReShade off yielded:

Fastest 31 FPS (~30ms)

No Change to Balanced or Improved

Best 20 FPS (~ 50ms)

Above was run by changing 3D Model setting in game and rewinding the turn. I believe slightly better results would be had if one was to set the quality in the menu and then loading a save...

I'll try to determine the size of detail bubble next. Again, I'm consistently seeing significant drop between 'balanced' and 'best'.

Share this post


Link to post
Share on other sites

Last post today on this matter. Promise.

Bubble Best/Balanced/Fast:

Camera #2 locked on unit - 600m/240m/100m

Camera #3 locked on unit - 340m/200m/220m

Camera #5 locked on unit - 50m/0m/0m

Turning around a locked unit using the rotate hotkey (eg 'Q') a couple of times as Best/Balanced/Fast in FPS:

Camera #2 - 25/45/40

Camera #3 - 20/30/35

Camera #5 - 30/45/60

In all cases, holding down the Rotate Left key ('Q') for more than a couple of complete turns resulted in the FPS counter shooting up which seems to indicate caching...

The bubble presented as a cone and I opted to measure the shortest distance. Save game used was 'Factory Outlet'. Finally, the ReShade FPS counter was used as AMD does not provide one.

More importantly, the response is smooth. Zoom and camera movement is immediate. Turning off the AA in-game and in the video driver has eliminated any lag.

Share this post


Link to post
Share on other sites
5 hours ago, Howler said:

 Further, changing the model detail while in game skews the number. I've had faster renders at every setting when you set the detail in the option menu then load the save game.

I very much doubt you'll be regularly getting 300-400m bubbles playing on giant complex maps like the Bridgehead... not unless one has an overclocked, liquid nitrogen cooled CPU (CM IS CPU intensive not really graphics card intensive, pure Gigahertz aids the game more than anything).

For such maps, it's a matter of finding that happy balance between a sufficient "visual bubble" for your play & your fps... playing on 3d Model Quality 'best' was always likely going to be a struggle on such a map.

I'm glad that I'm not the only one who's found turning off all AA & reducing your 3d Model quality can be of assistance to smooth play.

 

BTW

You can use Reshade to "reload" a scene from scratch so you don't have to go back to the option menu everytime... I suppose you could also alt-tab & click back to CM.

Share this post


Link to post
Share on other sites
1 hour ago, 37mm said:

For such maps, it's a matter of finding that happy balance between a sufficient "visual bubble" for your play & your fps... playing on 3d Model Quality 'best' was always likely going to be a struggle on such a map.

Agreed. You've got me now trying 'balanced' to see if the larger maps become playable.

1 hour ago, 37mm said:

You can use Reshade to "reload" a scene from scratch so you don't have to go back to the option menu everytime... I suppose you could also alt-tab & click back to CM.

Any comments I made regarding the option menu were based on my assumption that setting the 3D model in the options, as opposed to the hotkey in-game, may produce more accurate FPS measurement. One then starts or loads a game without concern for stale buffers/caches.

In any event, my numbers were measured first by using the hotkey and then rewinding the turn. I therefore loaded a save game once and never exited the game between measurements for the various 3D model settings.

Share this post


Link to post
Share on other sites

We can only hope one day, we get a graphics engine even at this level. I've upgraded to a i7-9700K@4.9GHz and an EVGA RTX 2080 Ti XC Ultra and still get terrible fps! Talking hitting 20fps and below on just a simple medium hills quick battle, not even with many trees. Super sluggish and laggy camera movement. lol!

IL-2 Sturmovik - Tank Crew

https://www.youtube.com/watch?v=fwkTxyh21-g
https://www.youtube.com/watch?v=3tQVifFTGKY
https://www.facebook.com/il2sturmovik/posts/2026223027455545?__tn__=K-R

 

 

Edited by AstroCat

Share this post


Link to post
Share on other sites
26 minutes ago, AstroCat said:

We can only hope one day, we get a graphics engine even at this level. I've upgraded to a i7-9700K@4.9GHz and an EVGA RTX 2080 Ti XC Ultra and still get terrible fps! Talking hitting 20fps and below on just a simple medium hills quick battle, not even with many trees. Super sluggish and laggy camera movement. lol!

IL-2 Sturmovik - Tank Crew

https://www.youtube.com/watch?v=fwkTxyh21-g
https://www.youtube.com/watch?v=3tQVifFTGKY
https://www.facebook.com/il2sturmovik/posts/2026223027455545?__tn__=K-R

 

 

thanks for posting! Didn´t yet have that on the radar! Looks very very promising. B)

http://simhq.com/forum/ubbthreads.php/topics/4435032/tank-crew-clash-at-prokhorovka

Share this post


Link to post
Share on other sites
51 minutes ago, AstroCat said:

We can only hope one day, we get a graphics engine even at this level. I've upgraded to a i7-9700K@4.9GHz and an EVGA RTX 2080 Ti XC Ultra and still get terrible fps! Talking hitting 20fps and below on just a simple medium hills quick battle, not even with many trees. Super sluggish and laggy camera movement. lol!

 

You have twice the CPU power I have & when I first started with CMSF2 I was running at ~10-15fps.

I now regularly play at 40-60 fps on the type of maps you describe (and that's very often at an 1800p resolution) so almost certainly, with a bit of work, we can get your fps up & improve your playing experience.

First things first... have you read & tried out DeutschRitters excellent advice?

Secondly, have you tried turning off ALL AA (turning off Vsync also seems to help)... both on your graphics cards settings & ingame options?

 

Edited by 37mm

Share this post


Link to post
Share on other sites

Thanks for the reply, I've done so much testing and tweaking through the years it's nuts. One thing though, and it can at times make a big fps difference but I can not play these games without SS/AA, otherwise it becomes a shimmering texture crawl mess that legit hurts my eyes to look at.

Edited by AstroCat

Share this post


Link to post
Share on other sites
6 minutes ago, AstroCat said:

Yeah it's the full ground extension of the really great flight sim IL2. 

yep, Il2 was always my favourite flight sim and they also succeeded in making the ground looking great from the skies. I´ve great expectations of tank crew and if they´ll yield some good money they might extend to combined arms further on. B) But multiplayer crew in realistically modelled WW2 tanks might take me to online multiplayer games at last.

Share this post


Link to post
Share on other sites
22 minutes ago, AstroCat said:

Thanks for the reply, I've done so much testing and tweaking through the years it's nuts. One thing though, and it can at times make a big fps difference but I can not play these games without SS/AA, otherwise it becomes a shimmering texture crawl mess that legit hurts my eyes to look at.

I understand the need for SS/AA... we'll get to that eventually.

At the moment I'm mostly concerned about your fps, let's get that up first.

Have you set your 3d Model Quality to balanced & Vsync on FAST (or even off) as per DeutschRitters advice? How is the ingame fps?

Likewise, how is your FPS with ALL AA turn off?

I reiterate that I had similiar FPS (worse even) issues to yourself just four months ago, yet this was me last night on a system much, much worse than your own...

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×