Jump to content

CMFI is not asking me to Activate. Any help?

Recommended Posts

Hello all.  I am in a dilemma.  I just bought the V4 Upgrade and I can't get the security to Activate.  I have been waiting on a ticket from the Help desk but thought you all may have some insight as well.  Specifically, I install CMFI from the original CD.  Check the folders for the Activate security shortcut, without finding anything.  I start the game thinking it may ask upon start up, it doesn't.  I play the game for a bit, with nothing.  I the exit, and install Gustav Line from the CD, and repeat the process of looking for a way to give it my License Key, play for a bit.  I exit that, and install V4 FULL that I bought the other day.  NOW upon start up, or with the shortcut, it asks me for the License Key.  Putting it in, and I press the Activate button and a black bar shows up with an X in the middle.  I also have tried the Base game and GL License keys.  Nothing is working.  The guy from the help desk says that it is because I didn't activate the base game.  How can I do that, if I can't do that?

I was wondering if any of you may have some suggestions for me.  I have installed into different directories, thinking it may be the "Program Files" problem.  My Firewall and security is disabled.  I have done all that I can and have gotten nowhere, yet.  Any ideas for me?

Share this post

Link to post
Share on other sites

License key hell.  I think your first mistake was going back to the install CD for keys. Sounds logical to do, but it only gets you what that license is for.  I think you are close, but v4 requires the activate new products shortcut - yeah the one you don't have. :P  All is not lost though!  Here are the instructions to create a shortcut key.  It is an older problem but still pops up once in a while.  Follow the instructions below (I included the link to the page if you want to see the full details)  Use the v4 key you got and this should work.  


Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:


Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license.

If this does not work I'd go back to the helpdesk and let them know you have tried this as well.

Edited by sburke

Share this post

Link to post
Share on other sites
11 hours ago, sburke said:


OK so between your help and the Desk, it is working.  I didn't realize that it was truly a FULL installer for v4.  For all others who are searching for help and find this..

Install or run only the Upgrade 4 V200 FULL.

Then launch the game,  (In my case, because I had bought the Upgrade 3) I copy and pasted the Upgrade3 Key into the Activation box.  

Then I went about conquering\defending Italy!!

If anyone see's a problem with what I've explained please edit this

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...