Jump to content

Recommended Posts

Hey all,

Bought CMBS a couple of days ago (+ module expansion and upgrade to engine v.4), great game so far - thing is it keeps crashing.. Multiple times per day

Spec:

Windows 10 pro x64

Ryzen 1800X

GeForce 1060 6GB - driver : 391.01

32GB RAM

No extra AV - just windows defender

 

Haven't tried anything funny e.g. edit the memory, no mods. Occasional alt+tabbing (never had a crash when alt+tabbing). Settings = all to highest.

The dev(s) have some rather meaningful exceptions, no readable text, all numbers, look different every time, same generic reason (unhandled exception, different libraries mentioned every time). Haven't found a coredump anywhere

 

any ideas?

Thx

Share this post


Link to post
Share on other sites

I posted this in the Tech Support sub-forum, but in case you miss it there:

 

There is NO subform for 2.10 tech support. If you're looking for help from the community for the CM series (CMBN, CMFI, CMRT, CMFB, CMBS, CMSF, CMA), then this is the place to post it.

Have you added exclusions to Windows Defender for the CM games ? Typically such interference usually results in the game not being able to launch, but it may be worth it otherwise just in case something else is happening that may be due to Windows Defender.

What ARE the libraries that are mentioned in your 'unhandled exceptions' ? If they're different every time, then I would guess that you might have a problem with your system rather than CM (CM is just running into the issue, though it is only a 32-bit program). You may want to run some memory diagnostics (such as Memtest86) and see if that comes up with anything. Some test are possible to fail even with good memory (certain 'Hammer' tests), but you'll want to pay attention to anything that fails.

If the memory tests fail to find any faults, then please get some more details on the crashes, possibly several of them if the errors are different.

Share this post


Link to post
Share on other sites

Hey @Schrullenhaft - o/s has been running fine, it's only cmbs that's crashing. Hardware is fine too - I use this box all the time/to it's full potential so if it was the memory etc the problem would occur outside cmbs. I haven't added any exceptions for the game - to be fair unless i see any reason to, i probably won't - there hasn't been any logs from defender implying it's blocking something etc

I'm not a windows expert but i think "Event ID 1000 – Application Error" is usually an unhandled exception on the application side? Here's some examples:

I'm happy to try to get a dump for one of the devs if they want to doublecheck about nvoglv32.dll error codes - typically it's access violation unhandled exceptions from what i see on their development forums, but i'm no windows dev and i'll leave that to the pros..

 

- System
   
- Provider
      [ Name] Application Error
   
- EventID 1000
      [ Qualifiers] 0
   
  Level 2
   
  Task 100
   
  Keywords 0x80000000000000
   
- TimeCreated
      [ SystemTime] 2018-04-02T18:16:05.161799400Z
   
  EventRecordID 17541
   
  Channel Application
   
  Computer DESKTOP
   
  Security
- EventData
      CM Black Sea.exe
      0.0.0.0
      58f8cbd6
      unknown
      0.0.0.0
      00000000
      c0000005
      cccccccc
      2e28
      01d3ca867fe7b5b2
      C:\Program Files (x86)\Battlefront\Combat Mission Black Sea\CM Black Sea.exe
      unknown
      dbefa7cf-b155-4613-b726-c2e9fc376a0f
       
       

 

---------------------------------------------------------------------------------

 

      CM Black Sea.exe
      0.0.0.0
      58f8cbd6
      nvoglv32.dll
      23.21.13.9101
      5a906832
      c0000005
      00a0177b
      15dc
      01d3ca568c1e771f
      C:\Program Files (x86)\Battlefront\Combat Mission Black Sea\CM Black Sea.exe
      C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_048172e9d7cc483d\nvoglv32.dll
      0bb7d1f5-7f93-46bd-9d53-d83d0eacc1bd
       
     

 

 

 

 

Share this post


Link to post
Share on other sites

thanks @Muzzleflash1990 - it is indeed an exception thrown by the nvidia driver, so the devs of the game will have to take a look i guess. Slightly worrying that people have been reporting this since Feb :S hope i'm not going to be stuck in this situation for months on :S

Share this post


Link to post
Share on other sites
Posted (edited)

I have a several CMFI errors recently that matches the with nvoglv32.dll . I am guessing that stands for NVidia OpenGL (something v32).

Faulting application name: CM Fortress Italy.exe, version: 0.0.0.0, time stamp: 0x58d2bf4d
Faulting module name: nvoglv32.dll, version: 23.21.13.9077, time stamp: 0x5a67b418
Exception code: 0xc0000005
Fault offset: 0x009fc348
Faulting process id: 0x63c
Faulting application start time: 0x01d3c78959ecb8a5
Faulting application path: C:\Games\Combat Mission Fortress Italy\CM Fortress Italy.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7a39871618b19f06\nvoglv32.dll
Report Id: a5d9e6d0-4c25-41ea-ba08-43bea800abaa
Faulting package full name:
Faulting package-relative application ID:

For both CMFI and CMBS I have quite a regular list of events related to application hangs / stopped interacting. Here is one:

The program CM Black Sea.exe version 0.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: 2b20
 Start Time: 01d3c2d0c2bf27d7
 Termination Time: 3
 Application Path: C:\Games\Combat Mission Black Sea\CM Black Sea.exe
 Report Id: 3150dc87-7df8-47f6-885d-1e110ab73cb8
 Faulting package full name:
 Faulting package-relative application ID:

Though the root cause could be the same for both, especially if the reason is interaction with drivers.

Edited by Muzzleflash1990

Share this post


Link to post
Share on other sites

@Muzzleflash1990 , thx for pitching in - i also just noticed we're both on amd64 - hope some dev will pick this up :)

p.s. regarding the application becoming non-responsive etc: i found that sometimes (mostly when saving) cmbs freezes for unusually long time e.g. >10 seconds. if i start clicking on things then i'll get the windows pop-up with 'blahblah has stopped responding' etc. , however,  If I don't click anywhere/don't hit any keys and just wait a bit without touching the mouse or keyboard then the game will recover. It's really odd as the box i'm using is pretty decent spec - i opened the windows resource monitor and there's hardly any i/o etc while this is happening

Share this post


Link to post
Share on other sites

I don't think that the issue actually correlates to the Ryzen or AMD64 instruction set since I believe some other users in the other thread are using Intel CPUs (I believe). Perhaps trying a slightly older video driver and see what happens:

388.71 WHQL (Win 10, 64-bit)

The 'non-responsiveness' during a game save has been something that has occurred for a long time intermittently to users. I don't know what the culprit may be in this case, but it could be (strangely) video driver related rather than actually I/O-disk related.

Share this post


Link to post
Share on other sites

About amd64, that just refers to the CPU instruction set. Since everyone on Windows (gaming at least) are running 64 bit, all are using amd64 instruction set. But unlike you I have an Intel CPU.

I know about the non-responsiveness. However, some of those do not recover, and those are the ones in my log.

Share this post


Link to post
Share on other sites

Interesting. I wouldn't have suspected that an Nvidia graphic setting would result in crashing. Sub-optimal graphics appearance or performance, yes, but not crashing. Do you know which particular setting made the difference ?

Share this post


Link to post
Share on other sites

yeah, i believe it was texture filtering. Trees with the current settings don't look like they're being drawn from scratch every time i move the camera around, graphics look way better and the game is smoother. Enabling fxaa related options would result in blurry pre-combat screens (some menus etc)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×