Jump to content
Deriuse

game crashes after some time playing

Recommended Posts

My brother & I just back to CM after 7 or 8 years, was really enjoying ourselves until game started crashing. This morning installed the changes recommended on Lethaface post. Helped but no cigar. Will try the older drivers. Disappointing as it is really a great game (you all know that) but an even better way to connect with my brother. Will report back results.

Share this post


Link to post
Share on other sites

Well the rolling back of the driver worked!

Played solo, no problem and just completed a small map with my brother on the net, perfect.

Thanks to everyone for an absolutely terrific thread. Lots of ideas discussed and good feed back.

Worth noting that after I rolled back the driver the custom NVidia profile was reset. I did not update so in the end, at lest in my case, it had no impact.

Share this post


Link to post
Share on other sites

I've found a compromise that works well for me.  I have retained a recent Nvidia driver.  I switch off shaders in game, which has stopped the crashing.  I use the War Movie advanced mod, which enhances the in game Movie mode.  I use SweetFX injector to inject SMAA to add anti aliasing (as anti aliasing is disabled by movie mode).

Share this post


Link to post
Share on other sites
On 9/21/2018 at 11:41 AM, Jock Tamson said:

Anyone tried 411.63 yet? - came out a couple of days ago.  If the problem persists into newer drivers this is going to be a real headache for anyone contemplating a new GTX 2080

Have made no changes since the roll back and everything has been stable and the game remains at max settings. Honestly I just want to play the game after being away so long so happy at the moment but you are spot on with the question about the future. 

Share this post


Link to post
Share on other sites
13 hours ago, rocketman said:

I just joined the club of crashes after playing a while 😫☹️😡

This under Nvidia 399.24 and GTX 970M. Will update now to 411.63.

 

Switching off shaders definitely fixes the crashing.  If you use the War Movie Advanced mod it looks just as good, IMO.

Share this post


Link to post
Share on other sites
1 hour ago, Jock Tamson said:

Switching off shaders definitely fixes the crashing.  If you use the War Movie Advanced mod it looks just as good, IMO.

I haven't tried that yet. In some ways shaders are essential as the graphics look dull without them.

Share this post


Link to post
Share on other sites
On 9/21/2018 at 5:41 PM, Jock Tamson said:

Anyone tried 411.63 yet? - came out a couple of days ago.  If the problem persists into newer drivers this is going to be a real headache for anyone contemplating a new GTX 2080

Updated to this driver and had a crash after that.

Share this post


Link to post
Share on other sites

You can downgrade to the 388.71 driver and see if that makes a difference for you (the link assumes you're using Windows 10 64-bit). If you try it, I suggest performing a 'clean install', which is a checkbox option during the installation process. This should require a reboot during the install/uninstall process.

Share this post


Link to post
Share on other sites
22 minutes ago, Schrullenhaft said:

You can downgrade to the 388.71 driver and see if that makes a difference for you (the link assumes you're using Windows 10 64-bit). If you try it, I suggest performing a 'clean install', which is a checkbox option during the installation process. This should require a reboot during the install/uninstall process.

I will try some things first and then revert to the old one. Has BFC started to pin down the problem and is it likely to be solved in the next patch? I'm worried what an unfixed problem will do to the CMSF2 release. Hopefully there will be an influx of new players and a lot of interest generated. If the first thing these new customers face is to install old drivers, there is a danger of it getting a bad rep. We don't want that. I guess those who have been with the series a long time are more tolerant. Just my 2 cents.

Share this post


Link to post
Share on other sites

I've had some problems with my mouse scrollwheel for quite some time and tried to solve it by turning of energy saving settings in the Device Manager for it. While at it I turned of energy saving settings also for keyboard, USB hubs and whatnot. I have yet to be able to reproduce a crash since doing so. Since the problem with crashes seem to have with mouser/keyboard input this might be a solution? So those having these crashes please try it. Note that it is in the Device Manager and not the "cog wheel"/Settings tab. While thinking of this problem and that some have solved it by turning shaders off, I wonder if a crash can be triggered by letting the game play for some time and then turning shaders on? Furthermore, one bug I have had since FB was released is that some scenarios/saves always start with shaders off despite having them on in the options.

Share this post


Link to post
Share on other sites
5 hours ago, The_MonkeyKing said:

I got a new GPU (RTX 2080) and I am still having this problem. Now I cannot downgrade the drivers anymore...

If you disable shaders, install War Movie Advanced Mod, and enable Movie mode, you will not be able to tell the difference.  You'll have no more crashes though

Share this post


Link to post
Share on other sites
1 hour ago, Jock Tamson said:

If you disable shaders, install War Movie Advanced Mod, and enable Movie mode, you will not be able to tell the difference.  You'll have no more crashes though

To me, assuming from the screenshots I've seen, with this mod you get a more high contrast look than stock shaders on. Is that so?

Share this post


Link to post
Share on other sites
On 8/7/2018 at 9:41 PM, Lethaface said:

I have been getting this issue for a while too. A week ago I found a thread on the forum which advised me to change my nvidia profile. It seemed to work at first, but didn't in the end. Yesterday I changed my profile again and specifically changed the 'pre-rendered frames' to '4', texture to 'quality' instead of 'high quality', and made sure MFAA was off. I can't remember who posted the profile, but credits to him.

Until my change yesterday I was able to reproduce the crash in the sense that it happened quite often, see below. Since I changed my profile, no more crashes have ocurred. I really tried to make it crash.

Faulting application name: CM Black Sea.exe, version: 0.0.0.0, time stamp: 0x58f8cbd6
Faulting module name: nvoglv32.dll, version: 24.21.13.9882, time stamp: 0x5b5f4df9
Exception code: 0xc0000005
Fault offset: 0x00823f6b
Faulting process id: 0x80c
Faulting application start time: 0x01d42dcee2fbcffe
Faulting application path: C:\Program Files (x86)\Battlefront\Combat Mission Black Sea\CM Black Sea.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_52ac7eb8f32780d5\nvoglv32.dll
Report Id: ef9feb22-61d5-4495-b7bd-786a6d24df31
Faulting package full name: 
Faulting package-relative application ID: 

I have provided some screenshots of my Nvidia profile.

CMx2NvidiaProfile-1.PNG.87b80e9c2c224e17d7c39591b404ffee.PNG
 

CMx2NvidiaProfile-2.PNG.8a6a1ddedbf144ecc5571f2027a43a94.PNG

CMx2NvidiaProfile-3.PNG.dc0c34ede9117cc1d742532b56668476.PNG

System: 
* I7-7700K (msi z270)
* Nvidia GTX 1080 with GSYNC monitor 2560x1440 @165hz (hence no vsync)
* 16GB DDR4
* SSD Samsung EVO 960
* 3TB Toshiba SATA for (win10) /users/documents etc (so CMx2 game files are on SATA disk)
* Latest NVIDIA Drivers: 398.82

EDIT:
I have experienced the crashes both with WEGO and RT. After my latest change I have approx played an hour of RT and 2 hours WEGO. The latter with a lot of alt tabbing, and both with some extensive clicking (except for the scenario loading screen, I left that alone). So far it survived. I wanted to share this before I leave my game for a couple of weeks and forget about the whole issue.

In game settings: everything maxed and shadows & shaders on.

I'm playing 'Debaltseve Devils' scenario now. Performance feels great, although fps is all over the place from 15 till over 100. I guess because of the GSYNC I don't notice the changes too much.

@Schrullenhaft fyi sir 😇.

These are pretty similiar to the settings I have on an older system (i5 2400, 1050 Ti)... although I made sure "threaded optimization" was off (I'm still playing around with the "antialasing transparency" settings).

My own game settings are now set to "excellent" & I have no fps issues with the foilage anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×