Jump to content
Chrizwit3

Game crashes during command phase.

Recommended Posts

Having problem with crashes during command phase. Game freezes, message comes up CM .exe has encountered a problem and will close. Always during command phase. Games themselves always boot no problem, have never crashed during a replay phase, only command. Couple of times has crashed in command phase whilst making a coffee, as in running fine only to come back coffee in hand to .exe encountered a problem. Annoying.

Am using Windows 10 and a 1050Ti NVidea Gx card plus an I7 processor. (Aware game only uses single core). Sound a 2270W Nvidea High def audio. (Is that the sound card?).

Do stubbornly play max gx, system put together in hope of gx overkill for CM games, have no mods however. Best can tell crashes not coinciding with virus checks etc, appear random.

Have however installed games on D drive, C being SSD. Hoping that not problem as noted lot of Data pushed onto C drive.

Share this post


Link to post
Share on other sites
1 hour ago, Chrizwit3 said:

Having problem with crashes during command phase. Game freezes, message comes up CM .exe has encountered a problem and will close. Always during command phase. Games themselves always boot no problem, have never crashed during a replay phase, only command. Couple of times has crashed in command phase whilst making a coffee, as in running fine only to come back coffee in hand to .exe encountered a problem. Annoying.

Am using Windows 10 and a 1050Ti NVidea Gx card plus an I7 processor. (Aware game only uses single core). Sound a 2270W Nvidea High def audio. (Is that the sound card?).

One good place to start is with drivers. What version of win 10 are you running. When 1709 came out a few other vendors were caught off guard with some of the changes. I think everyone has updated their drivers to work by now. Once Widows and the Nvidia drivers are up to date pay attention to sound card drivers and issues.

 

1 hour ago, Chrizwit3 said:

Do stubbornly play max gx, system put together in hope of gx overkill for CM games, have no mods however. Best can tell crashes not coinciding with virus checks etc, appear random.

Sounds like no pattern of what you are doing when it goes off.

 

1 hour ago, Chrizwit3 said:

Have however installed games on D drive, C being SSD. Hoping that not problem as noted lot of Data pushed onto C drive.

I have that - actually some CM games on C: (SSD) and some on D: (HDD) and data on D:. There should be no problem at all with that setup.

Share this post


Link to post
Share on other sites

My CM games are all on my D: drive, no hassles of any kind, but I use Win7.

Have you tried running the game with your AV disabled (it may be monitoring active processes and not like something it sees rather than taking the game out during a virus check)? 

If that solves the issue, create an exception in the AV settings for the folder the game .exe resides in and you should be sorted to run the game with AV active in future.

Edited by Sgt.Squarehead

Share this post


Link to post
Share on other sites
1 hour ago, Chrizwit3 said:

Having problem with crashes during command phase. Game freezes, message comes up CM .exe has encountered a problem and will close. Always during command phase. Games themselves always boot no problem, have never crashed during a replay phase, only command. Couple of times has crashed in command phase whilst making a coffee, as in running fine only to come back coffee in hand to .exe encountered a problem. Annoying.

Am using Windows 10 and a 1050Ti NVidea Gx card plus an I7 processor. (Aware game only uses single core). Sound a 2270W Nvidea High def audio. (Is that the sound card?).

Do stubbornly play max gx, system put together in hope of gx overkill for CM games, have no mods however. Best can tell crashes not coinciding with virus checks etc, appear random.

Have however installed games on D drive, C being SSD. Hoping that not problem as noted lot of Data pushed onto C drive.

The game will frequently crash when players give bad commands. For example: "Sergeant! Take your men and run down the street, FAST, at the machinegun bunker while maintaining a 5 meter covered arc. Go!" See? That's a bad command. The pixeltruppen frequently infiltrate your cpu and will toss a spanner in the works to save their mates. 

How do you prevent this?

Never let the men think they can trust each other. Create frequent incidents of friendly fire. You've GOT to do this as SOON as you install the game. If you ever let your men get a solid footing, they'll turn on you.

;)

Or, you may need to reinstall the game. (Kind of odd that it'd work sometimes but not others.)

Your best bet is to open a ticket with the Help Desk, or send a message to @Schrullenhaft. (<-- Kind of like the commissioner using the Bat-Light. ;) )

Share this post


Link to post
Share on other sites
6 minutes ago, c3k said:

Never let the men think they can trust each other. Create frequent incidents of friendly fire. You've GOT to do this as SOON as you install the game. If you ever let your men get a solid footing, they'll turn on you.

Back Sea Russ campaign  - first fight. Managed to cause self more casualties than AI. Have that side of things pretty much nailed thanks.:) 

Thankyou to all for such prompt responses. Pleased that D drive and max gx (particularly max gx) probably not cause. Shall check AV and drivers, though think drivers are up to date. Apologise now however as back to the grind of shifts so unlikely to be able to have a good look till Monday next. Last free night so shall carry on doing as have been; saving each and every turn. Current fight going well - not killed single one of own men.

Share this post


Link to post
Share on other sites

When the games crash during the command phase are you issuing any particular type of order ? Are you issuing orders, looking around the map etc. or are you leaving the game idle (possible power savings issue) and then it is crashing ?

Is this CMBN or is it another game or possibly is this happening with several/all of the CM games ?

Do you have anything running in the background (utilities, browsers, etc.) ? Do you know what is loading up a startup ? You may want to check by right-clicking on the Start Menu and selecting 'Task Manager' from the popup menu. Then go to the 'Startup' tab and in here will be a list of programs/applets/utilities that launch at startup. If you would like to remove an item from launching at startup, right click on its listing and select 'Disable' from the popup menu and it should NOT load the next time you launch Windows.

Share this post


Link to post
Share on other sites
20 hours ago, Schrullenhaft said:

When the games crash during the command phase are you issuing any particular type of order ? Are you issuing orders, looking around the map etc. or are you leaving the game idle (possible power savings issue) and then it is crashing ?

Is this CMBN or is it another game or possibly is this happening with several/all of the CM games ?

Do you have anything running in the background (utilities, browsers, etc.) ? Do you know what is loading up a startup ? You may want to check by right-clicking on the Start Menu and selecting 'Task Manager' from the popup menu. Then go to the 'Startup' tab and in here will be a list of programs/applets/utilities that launch at startup. If you would like to remove an item from launching at startup, right click on its listing and select 'Disable' from the popup menu and it should NOT load the next time you launch Windows

Thanks for response.

Have problem with Black Sea and Final Blitzkrieg, do have full Normandy bundle but not actually played as yet. Crashing whilst 'idle' has happened two or three times but positive not due to computer idle - that kicks in after about fifteen minutes, where as am only leaving five at most when making a coffee.

Majority is while moving mouse around map and or clicking on a unit. Have noticed that sometimes clicking on unit the 'thinking circle' pops up and message is 'wait for resolve or close' but it never resolves. Most regular is '.exe encountered a problem', sometimes whilst moving around sometimes clicking on units, occasionally in the few seconds just looking at map without input. As to removing items from launch too unsure as to which are safe to do so without guidance unfortunately.

Edit. Checked startup; Chrome, Delayed launcher(2), Program, Realtek HD Audio Manager, Windows Defender Notification and Wondershare Studio. Do know problem predates wondershare but not what 'Program' could be.

Edited by Chrizwit3
additional info.

Share this post


Link to post
Share on other sites
1 hour ago, Chrizwit3 said:

Windows Defender Notification

My money is on Defender (it actually removed my CM:FI .exe).....Maybe disable Defender start the game and see what happens.

If it cures the problem create an exception for the whole folder that the CM .exe resides in and restart Defender.

23 hours ago, c3k said:

@Schrullenhaft. (<-- Kind of like the commissioner using the Bat-Light. ;) )

It so is!  :D

Edited by Sgt.Squarehead

Share this post


Link to post
Share on other sites

the 'Wondershare Studio' is some sort of collage/scrapbook software that appears to get installed with other programs. If you're not using it, then I suggest disabling it (though it likely isn't the cause of the issue here). We've seen problems with 'Nahimic' audio software. This often gets installed with some MSI laptops/motherboards and other systems. I can't recall off-hand if the software prevented the running of CM or caused problems while it was running. I don't recall any problems with the Realtek Audio Manager (usually a 'red speaker' icon in your lower right tray). If it isn't being used, it can also be disabled without affecting your audio.

The 'chrome' I assume is simply a Chrome browser being launched at startup. Removing it may speed up boot up times, unless you almost always head to the internet on each boot. The 'Delayed Launcher' may be some Intel software that is involved with 'system restores'. You could disable that and it supposedly should make booting a bit faster.

I personally haven't really seen too many problems with Windows Defender. I do use other anti-virus security programs, so they typically run the security on the computer while Windows Defender acts more as a reminder service about updates or security being off/disabled. As a primary/sole security system you could add an 'exclusion' for the CM executables/folders in Windows Defender. If you're running a separate anti-virus/security program, then you could do something similar for it. However exceptions/exclusions really are geared for when the program will not run at all. It is somewhat rare for the security software to interfere once the program is running (at least in the manner that is being seen here).

Are you overclocking your video card or CPU at all ? If so, you may want to down-clock them or return them to the default clock speed and see if that makes any difference. 'Factory overclocks' typically should be fine (since they're the defaults as programmed by the manufacturer).

You may want to run some memory diagnostics on your computer (typically requiring a reboot into the diagnostic's OS), such as the free edition of Memtest86. There are some tests with the memory diagnostics that can cause almost any memory to not pass (certain 'hammer' tests), but most tests should be applicable and if there are errors you may need to replace your RAM or possibly change settings/voltages on it in your BIOS/UEFI setup.

Share this post


Link to post
Share on other sites
11 minutes ago, Schrullenhaft said:

It is somewhat rare for the security software to interfere once the program is running (at least in the manner that is being seen here).

I had issues with Webroot where the games ran fine but locked my system up solid on exit (since globally fixed by Webroot Tech Support).

Share this post


Link to post
Share on other sites

Schrullenhaft. For now have disabled Program, Launcher and wondershare and created exceptions for Black Sea and Blitzkrieg. Whole system pretty much defaults, no overclocks. Frustratingly not got the time to really dive into the game to see if had any effect, though computer unfazed by disabled programs and now boots even quicker than it did. So whether or not games sorted, seen a benefit. Has to be a good omen.

 

Share this post


Link to post
Share on other sites

I'm not sure if anyone found a fix but i am having the same issue. I recently bought a new computer and now every 20-30 minutes of playing then on one of the command phase it just stops responding and will not start responding again unless i close the game. This happens while i play CMFI CMFB and CMFB. Dont know what causes it because it doesn't matter about the size of the battle or anything like that. If anyone has more help on this that would be awesome, i dont think its my computer either because its much better than my previous one which ran CM just fine with out crashes.

Share this post


Link to post
Share on other sites
On 25/02/2018 at 8:52 PM, Mark_McLeod said:

I'm not sure if anyone found a fix but i am having the same issue. I recently bought a new computer and now every 20-30 minutes of playing then on one of the command phase it just stops responding and will not start responding again unless i close the game. This happens while i play CMFI CMFB and CMFB. Dont know what causes it because it doesn't matter about the size of the battle or anything like that. If anyone has more help on this that would be awesome, i dont think its my computer either because its much better than my previous one which ran CM just fine with out crashes.

Windows 10? Been intending to add reply a while. Game still crashes in command but in line with my Feb 9 post reboots way quicker afterwards. Something. 

However machine on occasion conflicting Google too and bringing up same message as did for CM. No expert, computer still under warranty so taking in for check. Confident now however own problem absolutely nothing to do with game itself. Life gets in way a lot currently but if a fix found for own machine will report back at some point.

Share this post


Link to post
Share on other sites

So after a little bit of testing i have found a way to stop the crashing, its not really a fix but a bypass i guess? Well when the game is loading whether it be because you're loading real time action or saving etc. When this happens if you try to press any key or click on the screen it will cause the game to "stop responding" which explains why it only happens to me in turn based and never real time. So all you really have to do is to be patient and let the game load. I assume most of people know about this and had more patients and brains then me, but  i hope it works for anyone else who has a similar problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×