Jump to content
Lee Vincent

Reshade Graphics Post-processor

Recommended Posts

If you use reshade and can afford the performance hit - don't forget to add SSAO or some version of ambient occlusion.  In my opinion, it adds huge amounts of depth to the image.

4jQjtJT.png
Off

9YNkx6s.png

On

It's a subtle effect with the caveat that due to how CM's depth buffer is made the effect will show through smoke, glass and trees.  (Trees I don't understand, the others I do haha!)

Share this post


Link to post
Share on other sites

I said I'd make an illustrated guide, and I did!  Hopefully it helps some of those who were asking me about it :D 

Step Zero is to download the Reshade distribution at the bottom of the page here: https://reshade.me/

Steps 1 through 8 are in my guide here: https://drive.google.com/open?id=1LG9Og33Re95sPx4KyKtk98DjyUyK-Qcn

And my preset is here https://drive.google.com/open?id=1dQ5zgLkyS5RRI559yJG929QFs2YqnRdb

Hopefully the archive works, I didn't really do extensive testing on it.

zU2QLl3.png?1

6YTMclm.png?1

3Tz42y8.png?1

Share this post


Link to post
Share on other sites
On 7.1.2018 at 2:32 PM, Marwek77 aka Red Reporter said:

I have problem with this... After install when i start CMBS it never start, just error message some windows crash...

I repost my comment from the RT screenshot thread, where I adressed this problem.

 

I just installed it and have got it running. I haven't played with the shaders, but with two out of the box preset shaders that come with reshade, I got very good results in replacing the ingame movie mode with better colors and with fully working anti aliasing.

System: Win10, Nvidia GTX960m

Here's what you do:

Download Reshade 3.1

Install

When asked during installation download fx-shader presets? YES

Running reshade it asks for the executable of the game you want to work with. Choose one. I chose FB.

When starting FB it crashed.

Go to the CM game data folder (usually in "Documents"). There you should see a "reshade-shaders" folder.

Rename "Shaders" and "Textures" in that folder to something else (e.g. Shaders_ Textures_)

Create a new "Shaders" folder. Into that folder you only copy those shaders you want to work with.

To have an instantly better looking movie-mode with working anti-aliasing, from the renamed "Shaders_" copy to "Shaders" folder:

ReShade.fxh

Levels.fx

Technicolor.fx

For fun you can also copy other shaders, like Nighvision.fx or Monochrome.fx

 

Start CM.

Press SHIFT + F2

Now you should see the ReShade config menu as an overlay within the game, where the shaders you copied into the folder, should be listed.

Choose one, i.e. "Monochrome".

The changes take effect immediately.

The game becomes b/w.

If that works, deselect Monochrome and select "Levels" and "Technicolor".

Voila! A good looking movie mode with fully working anti-aliasing.

 

When you are satisfied with your settings, go into ReShade's SETTINGS menu and switch from "Configuration Mode" to "Performance Mode". Which allegedly gives an even better performance.

 

With these two shaders activated I do not recognize a noticeable performance hit (ReShade allows to display the frame rate!).

Amazing software!

 

 

Share this post


Link to post
Share on other sites
5 hours ago, CarlWAW said:

I repost my comment from the RT screenshot thread, where I adressed this problem.

 

I just installed it and have got it running. I haven't played with the shaders, but with two out of the box preset shaders that come with reshade, I got very good results in replacing the ingame movie mode with better colors and with fully working anti aliasing.

System: Win10, Nvidia GTX960m

Here's what you do:

Download Reshade 3.1

Install

When asked during installation download fx-shader presets? YES

Running reshade it asks for the executable of the game you want to work with. Choose one. I chose FB.

When starting FB it crashed.

Go to the CM game data folder (usually in "Documents"). There you should see a "reshade-shaders" folder.

Rename "Shaders" and "Textures" in that folder to something else (e.g. Shaders_ Textures_)

Create a new "Shaders" folder. Into that folder you only copy those shaders you want to work with.

To have an instantly better looking movie-mode with working anti-aliasing, from the renamed "Shaders_" copy to "Shaders" folder:

ReShade.fxh

Levels.fx

Technicolor.fx

For fun you can also copy other shaders, like Nighvision.fx or Monochrome.fx

 

Start CM.

Press SHIFT + F2

Now you should see the ReShade config menu as an overlay within the game, where the shaders you copied into the folder, should be listed.

Choose one, i.e. "Monochrome".

The changes take effect immediately.

The game becomes b/w.

If that works, deselect Monochrome and select "Levels" and "Technicolor".

Voila! A good looking movie mode with fully working anti-aliasing.

 

When you are satisfied with your settings, go into ReShade's SETTINGS menu and switch from "Configuration Mode" to "Performance Mode". Which allegedly gives an even better performance.

 

With these two shaders activated I do not recognize a noticeable performance hit (ReShade allows to display the frame rate!).

Amazing software!

 

 

Thanx for good advice, i have Acer Aspire V17 Nitro with Nvidia Geforce GTX 960M and Win10

I did as you told, but CMBS is crashing. Only when i run with game with integrated graphics i am able to start the game and get into ReShade. When running with Nvidia graphic processor - crash. So i updated my graphic driver to the latest one 390.65 and run clean driver install, restarted notebook and CMBS crashed again. Even with administration rights. You have to know that long time ago i played with nvidia Profile Inspector, but with clean driver install it should be corrected. Or not?

How it is possible, that ReShade doesnt work?

Edited by Marwek77 aka Red Reporter

Share this post


Link to post
Share on other sites

Got everything to work, thanks @CarlWAWand @HerrTomNow need to figure out which shaders I want to use. @CarlWAWis those the only shader files that you are using? @HerrTomI set the RESHADE_DEPTH_LINEARIZATION_FAR_PLANE fromm 1000 to 40 and I don't see any difference from when it was 1000. 

Share this post


Link to post
Share on other sites
26 minutes ago, JohnO said:

Got everything to work, thanks @CarlWAWand @HerrTomNow need to figure out which shaders I want to use. @CarlWAWis those the only shader files that you are using? @HerrTomI set the RESHADE_DEPTH_LINEARIZATION_FAR_PLANE fromm 1000 to 40 and I don't see any difference from when it was 1000. 

Display depth is no longer available. As an anti-cheat feature, any game involving networking disables those shaders (depth based). I believe the TCPIP game mode triggers it.  @CarlWAW or @HerrTom may have built from source to workaround that code as wall hacking isn't much of an issue in CM titles.

Only the stock ReShade binary is white listed so altering it may get you banned when used in other games such as CoD, GTA, etc....

You can determine whether the display depth is accessible by running the DisplayDepth.fx shader. A black screen means unaccessible. My observations are as an AMD/ATI user.

YMMV using a NVidia card...

EDIT: It's still worthwhile for me. Has made CMSF so much more enjoyable to play. The Levels/Technicolor shaders @CarlWAW referenced above don't require display depth and have minimal impact on FPS. Another I like is AmbientLight.fx...

Edited by Howler
Merits

Share this post


Link to post
Share on other sites
3 minutes ago, JohnO said:

Got everything to work, thanks @CarlWAWand @HerrTomNow need to figure out which shaders I want to use. @CarlWAWis those the only shader files that you are using? @HerrTomI set the RESHADE_DEPTH_LINEARIZATION_FAR_PLANE fromm 1000 to 40 and I don't see any difference from when it was 1000. 

Glad it worked! :D 

You won't see a difference with the far plane until 2 things happen - 1: you reload Reshade - this could be through the "Reload" button on the bottom or alt-tabbing and 2: A depth-based shader is enabled.

First image: no extra shaders

4e1wwnU.png

Second image: Far plane set at 40

vKwsWZO.png

Third image: Far plane set at 1000

KzDtLR4.png

I didn't change some of the settings, so that's partly to blame but the other bit is there is less resolution for the shader to know how deep everything is in the image.

I also think the below slide is fairly enlightening.

tA2k9ak.png

Perhaps another way of looking at it is as a ruler.  Imagine you have a block of metal that's around 20 mm long and you want to measure it.  If you want to know exactly how big it is, the 40 mm calipers may be the best choice, since they have very fine resolution between zero and 100 mm.  (This is the far plane at 40 units)  Alternatively, you could use a meterstick, which is great if you want to measure something that's, say, a meter long, but we're measuring way on the small end of the tool.

OK, probably could have used a better analogy.  This one breaks down a bit when you think about digital measurements.  With the "depth buffer" here there is a fixed number of possible measurements it can save.

If you have 256 measurements to spread out across the region you're interested, setting it at 1000 units for example is essentially placing a measurement every 4 units, while you can get much more useful measurements in the region you care about by putting all of the 256 measurements every 0.15 units (up to 40 units).

I hope that word vomit explained something! I'd hate to confuse you any further haha!

25 minutes ago, Howler said:

@HerrTom may have built from source to workaround that code as wall hacking isn't much of an issue in CM titles.

I'm honoured you think I'm that code savvy!  I can write plodding engineering tools in Python and Matlab, but that's about it! :D 

23 minutes ago, Howler said:

Display depth is no longer available. As an anti-cheat feature, any game involving networking disables those shaders (depth based). I believe the TCPIP game mode triggers it.

It definitely works in single player in CM, and PBEM.  See any of my videos or AARs for proof!  You have a point about the concurrent multiplayer modes, Reshade may disable the depth buffer if it detects network traffic in the game.

26 minutes ago, Howler said:

YMMV using a NVidia card...

I'm on an NVidia 960M.  Works fine for me.

---

Didn't plan on writing an essay on digital resolution haha! Cheers!

Share this post


Link to post
Share on other sites
46 minutes ago, JohnO said:

Got everything to work, thanks @CarlWAWand @HerrTomNow need to figure out which shaders I want to use. @CarlWAWis those the only shader files that you are using?

Great.

I either use

Technicolor.fx + Levels.fx (or without Levels.fx, if I want less contrast and brighter blacks).

And shaders from @HerrTom's bundle (without the depth of field shaders):

Clarity.fx + SMAA.fx + Pirate_Depth.fx + Curves.fx + MXAO.fx

I tried them in different settings, too and I think they give a nice analog film touch and make flames stand out nicely.

Share this post


Link to post
Share on other sites

the Pirate_Depth is the preprocessor for the depth based effects in that package - I think you unfortunately need all of them for it to build correctly, but you don't need to enable them.  Pirate_Depth_SSAO and Pirate_Depth_GI are alternatives to MXAO that ships with Reshade.  The Pirate effects are real SSAO algorithms, as far as I know, while MXAO is specifically an approximate algorithm.  MXAO is much faster, for what it's worth, and in the end all we really care about is what looks best!

Share this post


Link to post
Share on other sites

There was an error for SMAA.fx and Pirate_Depth.fx. I removed them and everything is working great. Here is a screenshot of the shaders working. I need to make some adjustment on the contrast.

4oGdTkJ.png

 

Edited by JohnO

Share this post


Link to post
Share on other sites
9 hours ago, CarlWAW said:

@Marwek77 aka Red Reporter

Aspire V17 VN7-791G, Nvidia driver version: 382.05 here.

But I don't have CMBS. Make sure that CM runs fine without reshade: rename opengl.dll and opengl.ini in CM program folder to something else and see if it works.

After renaming CMBS works fine. I have to say, that game start very slow, quite long time is there black screen and i must wait up to 60 sec then it goes. Maybe i have too much mods?

Share this post


Link to post
Share on other sites

Here's a comparison of ReShade and stock graphics (wintersun in the back).

ReShade ( Clarity.fx + SMAA.fx + Curves.fx + MXAO.fx):

m35n-4-1764.jpg

Without:

m35n-3-15e3.jpg

 

Pay attention on the right to the snow on the ground into the woods. With Reshade the snow really feels like lying on the ground, while without Reshade is is just white, that could also come from the bushes.

And the trunks of the trees. Either to the right of the StuG or to the left into the dark wood. The texture of the trunks create a feeling of depth which the unprocessed graphic does not show.

But the important aspect is, that it doesn't only look nice on a screenshot, but it works for gameplay the same way.

Edited by CarlWAW

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...