Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Sign in to follow this  
Demian

Black roofs

Recommended Posts

Hello,

I have often buildings with black roofs or black walls not in place in the game, as you can see on the picture. The strange thing about that is, that say look only in game like this. In the 3D preview of the editor for example, they look normal.

Help appreciate! Thank you!

black walls.jpg

Share this post


Link to post
Share on other sites

Usually black or missing textures indicates a patch or module that isn't installed properly (missing some textures). It's a bit strange that your house models also have the walls spread out in that manner (as if something has happened to the 3D models). Do you have any graphical mods loaded up ? It's strange that things appear fine in the 3D editor, but in game come out black. What video card/chip do you have and what drivers are installed ? Has this always been a problem or something that has cropped up recently (and it was fine earlier) ? Which particular game is this ?

Share this post


Link to post
Share on other sites

It happens also with no mods installed. I have a geforce gtx 960 with the newest drivers. It happend recently. It's the game red thunder. But I have to correct that in the editor only the black walls disappear, but the roof(s) are black anyway.

Share this post


Link to post
Share on other sites

Is your game an 'Engine 4.0' update ("v2.00, Game Engine 4") or is it just 1.03 ? Have you actually 'opened' any of the BRZ data files with RezExplode ? The attached image (which is hopefully legible) is a v. 2.0, Game Engine 4 install. If you have different or less files or possibly different sized files, then you may have some corruption. Reinstalling and patching properly should fix that (if missing files or corruption is the issue).

CMRT-data-files.jpg

Share this post


Link to post
Share on other sites

Yes I have exact that version, the data folder is also complete. Never done anything with the modttools. After reinstalling more then once, I'm pretty shure the install is integer.

Edited by Demian

Share this post


Link to post
Share on other sites

What was the install process that you used for CMRT ? Recent purchases should be fully patched to v. 2.00/Engine 4.0 without ANY patching/upgrading being necessary. The attached image is the file info for the 2.00 version of the executable. The 'Size on Disk' and 'creation date' can be different from what you have, but the 'Size' and 'Modified' date should be the same.

I'm not aware of any settings within the Nvidia Control Panel (or other utilities that may modify the driver behavior) that would cause what you are seeing. Are you using 'Reshade' or any other utility that may interfere with OpenGL graphics ?

Do you know what map you are using (if this is a Quick Battle) or what scenario/campaign you may be playing ? I'd assume that a certain building and roof type will ALWAYS appear this way in game. Have you tried multiple maps (with these specific type of buildings possibly being present) and experienced the same problem ? Strange that this issue does NOT occur within the Editor, but only within an active game.

cmrt-2.0-file-info.jpg

Share this post


Link to post
Share on other sites

It's a simple standard install v. 2.00/Engine 4.0 matching the properties of the .exe file. There is nothing patched, modified or manipulated with any utilities or something. This problem occurs in other scenarios/maps too. As I mentioned before: this black walls disappear in the editor.

BTW: thanks for your effort to help me with this problem!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×