Jump to content
Sign in to follow this  
DeutschRitter

Cant Connect IP Adress

Recommended Posts

My brother and I are having a big issue playing a mp turn based via the internet. When we are using hamachi, we can connect but the one who isnt the host gets an error with deployable weapons. When the game progresses after the first round deployable weapons cant be deployed anymore. The button in the ui isnt there anymore! So we think that this is maybe an issue with hamachi. We tried to connect without hamachi but we cant. we forwarded the needed 7023 tcp and udp ports but we cant connect. So my questions:

1) Is somebody using hamachi and is having the same issue?

2) Can somebody help us to connect without hamachi?

Its very bad because we dont want to play via email. We are using skype and talking to each other and having fun like on a virtuel board game.  

Edited by DeutschRitter

Share this post


Link to post
Share on other sites
Quote

we forwarded the needed 7023 tcp and udp ports

First thing to check is that you have set static lan ip's on both your pc's so that the ports are forwarding to the correct end ips on each lan.  If your PCs are set to dhcp it may well be they are assigned different ips by your routers when they are turned on again.  Actually, only the host requires port forwarding to be set at all, the client doesn't need any special configs.

Secondly I wouldn't bother with Hamachi.  It's simply not need to play via tcpip given the above is setup correctly.

Edited by PIATpunk

Share this post


Link to post
Share on other sites
3 hours ago, DeutschRitter said:

1) Is somebody using hamachi and is having the same issue?

Check your windows firewall settings. For me, even if I allow Hamachi in my firewall settings, it still refuses to connect, so I have to disable Windows Firewall in order to get it to work. I have an anti-virus program, so I'm not at risk by turning off windows firewall. 

3 hours ago, DeutschRitter said:

2) Can somebody help us to connect without hamachi?

I have used a LAN emulator called Evolve with great success in the past. You can get it here: https://www.evolvehq.com/download

Share this post


Link to post
Share on other sites
17 hours ago, IICptMillerII said:

Check your windows firewall settings. For me, even if I allow Hamachi in my firewall settings, it still refuses to connect, so I have to disable Windows Firewall in order to get it to work. I have an anti-virus program, so I'm not at risk by turning off windows firewall. 

I have used a LAN emulator called Evolve with great success in the past. You can get it here: https://www.evolvehq.com/download

We tried Evolve. Same problem. The one who joins the game cant deploy weapons.

qHx3HX1.png

18 hours ago, PIATpunk said:

First thing to check is that you have set static lan ip's on both your pc's so that the ports are forwarding to the correct end ips on each lan.  If your PCs are set to dhcp it may well be they are assigned different ips by your routers when they are turned on again.  Actually, only the host requires port forwarding to be set at all, the client doesn't need any special configs.

Secondly I wouldn't bother with Hamachi.  It's simply not need to play via tcpip given the above is setup correctly.

We set static IPs but we can not connect without hamachi or evolve.

Its so bad because we cant play the game together. It is so annoying .... Why do we have this f******* error with evolve or hamachi! :(

Share this post


Link to post
Share on other sites
1 hour ago, DeutschRitter said:

Its so bad because we cant play the game together. It is so annoying .... Why do we have this f******* error with evolve or hamachi! :(

Is there any way for you to upload a video of the bug? I've never seen anything like this before, and have played both direct connect through evolve/hamachi, and PBEM quite extensively. Are you both on the same version of game? You can check this by looking at the lower right on the main menu:

50cJqS9MSC6vvf0ZO5KBkQ.jpeg

Other than that I really can't think of a reason for your issue. Having a video to see what is happening would help a lot to diagnose the issue. If its not possible to take a video I understand. 

I know you mentioned that you want to avoid PBEM, but it may end up being your best option. I think you'll find that if you use CM Helper with dropbox, you can actually exchange turns very quickly. You do not have to close the game or mess around with folders and files at all. CM Helper takes care of everything, so you and your friend can still chat in real time while you're trading turns back and forth. Its much less of a hassle than you may think, and you get the added benefit of being able to replay turns to see everything happen. Again I know its not what you would prefer, but its the best bet of resolving your issue, unless there is something we're still missing information on. 

Good luck!

Share this post


Link to post
Share on other sites
3 hours ago, IICptMillerII said:

Is there any way for you to upload a video of the bug? I've never seen anything like this before, and have played both direct connect through evolve/hamachi, and PBEM quite extensively. 

I will try to record a video. We have the same versions of the game.

Share this post


Link to post
Share on other sites

Because I am so desperate:

Would someone of you host a 2 player turn based lan game via hamachi or evolve to test my problem? You host a Quick Battle, I join the game, buy a couple of HMGs and we click 3 or 4 rounds. My brother is the only one I know who has the game. I live in germany but I am a night owl. I think we would find an appointment, if you are not from Europe.

Edited by DeutschRitter

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...