Jump to content
TGarner

Shadows in CM2 Games Again

Recommended Posts

Good morning all.

I just wanted to circle back around on an old topic and see if there has been anything new found that might help with the extremely hard and funky shadows in CM2 titles.

Love the new engine updates and Im not sure if its worse than it was before the upgrades but it really stands out again for some reason.

Seeing a lot of really harsh, hard shadows that get that sawtooth effect pretty bad.  Is there anything at all that anyone has found to soften up the shadows in these games?

Its really unfortunate for games that I think at least really great the shadow issues really take away from that.  Seems like there should be some way to at least soften them up to its not so stark.

Aside from turning them off of course. :)

Thanks for any help you all can offer.

I am running an NVidia 1060 6GB Superclock btw.

 

 

Share this post


Link to post
Share on other sites

No updates to shadows with the CM2 games as far as I'm aware. The 'sawtooth shadows' are a limitation of the graphics engine's implementation of lighting and shadows. To my knowledge 'softer shadows' would entail a significant performance penalty.

You can look through the Performance and Quality Tips for Nvidia users thread and see if there are any settings that MIGHT help reduce some of the sawtooth effect of the shadows. However nothing gets rid of the sawtooth effect though.                               

Share this post


Link to post
Share on other sites

It comes down to what GPU and drivers you have. My previous less powerful GPU rendered the shadows very nice, with the current one I'm experiencing the same thing as you do...

Share this post


Link to post
Share on other sites

Hmm interesting.  Ya im not sure as I have a pretty new GPU with a 1060 6GB Superclock and the game runs like a scalded dog.

Could be though.  I just know the shadows have always looks very harsh and sawtoothed for me.

Thanks for the reply!

 

Share this post


Link to post
Share on other sites

Anyone here have the problem that shadows flicker on and off when you move the camera?

I'm not the only one who has it; I've seen it in AAR videos as well.

It's definitely my number one graphical issue with the game ...

Edited by Bulletpoint

Share this post


Link to post
Share on other sites

I don't play with shadows due to too low frame rate with them turned on but for me when I try it shadows don't fliker but dissapear from the ground and units when I get my camera close to them. 

 

What flickers a lot are trees. Here and there a tree pops out on every map that flickers like crazy. Got used to it.

Share this post


Link to post
Share on other sites
On 27/10/2017 at 7:41 PM, Schrullenhaft said:

No updates to shadows with the CM2 games as far as I'm aware. The 'sawtooth shadows' are a limitation of the graphics engine's implementation of lighting and shadows. To my knowledge 'softer shadows' would entail a significant performance penalty.

You can look through the Performance and Quality Tips for Nvidia users thread and see if there are any settings that MIGHT help reduce some of the sawtooth effect of the shadows. However nothing gets rid of the sawtooth effect though.                               

Hi.. I would be very grateful if somebody would post their NVIDIA settings. I tried to check the old thread but it seems like the images are no longer up. I cant seem to get rid off the flickering of the shadows. 

Share this post


Link to post
Share on other sites
7 hours ago, kch001 said:

Hi.. I would be very grateful if somebody would post their NVIDIA settings. I tried to check the old thread but it seems like the images are no longer up. I cant seem to get rid off the flickering of the shadows. 

I also use Nvidia, and I've tried everything to fix the shadows. No luck. I don't think it has to do with the settings you can adjust in that panel. It's apparently due to some deeper driver issues that the game developers are unable to fix - apparently because the game is built on outdated tech that is no longer supported by the graphics card companies.. A damn shame, because it keeps bugging me a lot too.

Share this post


Link to post
Share on other sites

it is a tricky one... I cant seem to get rid off the flickering.. there is always a panel or a side on a tank that flickers. Luckily I seem to be to limit it, but it does kills the immersion a bit when you have a IS-2 rolling up looking like a 1970s disco ball.  ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×