Jump to content
Bagration

Can't launch the game anymore ...

Recommended Posts

Hello everyone,

 

Just created this thread because ... well that's simple as the title say : "I can't launch the game anymore" and I really don't know why ... I tough first that was a mod problem so I entirely removed the game but ... nothing change ... the funny part is, I also have CMFB and he work with no problem.

 

When I click on the Red thunder icon i have the blue circle loading of windows 10 and then nothing happened ...

 

Can you help me please, i really want to go back on this game :(

Share this post


Link to post
Share on other sites

I have noted recently for all my CM titles that I no longer see the Battlefront logo. The screen is black, it takes longer to load and sometimes I heard the booming sound which is played when the logo appears. If I click the mouse button too soon the game crashes. So if I wait long enough (like 20-30 sec) the menu appears and all is good.

Share this post


Link to post
Share on other sites
27 minutes ago, rocketman said:

I have noted recently for all my CM titles that I no longer see the Battlefront logo. The screen is black, it takes longer to load and sometimes I heard the booming sound which is played when the logo appears. If I click the mouse button too soon the game crashes. So if I wait long enough (like 20-30 sec) the menu appears and all is good.

Yes, and noticed that as well...However, if restarting to play the game later during the day, it comes up much faster (within 5 seconds). This is due to the Computers Temp Memory recognizing the exe.file from first start-up, and thus launches the game faster second time around.  

Share this post


Link to post
Share on other sites
1 hour ago, rocketman said:

I have noted recently for all my CM titles that I no longer see the Battlefront logo. The screen is black, it takes longer to load and sometimes I heard the booming sound which is played when the logo appears. If I click the mouse button too soon the game crashes. So if I wait long enough (like 20-30 sec) the menu appears and all is good.

Lucky you ...

I just have a weird thing to report in fact, i use avast antivirus and you can put game (or the antivirus do it automatically) and If i look the shortcut game for CMFB I have the complete name but if I look the red thunder, I get : "MainForme" name ... any idea what that could been ? 

Share this post


Link to post
Share on other sites

You mean you didn't already?  :o

Definitely the way forward!  ;)

Based on what you've said it might be your Avast.....Maybe turn it off completely and start the game (Webroot caused me loads of hassle, I'm just waiting on the next update/new product to see if they've fixed the issue permanently).

Share this post


Link to post
Share on other sites

Typically Avast has been pretty good with the CM series. If necessary, temporarily disable Avast during install and then re-enable it afterwards. Before running CMRT add an exception within Avast (Settings > General > Exceptions). Usually this is not needed (as you can see that other CM games are running), but just in case it is needed in this particular instance. I also suggest moving and/or wiping out your current installation BEFORE reinstalling CMRT. Also delete any shortcuts that you have BEFORE the reinstallation.  The activation (assuming that there hasn't been significant changes in hardware or OS since CMRT was installed) should remain in effect and another activation normally will not be necessary (even if you delete CMRT completely off of the computer). However there's always the possibility that another activation could be necessary and you should be prompted for it if that is the case. If you get an error about the activation at this point, then you may need to contact the Helpdesk and request an utility to wipe out the activation which will then allow you to activate the game again.

Are you running any other 'active' security software other than Avast (software firewalls, anti-malware programs, etc.) ? Windows Defender usually should not be a problem with any of the CM games and most anti-malware programs are 'passive' scanners (you have to run a scan 'manually' - rather than full-time, active protection).

Are you installing the 1.03 patch before attempting to run the game ? This typically shouldn't be an issue unless the patch is being installed to the incorrect directory.

Edited by Schrullenhaft

Share this post


Link to post
Share on other sites

Thanks for your answer, I will try that once the CM installer is download, since a little time my connexion is bad ... so that will take time, I will try it and tell you after if that work.

Share this post


Link to post
Share on other sites

Hello, Late respond but didn't have much time lately ...

 

Just for told you I tried your astuce and that still don't work ... I bought the 4.00 version so I install the game with the 2.00 files for the complete install, Try to launch it don't work, I install the 4.00 I launch and still don't work :( 

Share this post


Link to post
Share on other sites

So you never heard back from support?  At this point I've got to think that that is the way to go...

And CMRT used to run on the same computer?  How long ago?

Share this post


Link to post
Share on other sites

Hello,

Yeah I just sent the ticket yesterday to the support didn't have the time to take care of the problem before.

I bought RT the 1 December 2016, Played it all along with alot of mods, didn't play it to May 2017 to 5 July 2017 and suddendly didn't launch anymore, I didn't touch anything on my computer or on the game ... but LB still work as the first day ...

 

Really strange I know ...

Share this post


Link to post
Share on other sites
1 hour ago, Bagration said:

Really strange I know ...

heh, I know how frustrating it can be...I've had all sorts of weird problems with this game.  Держись!

Share this post


Link to post
Share on other sites

Hello,

 

nothing new the support don't respond me since a little time ... :(

Tell me guys, when you go on the battlefront website and you check your order, on the war thunder game for downloading it again, you have this files right ? 

 

hhft.thumb.jpg.988a736caed0352eed13c492d9bc30b0.jpg

Share this post


Link to post
Share on other sites

If you have purchased the CMRT 4.0 Upgrade, then I suggest downloading and installing the FULL 4.0 installer. The 'listing' in the download (for the 4.0 Upgrade purchase) will be 'CM Red Thunder 2.00 Full Windows' and it should be 3GB in size. Install ONLY this. Again, I suggest deleting your current CMRT installation (usually a manual process performed in the Windows Explorer file manager) BEFORE installing the 4.0 Full installer.

If you have NOT activated the 4.0 license key yet on this computer, then you will probably get prompted to activate a license key with this FULL 4.0 installation. Follow the instructions here in the 'Annoucement' thread of Special Upgrade 4 Tech Tips

Share this post


Link to post
Share on other sites
On 9/3/2017 at 7:26 AM, Bagration said:

Hello,

Yeah I just sent the ticket yesterday to the support didn't have the time to take care of the problem before.

I bought RT the 1 December 2016, Played it all along with alot of mods, didn't play it to May 2017 to 5 July 2017 and suddendly didn't launch anymore, I didn't touch anything on my computer or on the game ... but LB still work as the first day ...

 

Really strange I know ...

Yup, strange :)  There are no conditions I have ever seen where one of our games stops working for no reason.  The usual reason is a major computer update, but there is a message to the player that there's a "fingerprint mismatch" when that happens.

Since you have upgraded to Engine 4 you do not need to use anything else by the FULL installer, just as Schrullenhaft suggests.  Do not bother with the old v1.03 because the new version has 100% of the old data.  Using the old installer only causes problems, not solutions.

Once you've successfully installed Engine 4 (game version 2.00) launch and enter your Engine 4 license key.  Exit the game and use "Activate New Products" to launch the game a second time.  This time enter your original CMRT license key.  That should be all that is necessary.

As others have advised, keep your anti-virus software turned OFF when licensing.  All kinds of strange problems are caused by AV software.

Steve

Share this post


Link to post
Share on other sites

Reckon I'll follow a similar procedure when I reinstall CM:FI (might need your help with the licensing again) following Microsoft Internet Security's recent help.....Presumably the best the community can do is to keep reporting the false positives, submitting files and generally nagging their AV providers?

Share this post


Link to post
Share on other sites

Hello,

 

Thanks for your answer everyone, I will try directly the 4.00 version then, but I must say ... I tried to download the demo of RT and once installed .... I can't launch it just like the full game !

 

But Last Blitz work just fine ... I ... just don't understand anymore, really ...

Maybe I have a folder of Red thunder somewhere who block my game every time, but I will try to install the 4.0 version with no antivirus active and see what happened.

Share this post


Link to post
Share on other sites

×