Jump to content
Sign in to follow this  
IMHO

MacOS: CMBS does not recognize the license

Recommended Posts

Anyone had the same issue? My steps were:

1. Remove everything.

2. Run CMBS v.1.03 full installer.

3. Install v.1.04 patch

4. Run v.1.03 licence key

5. Install CMBS Battle Pack v2.10

6. Run CMBS Battle Pack v2.10 license

Basically first license key is correct and Patch+Battle Pack installs correctly. I can see the correct engine version and greyed out Battle Pack items. But second license key ruins everything - I get "Game Engine 4 required blah-blah-blah..."

 

Share this post


Link to post
Share on other sites

As the error mentions "Game Engine 4 required...". The Battle Pack is the 2.10 version of the game, which is the Game Engine 4.0. Since you didn't install the 4.0 Upgrade, it is looking for that license key.

I don't know if it is possible in some way to have the Battle Pack scenarios and campaigns without having the 4.0 Upgrade. Obviously with the 2.10 patch (4.0 Game Engine), you would have to have the 4.0 Upgrade, but I assume that the scenarios/campaigns in the Battle Pack can't be licensed and used with anything other than having the game Upgraded to 4.0 (Engine, game version 2.0) and patched to 2.10. The scenarios and campaigns probably wouldn't appear since they would not be of the 'correct version of the game'.

Share this post


Link to post
Share on other sites

2.10 is Game Engine 4 is it not? :wacko: Is my sequence correct:

  • 1.03 full install, 1.04 incremental patch and 2.10 all-inclusive patch
  • 1.03 license and 2.10 license

May be I shouldn't install 1.04 between 1.03 and 2.10? 'Cause it says "License failure: Game Engine 4 is required. Please run Activate New Products utility..." Though the activation tool finishes successfully and lists main game and the bundle. And bottom left corner of the main screen below the license activation says Game Engine 4 :(

Share this post


Link to post
Share on other sites

Open a ticket with the Helpdesk (click on the blue '+new ticket' button in the upper right) if you need the official word on this.

You need to install:

1) Full game (v. 1.03 in this case).

2) 1.04 incremental patch.

3) 4.0 Upgrade.

4) 2.10 patch / Battle Pack

The full game, 4.0 Upgrade and Battle Pack will require license keys.

Yes, 2.10 is Game Engine 4.0. However it does NOT include all of the .BRZ data files that the 4.0 Upgrade would (to my knowledge). The Battle Pack / 2.10 patch is NOT a replacement for the 4.0 Upgrade. To use the Battle Pack / 2.10 patch you NEED to have the 4.0 Upgrade installed and activated BEFOREHAND. The license key for the Battle Pack does NOT activate the 4.0 Upgrade/Game Engine 4.0. I believe that the copy-protection system will recognize that the 4.0 Upgrade is not activated and thus it gives you the error that you're seeing.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...