Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:


      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them

MAC OS CMRT ver 1.03 Not Working

Recommended Posts


I downloaded the latest CMRT ver 1.03 DMG from your website. I moved the file to the APPLICATIONS folder, double-clicked to launch and nothing happens. The CMRT icon jumps in the bar and that's it. I cleared the CACHE, re-downloaded  and re-installed the program several times. Ran out of things to try.

Please advise.

Thank you.

MacBook Pro, 13" retina, Iris Intel Graphics, 512 SSD HD, 8 Gb RAM, MAC OS Sierra, i5 2.5 mhz

Share this post

Link to post
Share on other sites

I received a reply from BF which worked. Posting it here for future ref:

MacOS Combat Mission won't launch or shows only a black screen


Conditions can arise during installation where Apple's installer and the MacOS do not properly set Permissions for Combat Mission. The result is the OS does not allow Combat Mission to fully run or even launch for security reasons. The two most common symptoms are:

  1. When the game is launched there is the standard "zoom" animation but nothing happens and the game is definitely not running.

  2. The game launches normally, and is running, but there is nothing but a black screen with absolutely nothing showing (note there is a similar symptom, but it isn't 100% black. Check this article http://battlefront.mojohelpdesk.com/help/article/136097)

What you need to do is trick the OS into reconfiguring the permissions. The way to this may sound a bit odd, but it makes sense from the OS perspective and that really is all that matters!

  1. Move the Combat Mission application outside of its folder. Anywhere will work.

  2. Select the application and the Copy command.

  3. With the Combat Mission folder selected use the Paste command to create a new application in the folder.

  4. Launch the newly created application and verify that it is working correctly.

  5. Delete the original application that is outside the Combat Mission folder. It is no longer needed and therefore takes up significant harddrive space for no reason.

There are several other methods that will work, but the above is the most straight forward and "foolproof" way. If you do the above and it doesn't work, then there is likely something else wrong and you should file a Ticket with the Help Desk.

Share this post

Link to post
Share on other sites