Jump to content
markus544

Any news about CMFI 4.0 release

Recommended Posts

I just want to point out a few years ago I was told the original CMFI license was redundant once 3.0 came out.  Yet I needed it here.  So I wouldn't be so quick forget about the original license if you bought original CMFI.  I would keep it around with an activation or two handy.

Share this post


Link to post
Share on other sites
2 minutes ago, Battlefront.com said:

Even easier... CMFI/Gustav Bundle is completely updated to Engine 4 :) You won't need to do anything more than buy, install, and use *one* license key to activate the whole thing. 

The CMFI license that came with your Upgrade 4 Big Bundle is redundant, though because you used it for 3 games already you came out ahead as you paid $25 for $30 worth of stand alone Upgrades.  And of course CMBN is in the mix for you at some point as well.

Steve

Big thanks Steve. Been wating since Christmas :D 

Share this post


Link to post
Share on other sites
13 minutes ago, Thewood1 said:

Got it working,what...7 hours after first attempt.  I entered all four serial numbers 2-3 times with no feedback other than the game wouldn't activate.  The helpdesk got back to me a few minutes ago to tell me CMFI and 4.0 activated, but 3.0 and GL didn't.  They have no idea why.  I tried re-entering both twice, got the error "x" on 3.0, but GL finally activated the second time and that seemed to activate everything else.  Holy crap...

Not sure if anyone can learn anything from this or not.

Glad it's all sorted.  To pick up on your last thought...

There's only three reasons why our sever would not register a license attempt:

1.  something nerffed communications between CM and license server.  This is pretty rare with this DRM (common under the eLicense system) but it can still happen.  If CM can't talk with our license server, well... obviously no magic happens.

2.  the game wasn't upgraded fully to Engine 4 when a licensing attempt was made.  Each EXE is programmed differently so trying to license an older EXE, then a newer one will not work.  That's a legacy problem and no longer a concern for any CM game going forward, thankfully!

3.  user error of not putting in a necessary license key.  People can easily think they put in a number when in fact they have not.  As noted, the feedback from the game isn't always informative (sometimes it is, sometimes it isn't... ) and once the mind is convinced of something it's hard to undo it.  The less than reliable feedback is a known problem with the DRM's internal diagnostics so we are working with them to get things improved.  I've also seen a few people who have been using Engine 2 only and think they have Engine 3, so that causes a problem because they don't have a key they need and aren't aware of it.

After many years of working with this specific flavor of this DRM these are the only possibilities that have ever come up.  Of course there is always a "Ghost In The Machine" possibility, but as of yet not seen one that I could verify.

Steve

Share this post


Link to post
Share on other sites
4 minutes ago, Thewood1 said:

I just want to point out a few years ago I was told the original CMFI license was redundant once 3.0 came out.  Yet I needed it here.  So I wouldn't be so quick forget about the original license if you bought original CMFI.  I would keep it around with an activation or two handy.

Yeah, back when you asked that was probably the only option that was available to us at the time.  As I said, the DRM was originally not really well suited for a game having being added to it over time in a haphazard way (i.e. customer choice).  It was set up for more traditional linear approach of mandatory succession.  That caused all kinds of problems which, thankfully, the DRM company worked out.  We now have a super smooth, super reliable system in place for all CM games going into the future.  CMFI is the last product to go through the transition process.

BTW, probably 99% of our customer base never runs out of activations.  The system we have is extremely adaptable to most situations most of the time.  However, the behavior patterns that do consume activations over time tend to be something done regularly.  Meaning, a customer that does chew up activations tends to keep doing so over time.  This is in stark contrast to the old eLicense system used for Shock Force, Afghanistan, and all non-CM products.  Chewing up eLicense activations is really, really easy to do.

4 minutes ago, Armorgunner said:

Big thanks Steve. Been wating since Christmas :D 

Christmas time in Spring ;)  You're welcome.

Steve

Share this post


Link to post
Share on other sites

Holy cow!

I come home from exams and speeches and decided to check up on the status of Fortress Italy and...

YES!!! :o

Thank you so much and good luck on the battlefield! 

Share this post


Link to post
Share on other sites
10 minutes ago, DougPhresh said:

Is there an OOB changelog?

Sure, here it is:

Everything changed!

Seriously, we spent the better part of 3 months overhauling the TO&E.  There's almost no formation that wasn't touched in some way, even if not apparent to you the customer.  There was no attempt to track the changes as that would have probably derailed the whole effort (i.e. I would have thrown myself out a window!).

But I can tell you that some of the biggest changes were made to the German Pioneer units, Panzeraufklärung, US Airborne Demolition Platoons, Commonwealth Lorried infantry, and more things that I want to remember.  In fact, just asking me has set back my therapy sessions several weeks.

:D

Redoing the TO&E was not as dramatic as all that, but it was kinda traumatic.  It wouldn't have been such a big deal if it weren't for the fact that doing things wrong would mean existing scenarios would crash.  To keep things backwards compatible was really tricky.  Plus we had to blow the dust off of Italy specific research that hadn't been touched in 2-4 years.  Which is why CMFI Upgrade 4 is out in April instead of in December with the rest.

Well worth it though!

Steve

Share this post


Link to post
Share on other sites

OK, it's working now.  :)  Thanks for all the help.  Along with not having the CMFI activation module (changing the shortcut settings target name worked), I did in fact need to go back and download V4 for CMFI (I had downloaded all the others when those became available and thought I already had CMFI 4.0) and then enter the key.  :D

Thanks to Steve, Pete, Mikey and Ultradave!

Share this post


Link to post
Share on other sites
11 minutes ago, Battlefront.com said:

Sure, here it is:

Everything changed!

Seriously, we spent the better part of 3 months overhauling the TO&E.  There's almost no formation that wasn't touched in some way, even if not apparent to you the customer.  There was no attempt to track the changes as that would have probably derailed the whole effort (i.e. I would have thrown myself out a window!).

But I can tell you that some of the biggest changes were made to the German Pioneer units, Panzeraufklärung, US Airborne Demolition Platoons, Commonwealth Lorried infantry, and more things that I want to remember.  In fact, just asking me has set back my therapy sessions several weeks.

:D

Redoing the TO&E was not as dramatic as all that, but it was kinda traumatic.  It wouldn't have been such a big deal if it weren't for the fact that doing things wrong would mean existing scenarios would crash.  To keep things backwards compatible was really tricky.  Plus we had to blow the dust off of Italy specific research that hadn't been touched in 2-4 years.  Which is why CMFI Upgrade 4 is out in April instead of in December with the rest.

Well worth it though!

Steve

Thank you for all the work!!

Right off the bat, I'm seeing a lot more Luftwaffe troop selections (although I still can't see if it's Field Divisions or HG after fall '43 ;)).

I also see a lot more options under appearance than shorts or greatcoat, could you speak on that a little? What is late camo, for example?

I'm also glad to see ground conditions independent of weather so there can be snow on the ground on an overcast day!

Share this post


Link to post
Share on other sites
9 hours ago, Battlefront.com said:

Installing the Full installer over an existing installation or in place of one solves all installation related issues.

Er, not quite I fear. I have the same problem that cobetco reports: all the license keys produce nothing but the dreaded white X in the black box. This is getting tiresome. I mean, it's great that you guys are so willing to hold our hands and see us through the problems, but why does it have to be so hard in the first place? I yearn for the days when all you had to do was something simple like have the disk in the reader or something similar. Not practical for a number of reasons, I know, still one feels more than a little wistful for the "good old days".

Michael

Share this post


Link to post
Share on other sites

I successfully installed the 4.0 upgrade to my CMFI GL Install by using my CM Fortress Italy - v3.0 UPGRADE key to activate .

Edited by Waycool

Share this post


Link to post
Share on other sites
1 hour ago, DougPhresh said:

Thank you for all the work!!

Right off the bat, I'm seeing a lot more Luftwaffe troop selections (although I still can't see if it's Field Divisions or HG after fall '43 ;)).

I also see a lot more options under appearance than shorts or greatcoat, could you speak on that a little? What is late camo, for example?

I'm also glad to see ground conditions independent of weather so there can be snow on the ground on an overcast day!

Oh yeah, and that too :D  Though I think some of those uniform options slipped through from the Rome to Victory Module we're working on.  So might not be relevant yet.

I did forget to say that you guys who use the Auto Picker for Quick Battles should be much happier with the selections.  Much, much happier.

Steve

Share this post


Link to post
Share on other sites
1 hour ago, Michael Emrys said:

Er, not quite I fear. I have the same problem that cobetco reports: all the license keys produce nothing but the dreaded white X in the black box. This is getting tiresome. I mean, it's great that you guys are so willing to hold our hands and see us through the problems, but why does it have to be so hard in the first place?

See previous six dozen explanations and the tech tips.  Staying with the status quo wasn't even an option, but if we had it would be 1000x worse than it is now.  Change is necessary and change sometimes comes with hiccups.  I really can't say it any different than that.

Quote

I yearn for the days when all you had to do was something simple like have the disk in the reader or something similar. Not practical for a number of reasons, I know, still one feels more than a little wistful for the "good old days".

The process is actually quite simple.  Install Update or Full installer, use Activate New Products link until you've entered all your license keys.  It really is as simple as that, but of course theory and practice are not always in alignment.  All I can say is that the vast majority of people have no problems with licensing the vast majority of times.  So the system does work as intended.  Unfortunately, there is some cosmic force that says that if someone has a problem with the system they are likely to keep having a problem with it.  Such people get a distorted perspective for understandable reasons.

Now, the "dreaded x" most likely means you have not entered a license key.  To be clear you need to do:

1.  your original CMFI key from way back in the dark ages of time.  This is Engine 2.

2.  your CMFI Upgrade 3.0 key (Engine 3) you bought somewhere along the way.  If you don't have one, then that's a problem.

3.  your CMFI Upgrade 4.0 key (Engine 4) that you recently purchased.

4.  (optional) Gustav Line key

If you've done as instructed, and not entered a wrong key at any stage, then it should work.  There is always a chance of an oddball problem with one of your keys.  There's 2-3 dozen Gustav Line Bundle customers who will be SOL until they contact us, for sure.  You're not one of them so you should be in the clear.  Theoretically.

Because I know you I was able to skip a tech support step and dive right into your order history.  I found your original CMFI (Engine 2), Upgrade 4 (Engine 4), and Gustav Line keys.  I verified that all three of them were successfully activated today, so they aren't problems.  What remains unknown is your Upgrade 3 (Engine 3) license key.  That one I can't check at the moment because you got it as a hardgood and therefore I don't have a record of it on this end.  My guess is that either you haven't entered it or you've entered the key off of the wrong CM product.  Less likely, but still possible, is the key didn't get imported correctly.

What you should do is double check what exactly you're entering in for Engine 3 and see if you can rectify it by entering it again.  If not, PM me your key and I'll see what it's doing.

Steve

 

Share this post


Link to post
Share on other sites

Mac results:  Up and running fine.  

I downloaded, and went ahead and entered license keys for the whole CMFI chain (CMFI -- got the dreaded 'X', then GL -- 'X' again, then v3.0 Upgrade - Play activated). On start, 'You need a license for 4.0'. Quit the app, ran the 'Activate New Products - CMFI.sh' in the app folder, entered the 4.0 bundle key, and TaDa! Up and running.

Thank you Steve et al.

Share this post


Link to post
Share on other sites
28 minutes ago, herr_oberst said:

Mac results:  Up and running fine.  

I downloaded, and went ahead and entered license keys for the whole CMFI chain (CMFI -- got the dreaded 'X', then GL -- 'X' again, then v3.0 Upgrade - Play activated). On start, 'You need a license for 4.0'. Quit the app, ran the 'Activate New Products - CMFI.sh' in the app folder, entered the 4.0 bundle key, and TaDa! Up and running.

Thank you Steve et al.

You're welcome :)  What you saw is exactly as it should be.  With the licensing it's all or nothing.  You can't 2/3rds license something and have it run, so until you entered in the magic 3rd element (Engine 4 key) you were kept out.  The difference between the X and "you need..." results has to do with the internal logic of what was entered and in what order.  We're trying to get more control over that because, obviously, better feedback would be helpful.

Steve

Share this post


Link to post
Share on other sites

Thanks for your reply earlier Steve.

Unfortunately i still cant get to the CMFI activate new products.

Installers all downloaded, but just hanging around in file format, i don,t get the option to "run" them.

I did read the option of changing the name in the properties thingy, but not confident enough to know what to change!!

Just really need to know where or how to get the file open, pretty happy to have a go with all the license keys input when it comes to it.

                                                      I know we will get there in the end, we always do! Regards, Ian.

Share this post


Link to post
Share on other sites
1 minute ago, chocice said:

Thanks for your reply earlier Steve.

Unfortunately i still cant get to the CMFI activate new products.

Installers all downloaded, but just hanging around in file format, i don,t get the option to "run" them.

I'm unclear what you mean.  There's three distinct phases:

1. Successfully downloading an installer (you only need one, either Full or Update)

2.  Successfully running the installer and having a updated installation

3.  Successfully licensing


Sounds to me that you might not have completed the first phase, which means you didn't do the second phase, which means you can not do the third phase.  Did you successfully run an installer?  You confirm that by checking the EXE in your CMFI folder.  If it doesn't have a 2017 creation date and a v2.00 number than you need to focus on getting the installation complete first.

Steve

 

Share this post


Link to post
Share on other sites
25 minutes ago, Battlefront.com said:

I'm unclear what you mean.  There's three distinct phases:

1. Successfully downloading an installer (you only need one, either Full or Update)

2.  Successfully running the installer and having a updated installation

3.  Successfully licensing


Sounds to me that you might not have completed the first phase, which means you didn't do the second phase, which means you can not do the third phase.  Did you successfully run an installer?  You confirm that by checking the EXE in your CMFI folder.  If it doesn't have a 2017 creation date and a v2.00 number than you need to focus on getting the installation complete first.

Steve

 

Thanks Steve,

I have successfully downloaded the installer, i,m on windows and downloaded both options, dunno whether that makes a differance or not??

It,s running the installer i can,t seem to do.

Havn,t got to licensing stage yet!!

Ian.

Share this post


Link to post
Share on other sites

Just played a small/tiny quick battle against the AI using engine 4.0. Fun battle and to my eye CMFI looks the best of the CM series.  Not sure if it is the colours or the small map or time of day but everything looked super sharp and smooth.  My only (tiny) complaint is when I Iet the computer auto pick the german forces (infantry only) they still ended up with an anti tank gun force (e.g approx 2x 88mm guns 4 x 75mm guns 2x infantry guns etc. Still as I said it was a fun battle :).  However it is probably about time I played a human.  I'm very inexperienced PBEM player but if anyone whats to play a small infantry Quick battle Probe or meeting engagement let me know.

Share this post


Link to post
Share on other sites

Quick question...

I downloaded full installer and ran it over my original installation - all worked OK and I entered my v3 key and it worked showing text that it was now on Engine 4.

However my Gustav module was missing..

So I found the Gustav Exe and installed module again... Used my Gustav Key and Module now installed..

However it now shows that I am on V1.10 and does not show I am on engine 4 at the main menu screen.

Have I nerfed the upgrade?

Share this post


Link to post
Share on other sites
2 hours ago, weta_nz said:

Just played a small/tiny quick battle against the AI using engine 4.0. Fun battle and to my eye CMFI looks the best of the CM series.  Not sure if it is the colours or the small map or time of day but everything looked super sharp and smooth.  My only (tiny) complaint is when I Iet the computer auto pick the german forces (infantry only) they still ended up with an anti tank gun force (e.g approx 2x 88mm guns 4 x 75mm guns 2x infantry guns etc. Still as I said it was a fun battle :).  However it is probably about time I played a human.  I'm very inexperienced PBEM player but if anyone whats to play a small infantry Quick battle Probe or meeting engagement let me know.

The force picking logic was worked on and it worked much better in testing. One way to do it is to have human picking for both, and hit the suggestions button until you get something that looks reasonable for the opponent. I think it works better for medium sizes and up, because it has more points to spend on a "typical" formation. So you'll get something like a PzGren bn minus one or two of it's companies, for example. We did a bunch of testing on it and while it isn't perfect, it's very much improved over what it was.

And I have a fairly empty platter right now if you'd like a game. I have dropbox. PM me and we can set something up - maybe a probe with me on defense - gives you more forces.


Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×