Jump to content

Recommended Posts

Just back for another run on CM Normandy, picked up the 3.0 upgrade, quite alarmed at the fact it is a 9.9GB download, is this right? the base game is only 1.3GB and upgrade 2.0 was only 500MB.

 

Share this post


Link to post
Share on other sites

It is because the download also contains all the BN modules which can be unlocked if you have a license for them. It makes the installment procedure from scratch easier for those who have all the modules.

Share this post


Link to post
Share on other sites

One more question, I bought the upgrade 2.0 a few years back, do I need to install this prior to 3.0, or does 3.0 include everything that is in 2.0?

 

Edit.. was hastey with the "one more question" statement.

I'm attempting to activate my Combat Mission: Battle for Normandy key and I'm being told it is invalid, yet I am copy/pasting straight from my account page.

 

Ok, Got it going by activating with the Upgrade 3.0 key, got into the game, quick battle, chose my options, hit next and CTD, windows 10!!!!!

Will wait till the 3.11 patch is downloaded, may contain compatibility for windows 10.

Edited by zonks40

Share this post


Link to post
Share on other sites
6 hours ago, zonks40 said:

One more question, I bought the upgrade 2.0 a few years back, do I need to install this prior to 3.0, or does 3.0 include everything that is in 2.0?

 

Edit.. was hastey with the "one more question" statement.

I'm attempting to activate my Combat Mission: Battle for Normandy key and I'm being told it is invalid, yet I am copy/pasting straight from my account page.

 

Ok, Got it going by activating with the Upgrade 3.0 key, got into the game, quick battle, chose my options, hit next and CTD, windows 10!!!!!

Will wait till the 3.11 patch is downloaded, may contain compatibility for windows 10.

I haven't had any issues with win 10, but you should patch up regardless

Share this post


Link to post
Share on other sites

I just decided to get back into this as well. BIG problem...

I have 3.0 and downloaded and installed the 3.11 patch, prior to attempting the 3.12 patch. However, I cannot Activate 3.0 (with the 3.11 patch) using either the serial number that came with the 3.0 upgrade OR the original number from CMBN when I first bought it way back in 2011.

 

Any help appreciated. Using Win10 and wondering if I'll just have to kill off everything an reinstall it all up to the purchased 3.0 Upgrade.

Share this post


Link to post
Share on other sites

joeperez  backup any game saves, mods, downloaded scenarios/campaigns, etc. and then just uninstall CMBN (typically deleting the directory). Install the 3.0 Upgrade (that is 9.9GB in size). If you have not activated the 3.0 Upgrade before, then you should be prompted to activate the game using the 3.0 Upgrade license key. If you have modules that were installed and previously activated, then they should still remain activated. The activation dialog box actually should list what is activated, but it doesn't list the activated modules/content properly until the Vehicle Pack activation or later.

If you upgraded to Windows 10 AFTER you have previously installed and activated CMBN, then you may be running into a problem with the activations. Usually this will result in an error message when you attempt to run the game (you won't see CMBN, just an error dialog box when you attempt to run it). If that is the case, then you would need to contact the Helpdesk to request the gsClean files for CMBN and its modules.

CMBN 1.x (and maybe 2.x) will NOT work with Windows 10. There is a conflict/incompatibility of some sort with the copy protection version used for CMBN 1.x that will not allow it to run. I haven't check with CMBN 2.x, so I'm not certain regarding it.

The CMBN 3.0 Upgrade (9.9GB) should install everything except the 3.12 patch and the 'Battle Pack'. I believe the 3.11 patch is unnecessary to install (since it was part of the Vehicle Pack, which is included in the 9.9GB 'master installer').

I suggest temporarily disabling your security software, if possible, since some security programs may interfere with the installation and/or activation process. You can then reactivate the security software after the activation process and then I would suggest making 'exceptions' within your security software for the game executables and/or directories (especially in any 'active protection' feature of your security software). 

Share this post


Link to post
Share on other sites
48 minutes ago, Schrullenhaft said:

joeperez  backup any game saves, mods, downloaded scenarios/campaigns, etc. and then just uninstall CMBN (typically deleting the directory). Install the 3.0 Upgrade (that is 9.9GB in size). If you have not activated the 3.0 Upgrade before, then you should be prompted to activate the game using the 3.0 Upgrade license key. If you have modules that were installed and previously activated, then they should still remain activated. The activation dialog box actually should list what is activated, but it doesn't list the activated modules/content properly until the Vehicle Pack activation or later.

If you upgraded to Windows 10 AFTER you have previously installed and activated CMBN, then you may be running into a problem with the activations. Usually this will result in an error message when you attempt to run the game (you won't see CMBN, just an error dialog box when you attempt to run it). If that is the case, then you would need to contact the Helpdesk to request the gsClean files for CMBN and its modules.

CMBN 1.x (and maybe 2.x) will NOT work with Windows 10. There is a conflict/incompatibility of some sort with the copy protection version used for CMBN 1.x that will not allow it to run. I haven't check with CMBN 2.x, so I'm not certain regarding it.

The CMBN 3.0 Upgrade (9.9GB) should install everything except the 3.12 patch and the 'Battle Pack'. I believe the 3.11 patch is unnecessary to install (since it was part of the Vehicle Pack, which is included in the 9.9GB 'master installer').

I suggest temporarily disabling your security software, if possible, since some security programs may interfere with the installation and/or activation process. You can then reactivate the security software after the activation process and then I would suggest making 'exceptions' within your security software for the game executables and/or directories (especially in any 'active protection' feature of your security software). 

This did not work. All I'm left with now is an empty CMBN folder.

Looking over your reply again, I'm don't think I made it clear what products I used to install the games. I have the ORIGINAL DVDs for all the products. I installed the original CMBN 1.0, then upgraded with the 2.0 DVD, and added the Commonwealth and Market-Garden DVDs as they became available. I then purchaed the 3.0 Upgrade DVD and installed that. Everything worked fine and was fulled activated when I tried to install the 3.11 patch. That's when I had to re-Activate my CMBN, and couldn't, with ANY license key.

I don't have any 9.9 GB file. If that is what you get when you purchase the *download* version of everything, then that's why I don't have it; I have DVDs.

I don't have the vehicle pack or newer scenario pack.

What I think I'll try to do is now install everything from scratch, CMBN version/module/upgrade, one DVD at a time, and see if I can at least get back to 3.0. If I have to, I'll live without the 3.11 patch.

Share this post


Link to post
Share on other sites

It looks like your installation order was incorrect. You would want to install Commonwealth BEFORE the 2.0 Upgrade and the Market Garden module AFTER the 2.0 Upgrade.Yes, the 3.0 Upgrade download is 9.9GB which is a 'master installer' that installs EVERYTHING with the exception of the 3.12 patch and the Battle Pack.

For an installation with just the DVDs alone. You will want to install in the following order:

1. CMBN base game (1.x)

2. Commonwealth module.

3. CMBN 2.0 Upgrade.

4. Market Garden module.

5. CMBN 3.0 Upgrade.

6. CMBN 3.11 patch.

7. CMBN 3.12 patch.

Run the game at this point (and NOT BEFORE) and use your CMBN 3.0 Upgrade license key. This will activate the CMBN base game with the 3.0 Upgrade (and 2.0 Upgrade). I'm not certain if the patches provide the 'Activate Modules' shortcut or not. If it does, then click on this and provide the Commonwealth license key. Once this completes, close it up and then relaunch the 'activate modules' shortcut again and provide the Market Garden license key. When you launch CMBN again it should hopefully have all of the installed modules activated (indicated by the icons along the bottom of the main menu).

It MIGHT be possible to request a link to the CMBN 3.0 Upgrade download from the Helpdesk to get the master installer file, even if you didn't purchase the download version. I don't know if Battlefront is actually offering this option at all or not for those who purchased the 'mail delivery only' option.

Edited by Schrullenhaft

Share this post


Link to post
Share on other sites
1 hour ago, Schrullenhaft said:

It looks like your installation order was incorrect. You would want to install Commonwealth BEFORE the 2.0 Upgrade and the Market Garden module AFTER the 2.0 Upgrade.Yes, the 3.0 Upgrade download is 9.9GB which is a 'master installer' that installs EVERYTHING with the exception of the 3.12 patch and the Battle Pack.

For an installation with just the DVDs alone. You will want to install in the following order:

1. CMBN base game (1.x)

2. Commonwealth module.

3. CMBN 2.0 Upgrade.

4. Market Garden module.

5. CMBN 3.0 Upgrade.

6. CMBN 3.11 patch.

7. CMBN 3.12 patch.

Run the game at this point (and NOT BEFORE) and use your CMBN 3.0 Upgrade license key. This will activate the CMBN base game with the 3.0 Upgrade (and 2.0 Upgrade). I'm not certain if the patches provide the 'Activate Modules' shortcut or not. If it does, then click on this and provide the Commonwealth license key. Once this completes, close it up and then relaunch the 'activate modules' shortcut again and provide the Market Garden license key. When you launch CMBN again it should hopefully have all of the installed modules activated (indicated by the icons along the bottom of the main menu).

It MIGHT be possible to request a link to the CMBN 3.0 Upgrade download from the Helpdesk to get the master installer file, even if you didn't purchase the download version. I don't know if Battlefront is actually offering this option at all or not for those who purchased the 'mail delivery only' option.

Will this procedure work the same on a Mac? I've been having problems...

Michael

Share this post


Link to post
Share on other sites

I believe this process should work on the Mac also. This listing does NOT have the Vehicle Pack and Battle Pack installations (the Vehicle Pack typically has the 3.11 patch as part of the installer, though I'm not certain on the Mac).

Share this post


Link to post
Share on other sites

Well, I followed the order of DVD installation to the letter, with no success. When I attempt to imput the CMBN 3.0 key, I get the message "Invalid serial number."

Looks like I'll have to kill off everything AGAIN and simply reinstall up to Upgrade 3.0. Hopefully there isn't anything too important in the 3.11 patch, but since I'm considering getting the Vehicle pack and scenario pack, that should include 3.11 anyway.

Thanks, guys.

Share this post


Link to post
Share on other sites
29 minutes ago, joeperez said:

When I attempt to imput the CMBN 3.0 key, I get the message "Invalid serial number."

I have had similar problems loading the games on a new computer. I have also had a situation where the games apparently loaded, but when I launch or close them, this message appears on the screen:

malformed data base schema (is_transient) - near "where": syntax error

Whatever could that mean?

:huh:

Michael

Share this post


Link to post
Share on other sites

Michael Emrys - This error apparently refers to SQLite which is an embedded database used by a number of programs written for MacOS. I don't know if CMBN utilizes it or not. What MacOS are you running and have you checked for any updates to your Mac lately ? Looking up your particular error mentions that a command is being used against an older version of SQLite that doesn't support 'is_transient'. Most of the information I've seen seems to regard reading Chrome cookies or Python programming. However I don't know about updating any sort of OS-level SQLite install. Usually most installs are for supporting other programs/programming tools. If CMBN is utilizing SQLite it is probably dependent on what is built-into MacOS (and would NOT utilize a separately installed instance of SQLite).

Are all programs closed on your Mac when you attempt to launch CMBN ? Did you follow the above process (for those that don't have access to the 3.0 Upgrade 'master installer') for installing CMBN ? Are you getting the 'invalid serial number' error attempting to activate the 3.0 Upgrade license key or was that in the past ? Are you logging on as someone different than the account used for the game installation ?

 

joeperez - Activating after the 3.0 Upgrade should be fine. I know that the activation dialog boxes don't show the correct information (on a successful activation) of what has been activated. I think the 3.11 patch potentially clears that up (where the successful activations list the correct modules that have been activated). A 'mail delivery only' copy of CMBN 3.0 Upgrade I have is a 16 character (not including dashes) license key with characters A-F and numbers 0-9. You can try typing it with or without dashes to see if that makes a difference.

Share this post


Link to post
Share on other sites
10 hours ago, Schrullenhaft said:

Michael Emrys -

joeperez - Activating after the 3.0 Upgrade should be fine. I know that the activation dialog boxes don't show the correct information (on a successful activation) of what has been activated. I think the 3.11 patch potentially clears that up (where the successful activations list the correct modules that have been activated). A 'mail delivery only' copy of CMBN 3.0 Upgrade I have is a 16 character (not including dashes) license key with characters A-F and numbers 0-9. You can try typing it with or without dashes to see if that makes a difference.

Tried it several ways. Since I have the "mail" version of the 3.0 upgrade, I also have that 16 character key number. After the 3.11 patch, typing the key with or without dashes results the refusal to accept it.

I got the patch from the Gamers Hell site, as I didn't fully understand the way the download was structured at Battlefront, with each individual file listed, and you have to select them all to be put into zip file (NEVER seen that before).  Perhaps I'll get all the files from the battlefront link and try again, since I know that reinstalling everything up to the 3.0 Upgrade will continue to work (nothing to lose by trying it one more time). <_<

Share this post


Link to post
Share on other sites

I have now attempted to apply the 3.11 patch downloaded directly from battlefront. Do I even have to mention that it failed miserably? When I applied the 3.0 Upgrade, the Activation box at game launch specifically asked for the ky # that came with the 3.0 Upgrade. Applying the 3.11 patch gives an Activation box that asks "Enter the key that was given to you when you purchased CM Battle for Normandy PC." Note that nothing is mentioned about the 3.0 Upgrade.

I entered the 3.0 Upgrade key (failure) then copied/pasted the key (very long letter/number set) that I have from the ORIGINAL CMBN 1.0 that I had when I pre-ordered this series at the beginning of it all. This key also results in failure.

I considered getting the vehicle pack and scenario pack, for the content as well as the included patched that apply automatically, but I think I'll hold off. If battlefront can't get their act together to make applying patches successful for people who've purchased all the individual products as they were released, I don't know if I can trust them anymore. I'll stick with reinstalling everything AGAIN from scratch and hold at the 3.0 Upgrade.

Share this post


Link to post
Share on other sites

You may want to contact the Helpdesk (click '+New ticket' in upper right) and see if they will provide you a link to the 9.9GB CMBN master installer. The explicit mention of the correct license key is confusing, but once you install the 3.0 Upgrade you MUST provide the 3.0 license key (not the 1.x license key). You can also request an additional activation for your 3.0 Upgrade license key from the Helpdesk, just in case it is out of activations (you'll need to supply the 3.0 Upgrade license key that you're going to use).

Are you disabling you anti-virus/security software during install and activation ? If necessary (it generally shouldn't be) you could also run the game with 'Run as administrator' (by right-clicking the launching icon and selecting that menu option). If you activate the license key in this manner, then you may need to launch the game with the 'Run as administrator' option each time though.

Share this post


Link to post
Share on other sites

I also apparently missed some patches that are necessary for the non-master file installer installation of CMBN. The Knowledgease article lists the installation process using the DVDs and standalone patches/upgrades . I specifically missed the need to install the 1.11 patch after the Commonwealth installation and the 2.12 patch to be installed after the Market Garden module, but BEFORE the 3.0 Upgrade.

You should be able to activate after the 3.0 Upgrade and then apply the 3.11 and 3.12 patches. I'm not sure if the 3.11 patch fixed some copy-protection system issues though.

Share this post


Link to post
Share on other sites

I'm able to get an up to 3.0 installation running without any patches whatsoever. My 3.0 key works fine when activating after the 3.0 Upgrade is installed, but that key goes nowhere after the 3.11 patch. 

I guess the Helpdesk is the next step. Thanks. 

Share this post


Link to post
Share on other sites

I don't think you need to activate the game again after you activate it after the 3.0 Upgrade is installed. If you're activating after the 3.0 Upgrade, then you shouldn't be prompted again for the license key to my knowledge. If you click the 'Activate Shortcuts' (not sure if that is present or not), then you would need to provide the module license keys for that. The 3.11 and 3.12 patches shouldn't need to reactivate to my knowledge (but I may be wrong).

Share this post


Link to post
Share on other sites

I sure hope that with the v4 upgrade, or with the x3 engine at the latest, that BFC can straighten out the installation mess that some of us find ourselves in. While I read that improvements have been made, it just seems to get worse and worse.

:(

Michael

Share this post


Link to post
Share on other sites
12 hours ago, joeperez said:

I guess the Helpdesk is the next step.

As, @Schrullenhaft said you should not need to reactivate after installing a patch. If that is what is happening then the help desk is your best hope. This forum is just for self help. We are not the professionals :)

11 hours ago, Michael Emrys said:

I sure hope that with the v4 upgrade, or with the x3 engine at the latest, that BFC can straighten out the installation mess that some of us find ourselves in. While I read that improvements have been made, it just seems to get worse and worse.

Humm, I think this is a case of reading the horror stories and concluding everything is a horror.  I testify that, overall, installing has been better with every release.  There is now all in one installers that mean you no longer get tripped up installing in the wrong order. BFC no longer uses crappy, spammy servers for distribution. Various fixes to activation and licensing...  Plus lots of stuff that you cannot even see.

Of course that does not prevent there from being the odd horror story (see above) but they are not the norm and the help desk has a damn near 100% success rate.  I would claim they had a 100% success rate but that would just mean someone would come along and prove me wrong.  And I cannot allow that :D

Share this post


Link to post
Share on other sites

×
×
  • Create New...