Jump to content
usgubgub

Could not initialise graphics display: REQUIRED: 1024x768, 32-bit color

Recommended Posts

Hi,

 

I get this error suddenly when I try to launch the game on one of my locations. Worked perfectly up to now. I am using a Samsung TV monitor with 3840x2160 resolution. The display size file says 0 0 0. This happened to me in another location when I tried to launch CMRT right after a new install and, after much fiddling, having turned the computer off and on again after a few hours, it magically worked, so I don't know how I fixed it. Sadly, this is not happening here, so I am stumped.

 I have CMBN, CMFI, CMRT and CMFB all installed and working perfectly on 3 other installations (different locations) with similar TV screens. I am worried because I move between different locations and it's the second time now this issue has arisen. I can't be without my CM games!

Edited by usgubgub
Forgot to mention important point

Share this post


Link to post
Share on other sites

Well, now I have a new problem: when I start the game the start screen flickers alternating between the creen or total blackout, sometimes it will stay black for a few seconds, then the start screen appears for a fraction of a second, then black again.

 

I have set the DPI settings to 100%, then back to 150% but no improvement. What am I not doing right?

Share this post


Link to post
Share on other sites

I'm not sure of the exact cause of the issue you're seeing, but your DPI settings seem to be conflicting with the 'Compatibility' setting you have for CM (' Disable display scaling on high DPI settings'). You'll probably want to set it for whatever is the default (which I would have assumed to be '100%').

Share this post


Link to post
Share on other sites

Thank you again Schrullenhaft.

Ok, I have reset the DPI settings to the default, which is 150%, reset the screen resolution to the recommended one (3840x2160), checked the display size file (0 0 0) and made sure the compatibility setting "Disable display setting on high DPI settings) is checked.

The game loads and there is no flicker. It works well.

The trouble is that all the writing is very small, the UI is very small, even the landmarks and objectives on the battle screen are very small and sometimes illegible. It was because of this that I had tried  a lower screen resolution (1920x1080)   yesterday, but that's what brought the flicker problem on. The start screen and writing were normal size as before but I got flicker.

Before I updated the TV's software two days ago the game worked perfectly and the writing was normal. Unfortunately I had not set the game up myself so I don't know what combination of settings were being used. I guess I can get used to the small writing but if there was a way to get back to what I had before I would prefer that.

               

Share this post


Link to post
Share on other sites

Hi

I am getting the same display error 1024*768, 32 bits when i launch the CMRT v4 in my new Lenovo windows 10 laptop, set up at 1920*1020

when I go to the CMT properties > Compatibility> Settings there is a "Change high DPI settings" box. After I select it, i have 2 check boxes: 

Program DPI - use this setting to fix scaling problems for this program instead of the one in Settings

High DPI scaling behavior - override high DPI scaling behavior - scaling performed by (choice): application/system/system(enhanced)

 

I tried to click all combinations to no avail. The error persists.

 

FYI, when i run CMRT on my win10 desktop with 1920*1080, i have no issues

Share this post


Link to post
Share on other sites

Which version of Windows 10 do you have ? Referencing version 1803, go to the Start Menu > Gear icon (Settings) > System control panel > Display menu item (on left). In the right pane, towards the top in the section labeled 'Scale and Layout', make sure that the setting selected in the drop down dialog is set to '100% (Reommended)'. Underneath that setting click on the text that says 'Advanced scaling settings'. In here in the section towards the top and the text that says 'Let Windows try to fix apps so they're not blurry', set that to 'OFF'. Below that in the 'Custom Scaling' section make sure that there is no entry type into the box (no numbers at all). Click the 'Apply' button if you've made changes. With changes it may be necessary to reboot (I'm not sure).

For the 'Change high DPI settings' within the app's compatibility tab UNCHECK both boxes and see if the error goes away on your laptop. If that doesn't work, then check the box for the 'Override high DPI scaling behavior' and in the drop box below it select 'Application' and try that out. Basically what we want is for Windows to NOT scale the DPI settings (in whatever manner it does this). This behavior seems to interfere with CM games and I assume your laptop may be set to use some sort of scaling.

Share this post


Link to post
Share on other sites

To avoid this error, set DPI settings to Override + performed by Application.

Just another indication of the age of this engine, when it crashes using simple DPI scaling.

Share this post


Link to post
Share on other sites
13 hours ago, Shadrach said:

Just another indication of the age of this engine, when it crashes using simple DPI scaling.

That is what I overheard them muttering about me in the grocery line yesterday.  Freakin young uns got no respect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×