Jump to content
Sign in to follow this  
Bulletpoint

Please help me solve my shadow problem that's driving me NUTS

Recommended Posts

When I turn the camera, shadows will flicker on and off. While keeping the camera steady, nothing will change. I tried pretty much everything at this point, deleting my mod folder, and also completely uninstalling my gfx driver using a driver cleaner utility, then reinstalling an older driver from my laptop manufacturer. Still the same problem.

I also opened a support ticket to ask the Battlefront guys, but they had no clue either.

I'm running an Nvidia GTCX 980m...

Share this post


Link to post
Share on other sites

I have same problem and after a lot of trial and error, research and hair puling I can say it seems to come down to video ram or video card problem

I run a laptop. So I hooked it up to a monitor, same faults. Now my room mate has a desktop pc with lots of video ram and a different video card. He has no such faults.

So it appears to be a equipment orientated fault and not a program defect. I run a GT740m Nvidia in my laptop with 8GB of ram.

Share this post


Link to post
Share on other sites
9 hours ago, mech.gato said:

I have same problem and after a lot of trial and error, research and hair puling I can say it seems to come down to video ram or video card problem

I run a laptop. So I hooked it up to a monitor, same faults. Now my room mate has a desktop pc with lots of video ram and a different video card. He has no such faults.

So it appears to be a equipment orientated fault and not a program defect. I run a GT740m Nvidia in my laptop with 8GB of ram.

Thanks for the reply. You mean basically it's due to a defective card, or do you mean it's not having enough RAM / gfx onboard memory?

Here's a video I found that shows the problem. It's from another game (Minecraft) but I think it shows the exact same issue.

 

Share this post


Link to post
Share on other sites

Hello Bulletpoint,

Great news! I found a thread on this forum I missed. I have my in game Options settings of 3D Texture Quality set to Balanced, 3D Model Quality is Best. Vertical Synchronization, Antialias/Multisample and High Priority Process all set to off.

I followed the directions in this thread and now I have shadows that do not flicker!

I hope this helps you out. If not let me know on this post and we will figure something out. Even if it means dancing naked in the moonlight and sacrificing a chicken.

Share this post


Link to post
Share on other sites
16 minutes ago, mech.gato said:

I have my in game Options settings of 3D Texture Quality set to Balanced, 3D Model Quality is Best. Vertical Synchronization, Antialias/Multisample and High Priority Process all set to off.

I followed the directions in this thread and now I have shadows that do not flicker!

What specific setting(s) did you change to fix your problem? The ones in bold above? Or other stuff from the thread as well?

Share this post


Link to post
Share on other sites
6 hours ago, mech.gato said:

I followed the directions in this thread and now I have shadows that do not flicker!

I set all settings to the ones in the first post in the thread, and put the in-game settings to what you suggested, and it unfortunately made no difference :( 

So bring on that chicken and let's go to the forest

Edited by Bulletpoint

Share this post


Link to post
Share on other sites

Man that stinks! It worked like a charm for me. Have you contacted Nvidia to see what they can do for help? I contacted them when I had trouble running a train simulator game and they were very helpful.

To answer earlier questions, I first thought it was a memory ram problem. Not enough memory to handle all the calculations when shifting view points. But this is not the case as the monkeying with the settings has solved it on this end. The other question as to what I did with settings is yes, I set the in game user options as stated and then followed the instructions in the post.

Now back to your problem. Have you updated drivers for the video card and possibly the monitor? What kind of monitor are you running, a CRT (like a t.v.) or a newer LED flat screen? What kind of cable connection between the monitor and pc, vga or usb? Also have you tried researching a fix for Minecraft shadows? As the error appears similar maybe a solution in that game will correct CMBN also.

And don't worry, just because my fault is corrected doesn't mean I am abandoning this thread. I am interested in helping you out even if it is just my suggestions on what course of action to take. Plus I have a forest and chicken standing by...

Share this post


Link to post
Share on other sites
1 hour ago, mech.gato said:

Have you updated drivers for the video card and possibly the monitor?

Yep, running the latest drivers. Just updated them this afternoon, in fact.

1 hour ago, mech.gato said:

What kind of monitor are you running, a CRT (like a t.v.) or a newer LED flat screen? What kind of cable connection between the monitor and pc, vga or usb?

I'm on a laptop. Asus G751 with Nvidia GTX 980m graphics card.

1 hour ago, mech.gato said:

Also have you tried researching a fix for Minecraft shadows?

Yes, I also tried googling many combinations of keywords, and found that lots of people have all kinds of problems with shadows, including some that have problems similar to the ones I have. Unfortunately, nobody seems to have received any answer in the forums I've found so far.. I'm generally pretty good at solving my own tech problems, but that also means that when I get stuck, I really have a problem.

1 hour ago, mech.gato said:

And don't worry, just because my fault is corrected doesn't mean I am abandoning this thread. I am interested in helping you out even if it is just my suggestions on what course of action to take.

Thanks a lot. If nothing else, it has a therapeutic effect on my blood pressure :)

1 hour ago, mech.gato said:

Plus I have a forest and chicken standing by...

What unholy apparition should we sacrifice it to? Chernobolg? Charles?

Share this post


Link to post
Share on other sites

Some more details that will hopefully help some brilliant person crack this problem:

Shadows seem to disappear once the object that throws the shadow gets close to the edge of the screen (any edge).

The problem only affects shadows from trees, bushes, buildings, and hedgerows. Shadows from walls, fences, troops are not affected.

Or actually: The same thing happens with these shadows, but the object needs to have actually left the screen area by some margin before the shadow stops being thrown. This becomes obvious when looking straight down on a field when the sun is low, so that long shadows are cast. When slowly scrolling, a standing soldier disapears from view at the bottom of the screen, but his shadow is still cast onto the field. When continuing to scroll a little bit so that he gets further from the visible area, suddenly his shadow will also "snap off" and disappear, before it actually scrolls out of view.

So, in short, all shadows are affected by the disappearing effect, but it's only noticed for vegetation and buildings, because their shadows stop being rendered too early, while the object making the shadow is still visible.

This means that it's probably not the exact same problem as in the Minecraft video, because my shadows disappear when they get close to the edge individually, while in the minecraft video it looks like all the shadows in the forest snap off at the same time, based on the angle the player is looking.

Edited by Bulletpoint

Share this post


Link to post
Share on other sites
13 minutes ago, Bulletpoint said:

Shadows seem to disappear once the object that throws the shadow gets close to the edge of the screen (any edge).

That's the way it has always worked, as far as I can remember.

Share this post


Link to post
Share on other sites
1 minute ago, Vanir Ausf B said:

That's the way it has always worked, as far as I can remember.

Well it would make sense to save rendering power by stopping to calculate the shadow once the object is no longer in view, but this just seems to happen too early in my case. I'm thinking there's some setting in the code somewhere that thinks the object is out of view, but gets it wrong...

Share this post


Link to post
Share on other sites
Sign in to follow this  

×