Jump to content
LukeFF

Blurry terrain textures

Recommended Posts

I'm suddenly seeing an issue with the terrain textures, where they show up very blurry once I move the camera around a bit. All of my graphics details are set to the max both in the game in the nVidia control panel for my GTX 1070, but so far nothing has helped. Very strange. Anyone else experience this?

CM Black Sea 2016-10-22 13-43-02-97.jpg

 

Share this post


Link to post
Share on other sites
22 hours ago, rocketman said:

Did you install a new driver just yesterday? I did for my nVidia 970 MX and I'm having weird looking shadows.

I did, so I'm going to try rolling back my drivers to see if that helps.

Share this post


Link to post
Share on other sites
6 hours ago, rocketman said:

That's great. Did it even work with the lates driver or did you have to settle for the previous one? Hopefully this will fix my problem as well.

I went with the previous released driver for my card - 373.06. All of the games on my computer run fine with it, so that's good enough for me. 

Share this post


Link to post
Share on other sites
On 2016-10-22 at 10:46 PM, LukeFF said:

I'm suddenly seeing an issue with the terrain textures, where they show up very blurry once I move the camera around a bit. All of my graphics details are set to the max both in the game in the nVidia control panel for my GTX 1070, but so far nothing has helped. Very strange. Anyone else experience this?

CM Black Sea 2016-10-22 13-43-02-97.jpg

 

I had this problem now in CMFI with latest 375.63 nvidia driver. Might roll back it like you did.

Share this post


Link to post
Share on other sites

It seems that the blurry terrain is caused by some setting in the nVidia control panel and affects all CM*2 games (at least for me). I will try to understand which setting that causes it.

@LukeFF do you by any chance have the same settings now as when you had the problem? In that case - which?

Share this post


Link to post
Share on other sites

I had this issue and looked in the Combat Mission graphics settings. It appeared my texture quality was set to lowest by the driver or something.  Changing it higher fixed it for me.

Share this post


Link to post
Share on other sites
3 hours ago, rocketman said:

@LukeFF do you by any chance have the same settings now as when you had the problem? In that case - which?

Yes, I had the same settings as before. I am not at my gaming computer right now, though, so I don't what exactly they are.

Share this post


Link to post
Share on other sites

Tried a few things and it seems like the newer Nvidia drivers and the anti-alias settings in the control panel doesn't work well with the CM option in game anti-aliasing. So both should not be on for what it looks like. I wonder if this is true for all Nvidia cards?

Share this post


Link to post
Share on other sites
On 11/15/2016 at 2:43 PM, rocketman said:

Tried a few things and it seems like the newer Nvidia drivers and the anti-alias settings in the control panel doesn't work well with the CM option in game anti-aliasing. So both should not be on for what it looks like. I wonder if this is true for all Nvidia cards?

I've always let CM control the anti-aliasing settings, as that reduces overhead on the card and because the in-game anti-aliasing looks good to me.

Share this post


Link to post
Share on other sites
2 hours ago, Hister said:

I'm experiencing the same. How to fix this? Do I have to install older Nvidia drivers? 

You can turn anti-aliasing off in the Nvidia control panel. I can't remember if you have to turn all off or just one of them.

Share this post


Link to post
Share on other sites
3 hours ago, Wolfseven said:

its open GL you need to make a profile and then turn off FXAA.

I already have FXAA on off for the CM nvidia profile so it's not that. 

 

4 hours ago, rocketman said:

You can turn anti-aliasing off in the Nvidia control panel. I can't remember if you have to turn all off or just one of them.

OK, will try but then the game becomes ugly as hell. Darn it. 

Edited by Hister

Share this post


Link to post
Share on other sites

I've put antialiasing gamma correction to off and the textures are still blurry. 

 

Edit: Antialiasing mode put to off makes the problem go away but the visuals are beyond acceptable this way - rather have blurred ground textures then this.

 

No other solution as of yet? Will Nvidia fix this or...? 

Edited by Hister

Share this post


Link to post
Share on other sites
1 hour ago, Hister said:

I've put antialiasing gamma correction to off and the textures are still blurry. 

 

Edit: Antialiasing mode put to off makes the problem go away but the visuals are beyond acceptable this way - rather have blurred ground textures then this.

 

No other solution as of yet? Will Nvidia fix this or...? 

Nvidia probably don't care about a small company like BFC :(

Do you have anti-aliasing on in game? That should make it look better. And then turn all anti-aliasing settings in control panel off or controlled by program. That helped me.

Share this post


Link to post
Share on other sites
28 minutes ago, rocketman said:

Nvidia probably don't care about a small company like BFC :(

Do you have anti-aliasing on in game? That should make it look better. And then turn all anti-aliasing settings in control panel off or controlled by program. That helped me.

That is exactly how I have it set. Why does it not work for me and works for you? Buffled. 

Share this post


Link to post
Share on other sites

I don't know - sorry :(

Just to check - updated to 4.0?

What card do you have and driver version?

I don't have a game going on in BS at the moment so I won't check right now, but I'm not seeing it in any games since changing the settings. Try resetting the entire profile in the Nvidia control panel. If it is still present then perhaps helpdesk should have a look.

Share this post


Link to post
Share on other sites

Yes, updated to 4.0.

Latest Nvidia drivers (376.33). 

GTX 660Ti GPU

AMD FX 6300 CPU

Blurred textures are introduced with Antialiasing-Transparency Nvidia control panel setting which I use in order to make game look less shimmery. 

The higher the 3D texture quality you set ingame, the more shimmering is present. This was offset with Antialiasing-Transparency control panel setting but it now introduces the blurred ground textures. 

 

I will for the time being set 3D textures to balanced and Antialiasing-Transparency to off. As soon as you put them to improved immense texture shimmering gets introduced if Antialiasing-Transparency is set to off. 

 

 

 

Share this post


Link to post
Share on other sites
29 minutes ago, Hister said:

Yes, updated to 4.0.

Latest Nvidia drivers (376.33). 

GTX 660Ti GPU

AMD FX 6300 CPU

Blurred textures are introduced with Antialiasing-Transparency Nvidia control panel setting which I use in order to make game look less shimmery. 

The higher the 3D texture quality you set ingame, the more shimmering is present. This was offset with Antialiasing-Transparency control panel setting but it now introduces the blurred ground textures. 

 

I will for the time being set 3D textures to balanced and Antialiasing-Transparency to off. As soon as you put them to improved immense texture shimmering gets introduced if Antialiasing-Transparency is set to off. 

 

 

 

That is the driver I use on a GTX 970M card. Can you post screen shots of this "shimmering" you mention as I don't grasp what you are seeing.

Share this post


Link to post
Share on other sites

×
×
  • Create New...