Jump to content
  • Announcements

    • Battlefront.com

      Final Blitzkrieg v1.01 released!   05/21/2016

      Once again proving that we don't sleep much, we have just released v1.01 for CM: Final Blitzkrieg.  There's lots of great improvements and fixes now just one download away.  Click HERE to see the release notes and download links.  Thanks to everybody for reporting issues and special thanks to the testers who make sure we don't overlook them.
    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
ChrisND

v1.01 Patch is here!

Recommended Posts

18 hours ago, Anthony P. said:

I don't see any division patches on either 82nd nor 101st airborne winter units, which I'd expect since they wear the same jackets as when you select normal uniforms. Is this a bug, or by design?

Hi,

 

there are only no explicit textures. But I tested and when you put textures with [101st] and [82nd] in your mod-folder, these uniforms will be shown!

 

Greetings, alex

Share this post


Link to post
Share on other sites
On 2016-05-23 at 2:03 AM, Erwin said:

You make it sound easy, but I still am confused.  How does one know which mods have "strings".  And what is the "game install mod location" - where the game installs or where the mods install?   Sounds like the safest action is to remove the mods folder altogether b4 installing any patch, so one doesn't have to worry about the above.

OK sorry I'll be more explicit.

On the subject of how do you know -> by reading the fine print / readme / forum post associated with the mod.  For example Vin goes out of his way to point out that his mods are version specific.  If you don't see that kind of language in the description of a mod then it is not version specific.  At the moment the only one I know of is Vin's Animated text mod.

On the subject of where to put mods ->

On my machine I have CMFB installed in "C:\Programs\Battlefront\CMFB".  Which means that there is place for mods in the documents folder in a location like this: "C:\Users\<username>\Documents\Battlefront\Combat Mission\Final Blitzkrieg\User Data\Mods".  That location will be used by any version of the CMFB game you have installed.  There is however another place you can put mods - under the game install directory, which for me is here: "C:\Programs\Battlefront\CMFB\Data" that location will only be used by the version of the game installed at "C:\Programs\Battlefront\CMFB".  I always create a "Mods" folder under that so I can keep track of what I added.  So now I can have "C:\Programs\Battlefront\CMFB" and "C:\Programs\Battlefront\CMFB101" running and sharing all my Aris vehicle mods (in the shared my documents mod directory) but each with their own version of Vin's Animated text mod (each a separate mod in the game install directory).

If you are not one to keep multiple versions around for long I admit it is not really super important.  But it does serve as a reminder that certain mods are version specific.  My way of working is to copy my game install and patch the copy so I am then able to run either version. After I do that copy I delete any install directory mods so after my patch it will run without problems.

Share this post


Link to post
Share on other sites

Ever since CM1 and CMSF I have installed all BF games to c:/sims/'GAME NAME" and did not have a problem for many years.  However, I get the feeling that this now confuses the updater for patches etc, as I found a 2nd installation of the game elsewhere, and had to manually move the new files into the correct folders in order to get the v1.01 running.

Share this post


Link to post
Share on other sites

BFC,

Belatedly found this announcement and successfully installed patch quickly and with zero issues on my 132 in cyber years iMac. Longest part of the process? The download!

Regards,

John Kettler

 

 

 

Edited by John Kettler

Share this post


Link to post
Share on other sites
On 5/22/2016 at 8:38 PM, ChrisND said:

 

Bug Fixes

* Floating trenches and moving fortifications in TCP/IP fixed.

 

Mines appear to still have teleport capability. Here they are magically appearing in my spawn at the start of a quickbattle game. They were placed at start nearly 700m away.

 

 

Saving and reloading moved the mines to their correct locations.

Share this post


Link to post
Share on other sites

Anyone else seeing this problem when trying to install the patch.  I have my game on an alternate drive.  Not my main one.  I tried unzipping to that drive and then installing and also installing from inside the game folder.  I keep getting the same message.  Any help is appreciated.

 

Thanks.

 

 

 

Screen Shot 06-11-16 at 02.41 PM.JPG

Edited by eniced73
forgot screen shot

Share this post


Link to post
Share on other sites

I think it tries to install to the BF default install path.  If you have a different path you need to copy the files into the correct folders manually.  At least that is what I had to do.  Wish BF would give us a choice (ie: able to "BROWSE") of install path with patches.

Share this post


Link to post
Share on other sites
On May 29, 2016 at 4:51 AM, SgtHatred said:

 

Mines appear to still have teleport capability. Here they are magically appearing in my spawn at the start of a quickbattle game. They were placed at start nearly 700m away.

 

 

Saving and reloading moved the mines to their correct locations.

 

On June 8, 2016 at 8:04 AM, Anthony P. said:

The M1919A6 gets a second bipod when semi-deployed on the ground:

i2D3aZO.png

The loader here is awfully low down to be operating his .50 cal:

y11XEea.png

 

Gah! Thanks for the reports. I'll verify and pass them on. (Is a dual bipod a quapod?)

Ken

Share this post


Link to post
Share on other sites
On 2016-05-22 at 4:38 AM, ChrisND said:

* Vehicle commanders now button faster in response to small arms fire.

Was this supposed to apply to halftracks as well? If so, it's not working. If not, no issue of course.

Share this post


Link to post
Share on other sites

I don't think halfie gunners ever button due to incoming fire, so "buttoning faster" isn't relevant. The change with halftrack gunners on the advent of FB is that they default to buttoned, and won't fire unless "opened up". Given the rate at which they die, they'd have to button really quickly for it to make much difference :)

Share this post


Link to post
Share on other sites
On 23 May 2016 at 0:55 PM, Erwin said:

When I install the patch, it doesn't work - in that I don't see the new 1.01 data in the data folder.  I installed the original game to C:/SIMS/CMFB and I know that the patch must go into the installed folder.  However, the patch installer doesn't give one the opportunity to select which folder to install the patch to.  Is it installing to another folder?  How to get it to install to the correct folder?

Thank you Erwin.

On my Mac it was opening a New folder in my Applications folder. Copied all of the contents to where I want them and it worked.

Up to now, on all the Mac Updaters we had the choice of choosing where to install the Updates. 

BF please think of including this feature in an upcoming update, if possible?

Cheers!

 

Share this post


Link to post
Share on other sites

I have most of the CM games and never seen this message before after installing a patch. I went to the game directory following the path in the message and put a folder named 'mod' in there and reinstalled the patch but no go. Could anyone point out what I'm doing wrong? Thanks in advance.

error2.jpg

Share this post


Link to post
Share on other sites

My guess is you are unzipping more than just the patch and it is selecting other archived files at the same time.  That particular file is not part of the BF patch.  That sounds like a mod file that is also being affected.  You may want to make sure the patch file goes into a directory with no other files in it

Edited by sburke

Share this post


Link to post
Share on other sites

Yes thanks sburke I just rushed back here to apologise for time wasting. I opened the patch onto my desktop and just ran it from there and it must have been picking up other files that were already on the desktop. Thanks for your reply. :wacko:

Edited by bruce90
spelling

Share this post


Link to post
Share on other sites

Hi, thanks for the patch!

Just one small bug report (so far, lol)

the trigger for music splash.wav is still broken during scenario load. music intro.wav plays instead. (music end of battle.wav works fine as normal after a scenario).

Just mentioning it in case you were unaware. I see Erwin and CMFDR were talking about the bug in Maps & Mods before 1.01 patch release... :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×