Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them

Recommended Posts

***NVIDIA CONTROL PANEL SETTINGS***

(EVGA GeForce GTX 980 Ti Superclocked + ACX 2.0 + Blackplate)

*AA FXAA - Deactivated

*AA Gamma correction - Deactivated

*AA Mode - Deactivated

*AA Settings - None

*AA Transparency - Deactivated

*CUDA GPUs - All

*Shader cache - Activated

*TF Anisotropic sample optimization - Deactivated

*TF Negative LOD Bias - Authorized

*TF Trilinear Optimization - Activated

*Power Management Mode - Adaptive

*Mutli-Frame Sampled AA (MFAA) - Deactivated

*Threaded Optimization - Activated

*Vertical Sync - Adaptive (half refresh rate)

*Virtual Reality pre-rendered frames - 1

*Maximum pre-rendered frames - 4

*Triple Buffering - Activated

***SCREEN PARAMETERS***

*Screen Resolution = 1680*1050 (iiyama prolite 27" 16:10)

*Refresh Rate = 60hz

 

***GAME OPTIONS***

*Sound - ON

*Music - ON

*Display Size - Desktop

*Vertical Synchronization - OFF

*3D Model Quality - Better

*3D textue Quality - Improved

*Antialias/Multisample - OFF

*High Priority Process - ON

*Language - XXXXXX

******************************

Tell me how it works for you ;)

 

 

 

 

 

Edited by Worghern

Share this post


Link to post
Share on other sites

I've installed this mod today and taken a good look at it. Excellent work, but like I thought at first glance: too sharp and crispy for me. But very impressive job, Worghern. I'm sure it will be a huge succes. Vive le difference and nice to see another great mod artist is among us.

Share this post


Link to post
Share on other sites

Worghern's Re-shaders seems to result in my screen gradually becoming opaque with gritty whiteout when I load the game, and when I press GO during a game. 

So, I removed the Re-shader mod, and restarted my computer.  However, even without this mod in the Z folder, I see the text message saying that Re-shader 1.1 has loaded.  :(

As soon as I see the text message, the screen (not the menu itself) slowly starts going whitish-pink "snow".  It disappears once I select a scenario.  But, it starts again when I press GO after completing a turn.  The screen slowly goes a granular pinkish-white while processing takes place.  But, when the movie starts the problem disappears and the screen  looks fine.

Thinking there was a mod incompatibility, I removed my entire MODS folder to my Desktop.  But when I restarted the game, I still get the text message that Re-shader1.1 is installed, and the problem still exists.  When I press SCROLL LOCK to disable Re-shader, I don't get the whiteout effect.  But, the Re-shader is still clearly still installing from someplace.

Does the Re-shader mod install to some other place than the Z/Mod folder as well, so I need to hunt it down and remove? 

 

Edited by Erwin

Share this post


Link to post
Share on other sites

Once in the intro menu, scroll-lock to deactivate the RESHADE filter. Once in game, scroll-lock to activate it again. It seems you have not completely delete the RESHADE filter from your FB game.

 

"Sweetfx" folder

"Opengl32.dll" file

"Opengl32.log" text file

"Reshade.fx" file

"Sweet.fx"

 

Share this post


Link to post
Share on other sites

Yes, I just remembered that I need to remove the files from the root directory as well.  Duh...

I love the visual effect of your mod, so will try it again with different NVidia settings.

Share this post


Link to post
Share on other sites

Even without the Shader thingy, I think Worg's textures are a game changer. Man, previously I couldn't enjoy the game without a gridded terrain texture but now Environment 2.0 improve so much the immersive factor, for me, that I actually spend so much time wandering around at ground level that it can count as a recce patrol. I even disable the icons the first time I watch the replay phase just the enjoy the postcard animating itself before my eyes.

Get Worg's terrain, Aris' vehicles textures and Waclaw's sounds and you are there, on the battlefield among your men, not anymore sitting on your armchair.

Now, what I think may be just great would be to get an easy plug and play solution, an all in one download so one don't spend half an afternoon, finding, downloading and installing all these marvels. Especially those who ain't that much of a techy. Going a bit further, one could imagine a centralized repository where modders could drop their mods and update it while end users would simply synchronise their mod folder from time to time to enjoy the goodies. That's the way things are done on ArmA and some flight sim for example to manage multiplayer mod packs.

 

(Sorry for that digression Worghern)

Edited by CMFDR

Share this post


Link to post
Share on other sites
On ‎5‎/‎5‎/‎2016 at 4:17 AM, CMFDR said:

Nervermind, somehow I didn't get that Reshade file when I downloaded them all yesterday.

@Erwin these files must be directly in your root folder afaik 

a0594426179fe760242cf94e2f5d6c81.png

*********************************************

I've updated files on the mirror :

http://superdupontzeserveur.fr/cm/worghern/WorghernFinalBlitzkriegBeta.7z.001 (495 Mb)

http://superdupontzeserveur.fr/cm/worghern/WorghernFinalBlitzkriegBeta.7z.002 (495 Mb)

http://superdupontzeserveur.fr/cm/worghern/WorghernFinalBlitzkriegBeta.7z.003 (65 Mb)

It does include conveniently named folders, with Reshade and patch embedded, and is especially trimmed to fit on CMMods III (your call Bootie)

1ce8c2690980e91da49cd82c52800ac9.png 

Am doing a complete reinstall.  Are the above 3 downloads the latest files and everything I need? 

Also, where do I get your version of zip?   Has anyone else used it and can confirm it's safe.  (Can't figure out the advantage of using these obscure forms of zip which are not universally used.)

Thank you...

Edited by Erwin

Share this post


Link to post
Share on other sites
On ‎14‎/‎01‎/‎2018 at 4:02 AM, BornGinger said:

No updates to this mod for more than a year. So I guess the beta version became the finished version.

Whatever version was last released is probably the 'finished' version - Worghern hasn't been here since September 2016.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×