Jump to content
GhostRider3/3

wont install properly I think?

Recommended Posts

So I got a new computer, Installed Black Sea, and Red Thunder with no issues.  I deleted all of my games off the old computer.  Today I went to Install CMBN and it seems to install fine until you try and run the game, then I get this error message that reads;

"Not able to run with current UI, make sure you have the proper UI files."  I am guessing it means User interface.. but not so sure.

 

Thanks for any help.  Would like to get the entire bit of the Combat mission series loaded.

 

J.

 

Share this post


Link to post
Share on other sites

I'm not sure, but I seem to remember that this happened to me too a while ago, and the problem was that I had installed an old version. Have you bought the 3.0 upgrade? If so, did you download and use the latest installer, or were you using an old installer?

Share this post


Link to post
Share on other sites
1 hour ago, JSj said:

I'm not sure, but I seem to remember that this happened to me too a while ago, and the problem was that I had installed an old version. Have you bought the 3.0 upgrade? If so, did you download and use the latest installer, or were you using an old installer?

Well call me not that computer savvy.  But would it matter?  Why would it not play from the installed disk.. the game does no have to be connected to the internet.  So why would you not be able to just load the game on your cpu and play it without the upgrades.  I have my original CMBN disk, the Commonwealth Disk, I simply tried installing the game to play it vanilla.. would not work obviously.  My guess is that I may need to pick a different path when installing the game so its not confused with my Black Sea, or Red Thunder.. as they are both 3.0 maybe.  I don't know.

Share this post


Link to post
Share on other sites

I agree, you should be able to just install and run an older version. I just remember that I had some problems trying to install the game from an old installer. (This was a while ago, so I don't remember if the error messages were the same as what you are getting.) I solved this by downloading the latest installer (I had already bought the 3.0 upgrade, I was just trying to use the old installer, and I though that I then just needed to download a patch, not the whole installer again, but this did not work for me).

Hopefully, someone that knows more about the details than me will help you. If not, I think that you can get help by opening a support ticket, somewhere on the battlefront.com website. And, if you are planning on playing CMBN again, I would really recommend that you upgrade to 3.0, as there are many improvements that you will otherwise miss out on.

Edited by JSj

Share this post


Link to post
Share on other sites
21 minutes ago, JSj said:

I agree, you should be able to just install and run an older version. I just remember that I had some problems trying to install the game from an old installer. (This was a while ago, so I don't remember if the error messages were the same as what you are getting.) I solved this by downloading the latest installer (I had already bought the 3.0 upgrade, I was just trying to use the old installer, and I though that I then just needed to download a patch, not the whole installer again, but this did not work for me).

Hopefully, someone that knows more about the details than me will help you. If not, I think that you can get help by opening a support ticket, somewhere on the battlefront.com website. And, if you are planning on playing CMBN again, I would really recommend that you upgrade to 3.0, as there are many improvements that you will otherwise miss out on.

I have everything.. CMBN, Commonwealth, Market Garden ,Vehicle Pack which was version 3.11  Anyways still makes no sense that you cant play a older version. the only thing that changed was my computer.. and windows 10.  That being said, Red Thunder Plays just fine, and so does Black Sea.  I will check Anti virus, or something else. .or bloody hell check internet of the error message to see what it means... all the Devs maybe for this game are sleeping, or this module is too old and no one really cares because of Blitzkrieg... which I ordered. :)

Share this post


Link to post
Share on other sites

So you can declare it to makes no sense but CMBN 1.x (not sure about 2.x) will not run under Windows 10.  Reality always wins and with computers reality can be totally confusing :D

Share this post


Link to post
Share on other sites

The CMBN 1.x versions do not work with Windows 10 due to an incompatibility with the copy-protection system used for that version and Windows 10. I don't know the exact details of why it is incompatible and what specifically that Windows 10 is doing that causes such a problem. The copy-protection system was updated by the DRM vendor before the Windows 10 release (and even before the Windows 10 public beta) and Battlefront used that updated version starting with either version 2.0 or 3.0.

Share this post


Link to post
Share on other sites

×
×
  • Create New...